Joined: 12 May 2004
|Posted: Thu Jul 31, 2008 9:26 pm Post subject: [ GLSA 200807-15 ] Pan: User-assisted execution of arbitrary
|Gentoo Linux Security Advisory
Title: Pan: User-assisted execution of arbitrary code (GLSA 200807-15)
Date: July 31, 2008
A buffer overflow vulnerability in Pan may allow remote attacker to execute arbitrary code.
Pan is a newsreader for the GNOME desktop.
Vulnerable: < 0.132-r3
Unaffected: >= 0.132-r3
Unaffected: >= 0.14.2.91-r2 < 0.14.2.92
Unaffected: = 0.14.2
Architectures: All supported architectures
Pavel Polischouk reported a boundary error in the PartsBatch class when processing .nzb files.
A remote attacker could entice a user to open a specially crafted .nzb file, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
There is no known workaround at this time.
All Pan users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=net-nntp/pan-0.132-r3"
Last edited by GLSA on Mon Feb 09, 2009 4:18 am; edited 2 times in total