Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Portage] Impossible de faire un emerge portage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
29fredz
n00b
n00b


Joined: 31 Jul 2008
Posts: 4

PostPosted: Thu Jul 31, 2008 9:56 am    Post subject: [Portage] Impossible de faire un emerge portage Reply with quote

Bonjour,

Suite à une demande, de la part de notre hebergeur web, de mise-à-jour du systême d'exploitation de notre serveur dédié sous Gentoo afin de prévenir la "faille dans les serveurs DNS qui a été récemment découverte", j'essaye, en vain, de mettre à jour ce système ...

J'ai tout d'abbord commencé, comme l'indique la doc de ce site, par une "Mise à jour de l'arbre Portage" par la commande emerge --sync.

A la suite de cela, emerge ne fonctionnait plus et me mettait constament :
Code:
!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        This profile is deprecated. Please update to 2007.0 or 2008.0 using eselect profile.

j'ai donc modifié le profil pour passer en 2007.0 (j'étais à la base en 2006.0).

j'ai recommencé une mise à jour de l'arbre portage, et j'ai modifié un fichier de conf comme demandé à la fin de cette installation...

Un autre message apparaissait à la fin de cette mise-à-jour disant :
Code:
 * An update to portage is available. It is _highly_ recommended
 * that you update portage now, before any other packages are updated.
 * Please do so and then update ALL of your configuration files.

j'ai donc essayé de faire un emerge portage pour avoir le résultat suivant :
Code:
Calculating dependencies ...done!

!!! Error: the <sys-apps/portage-2.1.4_rc1 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

j'ai alors fait un emerge --pretend portage et :
Code:
These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <sys-apps/portage-2.1.4_rc1 (is blocking app-shells/bash-3.2_p33)

[blocks B     ] <sys-apps/util-linux-2.13 (is blocking sys-apps/coreutils-6.10-r2)
[ebuild     U ] sys-apps/sandbox-1.2.18.1-r2 [1.2.17]
[ebuild     U ] app-misc/pax-utils-0.1.17 [0.1.11-r1]
[ebuild     U ] app-shells/bash-3.2_p33 [3.1_p16]
[ebuild     U ] sys-apps/portage-2.1.4.4 [2.0.54-r2]
[color=red]*** Portage will stop merging at this point and reload itself,
    then resume the merge.[/color]
[ebuild     U ] sys-devel/automake-wrapper-3-r1 [1-r1]
[ebuild     U ] sys-devel/autoconf-wrapper-4-r3 [3-r1]
[ebuild  N    ] app-arch/lzma-utils-4.32.6
[ebuild     U ] sys-devel/m4-1.4.11 [1.4.4]
[ebuild     U ] sys-devel/autoconf-2.61-r2 [2.59-r7]
[ebuild  NS   ] sys-devel/automake-1.10.1
[ebuild  N    ] sys-apps/attr-2.4.39
[ebuild  N    ] sys-apps/acl-2.2.45
[ebuild     U ] sys-devel/gettext-0.17 [0.14.4]
[ebuild  N    ] sys-apps/coreutils-6.10-r2
[ebuild  N    ] dev-python/pycrypto-2.0.1-r6


Suite à certaines réponses à des questions similaires trouvées sur le net, j'ai essayé, en vain, de supprimer les packages qui provquaient un blocage, à savoir :
Code:
emerge --unmerge coreutils
emerge --unmerge bash
emerge --unmerge portage

rien de tout cela n'a fonctionné, emerge portage me donne toujours la même erreur ...

Cela fait maintenant 4 heures que je batailles pour mettre à jour ce système, et-ce que quelqu'un pourrait me venir en aide ?!

Merci par avance


Last edited by 29fredz on Thu Jul 31, 2008 1:46 pm; edited 3 times in total
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Thu Jul 31, 2008 12:48 pm    Post subject: Re: Impossible de faire un emerge portage Reply with quote

29fredz wrote:
Bonjour,

Suite à une demande, de la part de notre hebergeur web, de mise-à-jour du systême d'exploitation de notre serveur dédié sous Gentoo afin de prévenir la "faille dans les serveurs DNS qui a été récemment découverte", j'essaye, en vain, de mettre à jour ce système ...

J'ai tout d'abbord commencé, comme l'indique la doc de ce site, par une "Mise à jour de l'arbre Portage" par la commande emerge --sync.

A la suite de cela, emerge ne fonctionnait plus et me mettait constament :
Code:
!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        This profile is deprecated. Please update to 2007.0 or 2008.0 using eselect profile.

j'ai donc modifié le profil pour passer en 2007.0 (j'étais à la base en 2006.0).

j'ai recommencé une mise à jour de l'arbre portage, et j'ai modifié un fichier de conf comme demandé à la fin de cette installation...

Un autre message apparaissait à la fin de cette mise-à-jour disant :
Code:
 * An update to portage is available. It is _highly_ recommended
 * that you update portage now, before any other packages are updated.
 * Please do so and then update ALL of your configuration files.

j'ai donc essayé de faire un emerge portage pour avoir le résultat suivant :
Code:
Calculating dependencies ...done!

!!! Error: the <sys-apps/portage-2.1.4_rc1 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

j'ai alors fait un emerge --pretend portage et :
Code:
These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] sys-apps/portage-2.1.4_rc1 (is blocking app-shells/bash-3.2_p33)

[blocks B     ] <sys-apps/util-linux-2.13 (is blocking sys-apps/coreutils-6.10-r2)
[ebuild     U ] sys-apps/sandbox-1.2.18.1-r2 [1.2.17]
[ebuild     U ] app-misc/pax-utils-0.1.17 [0.1.11-r1]
[ebuild     U ] app-shells/bash-3.2_p33 [3.1_p16]
[ebuild     U ] sys-apps/portage-2.1.4.4 [2.0.54-r2]
[color=red]*** Portage will stop merging at this point and reload itself,
    then resume the merge.[/color]
[ebuild     U ] sys-devel/automake-wrapper-3-r1 [1-r1]
[ebuild     U ] sys-devel/autoconf-wrapper-4-r3 [3-r1]
[ebuild  N    ] app-arch/lzma-utils-4.32.6
[ebuild     U ] sys-devel/m4-1.4.11 [1.4.4]
[ebuild     U ] sys-devel/autoconf-2.61-r2 [2.59-r7]
[ebuild  NS   ] sys-devel/automake-1.10.1
[ebuild  N    ] sys-apps/attr-2.4.39
[ebuild  N    ] sys-apps/acl-2.2.45
[ebuild     U ] sys-devel/gettext-0.17 [0.14.4]
[ebuild  N    ] sys-apps/coreutils-6.10-r2
[ebuild  N    ] dev-python/pycrypto-2.0.1-r6


Suite à certaines réponses à des questions similaires trouvées sur le net, j'ai essayé, en vain, de supprimer les packages qui provquaient un blocage, à savoir :
Code:
emerge --unmerge coreutils
emerge --unmerge bash
emerge --unmerge portage

rien de tout cela n'a fonctionné, emerge portage me donne toujours la même erreur ...

Cela fait maintenant 4 heures que je batailles pour mettre à jour ce système, et-ce que quelqu'un pourrait me venir en aide ?!

Merci par avance

Bonjour,

Perdu... Desinstaller le package manager ainsi que l'interpreteur de ligne de commande est a mon sens une tres mauvaise idee... D'ailleurs si tu as fait:
Code:
emerge --unmerge portage
tu ne dois plus etre capable de faire
Code:
emerge portage
(l'erreur devrait alors etre un truc du genre Unknown commande emerge...)

Du coup, j'emet des doutes sur la sortie de emerge dans l'etat actuel. Peut etre pourrais tu mettre une version 'updatee' afin que nous puissions distinguer qui bloque qui.

PS1: Si tu as vraiment supprimer bash, evite de te rebooter ton serveur...
PS2: Peux tu mettre ton titre en conformite (cf topic 'Comment poster tout en haut du forum fr)
Back to top
View user's profile Send private message
29fredz
n00b
n00b


Joined: 31 Jul 2008
Posts: 4

PostPosted: Thu Jul 31, 2008 1:29 pm    Post subject: Reply with quote

re-Bonjour,

désolé pour le sujet, je viens de corriger ça ...

Pour ce qui est des "emerge --unmerge", quand je dis que "ça n'a pas fonctionné", je veux dire que les unmerge ont échoué :
!!! FAILED prerm: None
en fin de résultat des unmerge (en tout cas pour portage, j'ai encore le résultat sous les yeux).

Le résultat ACTUEL de "emerge --prevent portage" est celui copié dans mon précédent message (je suppose donc que bash et coreutils n'ont pas été désinstallés correctement eux non plus vu qu'ils sont toujours en conflit avec portage).

Si quelqu'un a une idée, je suis vraiment preneur
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jul 31, 2008 2:13 pm    Post subject: Re: [Portage] Impossible de faire un emerge portage Reply with quote

29fredz wrote:
Calculating dependencies ...done!
[blocks B ] <sys-apps/portage-2.1.4_rc1 (is blocking app-shells/bash-3.2_p33)

Cela signifie que ta version actuelle de portage bloque la mise à jour vers bash-3.2_p33
Il faudrait donc upgrader portage mais ... c'est justement ce que tu essaies de faire ... :? :!:
La solution :
- masquer temporairement les versions de bash supérieures à celle qui est installée pour l'instant
- emerge portage (va donc faire sauter le blocage ! :cool:)
- annuler le masquage de bash de la 1ère étape
- emerge bash

Quote:
[blocks B ] <sys-apps/util-linux-2.13 (is blocking sys-apps/coreutils-6.10-r2)

Une version de util-linux inférieure à 2.13 bloque la mise à jour de coreutils vers 6.10-r2
Là, ça devrait être plus simple :
- emerge util-linux (upgrade pour faire sauter le blocage)
- emerge coreutils
Back to top
View user's profile Send private message
29fredz
n00b
n00b


Joined: 31 Jul 2008
Posts: 4

PostPosted: Thu Jul 31, 2008 2:36 pm    Post subject: Reply with quote

Oups ! J'ai peut-être bien fait une grosse bêtise sur le bash ! :oops:

quand je fais un "ls" j'ai une réponse très étrange :
Code:
-bash: /usr/bin/ls: Aucun fichier ou répertoire de ce type


la suppression n'a pas du fonctionner entièrement mais elle a quand même posé problème apparement...

Y a t'il un moyen de corriger mes c*****ies ou je suis bon pour tout réinstaller ?

J'ai essayé également de mettre à jour util-linux (qui lui était bloqué par setarch...); j'ai donc essayé un "emerge setarch" et le résultat ne me dit rien de bon :
Code:
: ~ # emerge setarch
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/setarch-2.0 to /
Unable to run required binary.


Autre petite question (si jamais j'arrive à résoudre le problème de bash....), comment dois-je faire pour
Quote:
masquer temporairement les versions de bash supérieures à celle qui est installée pour l'instant
?

Merci
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jul 31, 2008 3:11 pm    Post subject: Reply with quote

29fredz wrote:
quand je fais un "ls" j'ai une réponse très étrange :
Code:
-bash: /usr/bin/ls: Aucun fichier ou répertoire de ce type

la commande ls est fournie par le package coreutils (et non par bash) et comme tu l'as désinstallé ...
Ca risque d'être assez coton vu que tu ne disposes plus d'aucune commande externe ! :(

Quote:
J'ai essayé également de mettre à jour util-linux (qui lui était bloqué par setarch...); j'ai donc essayé un "emerge setarch" et le résultat ne me dit rien de bon :
Code:
: ~ # emerge setarch
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/setarch-2.0 to /
Unable to run required binary.

Ca confirme mes craintes : emerge essaie probablement d'exécuter une commande externe (genre "cp" ou "mkdir") qui n'existe plus.
Si tu as installé busybox, il y a peut-être moyen de t'en sortir en créant un symlink vers toutes les commandes importantes.
Cela te permettrait de réinstaller coreutils ...

Quote:
Autre petite question (si jamais j'arrive à résoudre le problème de bash....), comment dois-je faire pour
Quote:
masquer temporairement les versions de bash supérieures à celle qui est installée pour l'instant
?

C'est le b-a-ba de gentoo ! (man portage ;))
Code:
echo ">app-shells/bash-ta_version" >> /etc/portage/package.mask
[EDIT] : les guillements fermants étaient mal placés :oops:


Last edited by ghoti on Thu Jul 31, 2008 4:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
29fredz
n00b
n00b


Joined: 31 Jul 2008
Posts: 4

PostPosted: Thu Jul 31, 2008 4:00 pm    Post subject: Reply with quote

Super !

Merci beaucoup pour ton idée, apparement j'ai bien busybox d'installé, par contre les liens ne fonctionnent pas ...
Code:
: bin # pwd
/usr/bin
: bin # busybox ln -s "busybox ls" ls
: bin # busybox ls -l ls
lrwxrwxrwx    1 root     root           10 Jul 31 17:54 ls -> busybox ls
: bin # ls
-bash: /usr/bin/ls: Aucun fichier ou répertoire de ce type


mais je vais créer des nouveaux scipts appelant busybox pour les fonctions les plus importantes ! (j'ai essayé avec un scipt pour ls, et ça fonctionne)

J'espère pouvoir me dépatouiller avec tout ça !

Encore merci !
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Thu Jul 31, 2008 6:58 pm    Post subject: Reply with quote

D'aprés la doc ça marche comme ça :
Code:
ln -s /bin/busybox ls
./ls


Voir là : http://www.busybox.net/downloads/BusyBox.html
_________________
Ez.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jul 31, 2008 7:50 pm    Post subject: Reply with quote

Ezka wrote:
D'aprés la doc ça marche comme ça :
Code:
ln -s /bin/busybox ls
./ls

Oui, sauf que coreutils est flingué et que, par conséquent, "ln" n'existe pas ... :(
Donc, ce serait plutôt qque-chose du genre :
Code:
busybox ln -s /bin/busybox /bin/ls
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum