Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[montage d'un disque] problème étrange (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
banane man
n00b
n00b


Joined: 27 Jul 2008
Posts: 3

PostPosted: Sun Jul 27, 2008 9:49 pm    Post subject: [montage d'un disque] problème étrange (résolu) Reply with quote

Bonjour,

suite à une réinstallation de ma Gentoo je suis face à un problème insoluble malgré de nombreuses recherches : impossible de monter un cd rom ou un dvd. J'ai passé en revue les options du noyau une bonne demi douzaine de fois. La ligne de mon fsta[/quote]b est la suivante :
Code:
/dev/hdb                /mnt/cdrom      auto            noauto,ro          0 0

(j'ai essayé avec la variante <type> : iso9660,udf)

Rien n'y fait : mes applications multimédia telles que k3b ne trouvent pas mon graveur et quand je tente de monter le dvd manuellement, mon système tout entier plante systématiquement.
Il est impossible que le problème soit matériel car avec ma partition Ubuntu tout fonctionne correctement.

Une idée ?


Last edited by banane man on Sun Jul 27, 2008 11:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Sun Jul 27, 2008 10:05 pm    Post subject: Reply with quote

Hello,
je ne sais pas si ça va t'aider à grand chose, mais dans mon fstab moi j'ai l'option "user":
Quote:

/dev/cdrom /mnt/cdrom auto noauto,ro,user 0 0

es-tu sur que ton graveur est bien "/dev/hdb" ?? (dmesg | grep hdb)
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
banane man
n00b
n00b


Joined: 27 Jul 2008
Posts: 3

PostPosted: Sun Jul 27, 2008 10:23 pm    Post subject: Reply with quote

Merci d'avoir répondu aussi rapidement.

L'ajout de l'option user ne résoud rien, par contre le lancement de la commande que tu me proposes me renvoie un message étrange :
Quote:

ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
hdb: ATAPI I DVD A DH20A4P, ATAPI CD/DVD-ROM drive
hdb: host max PIO5 wanted PIO255(auto-tune) selected PIO0
hdb: host max PIO5 wanted PIO255(auto-tune) selected PIO0
hdb: status error: status=0x58 { DriveReady SeekComplete DataRequest }
hdb: drive not ready for command


Les deux dernières lignes se répètent plusieurs fois. Qu'est-ce que ça veut dire ?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Jul 27, 2008 10:44 pm    Post subject: Reply with quote

T'utilises quoi comme drivers ATA ? La vieille pile IDE dépréciée ou la libata qui va bien ?
Si c'est le premier cas (à priori ça l'est, vu que t'as un hdb...), je te conseille de désactiver entièrement ce vieux support IDE (qui cause plein de conflits et autres problèmes divers, et qui disparaitra très bientôt de toute façon), et de mettre le nouveau support PATA/SATA à la place (libata toussa...). T'y sélectionnes ton chipset SATA (ou PATA si t'as plutôt de l'IDE), t'oublies pas à côté d'activer le support SCSI disk, SCSI cdrom et SCSI generic (ce dernier est nécessaire pour pouvoir graver), tu recompiles ton kernel et tu reboot dessus, tu devrais avoir un meilleur support de ton cdrom :)
Par contre attention, ton disque dur va se retrouver en sda si c'était pas déjà el cas jusque là, donc corrige ton fstab et ton grub.conf comme il faut. Et ton cdrom sera en sr0, mais ça ne te changera pas grand chose, ya toujours les symlink /dev/cdrom et tout :)
Back to top
View user's profile Send private message
banane man
n00b
n00b


Joined: 27 Jul 2008
Posts: 3

PostPosted: Sun Jul 27, 2008 11:08 pm    Post subject: Reply with quote

C'était en effet la solution, merci beaucoup ! Je me demandais aussi pourquoi mes périphériques n'étaient pas nommés sdX, maintenant j'ai compris ! je n'avais pas compris ce passage de la doc.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum