Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] Installazione gentoo 2008 su notebook ibm
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Sun Aug 03, 2008 4:20 pm    Post subject: Reply with quote

ti ringrazio veramente di tutto sei un grande. ora sto usando profuse per abilitare e disabilitare le use che mi servono e sto piano piano capendo meglio quello che dici in merito a globali e locali anche leggendo la documentazione italiana. se riesco a mettere tutto apposto e ad installare gentoo e se abiti vicino le mie parti ti offro una cena xD di dove sei tu?

EDIT: ecco fatto ho scelto le use che mi servono ora ho visto però che il kernel che è di default per la 2008.0 è il 2.6.25-r5 e il conf che ho trovato io per il mio ibm r61 è per un 2.6.24-r3 e l'eselect che mi avevate consigliato nn mi trova il comando. non ho ancora fatto l'emerge kernel-sources, l'eselect lo devo lanciare dopo aver fatto emerge kernel-sources?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Aug 04, 2008 5:29 pm    Post subject: Reply with quote

Code:
USE="symlink" emerge gentoo-sources
e non ti serve neppure eselect. Per riciclare una conf di un kernel precedente ti basta copiare il .config e lanciare make oldconfig (le opzioni deprecate vengono scartate in automatico e per quelle nuove ti viene chiesta conferma, oppure se usi genkernel lanci make mrproper in /usr/src/linux copi il .config e lo avvi con --noclean (ed aventualmente --menuconfig per rivedere meglio cosa hai combinato).

Quanto al di dove sono... è scritto chiaramente (si fa per dire) nelle mie signature ovvero a circa 80 km dalla bocca principale di un vulcano quiescente che circa 2000 anni fa ha pensato di fare l'ultimo vero disatro, per il quale è giustamente famoso in tutto il pianeta. Mi pare una informazione sufficiente. (altrimenti potrei dire che ero in classe con la nipote di una nota pornostar ma se faccio il nome è troppo facile) :twisted: Piuttosto completa tu le informazioni sul tuo profilo o presentati nell'apposito thread sul nickname od in quello sui nomi dei computer nella propria rete.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Mon Aug 04, 2008 6:17 pm    Post subject: Reply with quote

ah ok quindi posso anche mettere questo kernel 2.6.25-r7 e metterci lo stesso il config come hai detto tu. Ma il config lo devo mettere subito o posso aspettare a metterlo dopo il riavvio? perchè così mi regolo. a me avevano detto, sempre su questo topic, che dovevo cercare di creare una configurazione del kernel con genkernel che mi permetteva di far partire la macchina e poi usavo il config è così? ti ringrazio veramente di tutto se ho intuito bene anzi sono proprio sicuro che questo vulcano è il vesuvio quindi non siamo molto lontani. io sono di latina comunque provvederò a breve ad aggiornare il mio profilo e a presentarmi, e spero di farlo dalla mia gentoo xD ti ringrazio


EDIT: un'altro consiglio vorrei ricevere se puoi: se ho capito bene questa configurazione del kernel è una configurazione che ottimizza e adatta il piu possibile il kernel al mio portatile, però volevo sapere se è meglio a questo punto compilare il kernel manualmente (con un'apposita guida per questo portatile che indica le principali e indispensabili funzioni da attivare nel kernel per questo portatile) oppure provare a usare genkernel e dopo "il reboot" di fine installazione mettere il config e magari ricompilarlo li manualmente? non so se va bene usare prima genkernel e poi ricompilare a mano, potresti darmi un consiglio? ti ringrazio anticipatamente

EDIT: ho risolto per il kernel ho seguito quella guida e poi successivamente al riavvio provo a metterci quel config. comunque installando syslog-ng sono incappato in un'errore di dipendenze circolari e l'emerge mi consiglia di disabilitare quelle che "rompono" ma come faccio a vedere quali sono in conflitto?
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Tue Aug 05, 2008 1:11 am    Post subject: Reply with quote

mmm, output? io di solito in caso di dipendenze circolari, se non ho voglia di sbatterci troppo la testa vado di USE="-*" emerge quellochemiserve, poi una volta installato vado a rivedere se ci sono ancora. le dipendenze circolari sono una rogna.
al massimo prova con un USE="-X -gtk -gtk2 -gnome" o qualcosa del genere, di solito sono quelle che rompono.
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Tue Aug 05, 2008 1:42 am    Post subject: Reply with quote

grazie ma ho risolto non installando quel demone xD l'installazione comunque è andata a buon fine ora magari è un pò tardi per smanettarci ma domani farò un pò di conti con l'ottimizzazione e allora prenderò qua e la i vostri consigli vi ringrazio di tutto ragazzi siete mitici!!! un ringraziamento particolare va al djinnZ che mi ha sorbito per tutta la mia installazione :)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Aug 05, 2008 5:22 pm    Post subject: Reply with quote

Ic3M4n è una scimmia (dal logo di gnome) quindi ti ha indicato le possibili cause di dipendenze circolari che affliggono gli gnomi. Le lucertole (dal logo di kde) hanno il medesimo problema con X, gtk, odbc ed ovviamente qt* e kde (che sono le librerie che contraddistinguono la loro forma di masochismo) quindi nel tuo caso la riga giusta è "-X -gtk -qt3 -qt3 -qt3support -kde -odbc".
Ovviamente compilare con USE="-*" le dipendenze in conflitto risolve sempre i problemi, alla fine va a finire che perdi una giornata a ricompilare più volte i massimi mattoni (xulrunner/firefox, qt, gtk, glib e wxgtk sono tra i pacchetti più corposi e guarda caso sono sempre loro a dare fastidio).

Onestamente tra il configurare il kernel a puntino per il primo riavvio o fermarsi al solo supporto per nic e controller... non ho idea di quale possa essere la soluzione migliore, alla fine il risultato è identico. Tanto se un pacchetto ha bisogno che sia attivata o disattivata qualche opzione specifica te lo dice nel messaggio d'errore in genere.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Tue Aug 05, 2008 6:33 pm    Post subject: Reply with quote

mmm, logicamente -qt3 -qt4 e simili sono già in make.conf di default ;)
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Tue Aug 05, 2008 7:03 pm    Post subject: Reply with quote

we ragazzi ho installato tutto per bene e updatato anche il portage con i vari emerge -e system, emerge -e world ecc e va tutto ok solo che ho un problemino con la scheda wireless: ho una guida per avviarla e precisamente mi dice di avviare questi comandi:
Code:
echo net-wireless/iwlwifi >> /etc/portage/package.unmask
echo net-wireless/iwlwifi ~x86 >> /etc/portage/package.keywords/my.keywords
echo net-wireless/ipw3945-ucode ~x86 >> /etc/portage/package.keywords/my.keywords
echo net-wireless/iwlwifi ipw3945 >> /etc/portage/package.use
emerge iwlwifi wpa_supplicant


però non riesco proprio a capire una cosa: i file package.unmask, la cartella package keywords, e il file my.keywords non esistono! djinnZ mi aveva detto che per esempio il package.use era un file che dovevo creare io e che non esisteva, anche gli altri che ho nominato sono file da creare? perchè non li trovo da nessuna parte e se emergo il wilwifi mi dice di "maskare" tramite il file package.mask che sta da ttta un'altra parte. cosa faccio?

EDIT: altra cosa per installare kde mi basta fare emerge kde e configurare l'xorg e sto apposto o devo mettere anche il kde-meta come mi consigliava djinnZ? e mentre installo mi dice sempre che ci sono piu di 18 file config in /etc che necessitano di update. ho cercato su internet ma non c'è scritto da nessuna parte e nemmeno il man mi ha aiutato molto, cosa posso fare? vi ringrazio anticipatamente ragazzi
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Aug 05, 2008 7:43 pm    Post subject: Reply with quote

se hai installato correttamente il portage ti è stata creata solo la cartella /etc/portage i vari file package.qualcosa (o le cartelle) li devi creare tutti manualmente. Il package.mask di cui si parla negli howto è sempre un file da creare in /etc/portage quello che dici tu fa parte del profilo e potresti anche modificarlo ma verrebbe riscritto al prossimo emerge --sync.

kde.meta è il kde suddiviso in singoli sottopacchetti kde e basta è il kde monolitico. Per esempio kdegames comprende il solitario, il burger king (me lo ricordo perchè è stato il primo videogame omaggio della prima console che abbiamo avuto a casa, roba pre-C64, mamma quanto sono vecchio) il mahjonng e non ricordo quali altri. Se installi kdegames te li becchi tutti e per aggiornarne uno devi ricompilare il pacchetto completo, se installi kdegames-meta emerge non fa altro che procedere all'installazione dei singoli giochi. Il rovescio della medaglia è che emerge esegue tante volte quanti sono i sottopacchetti l'automake e ci mette molto più tempo ad installare tutto. Però se per esempio non vuoi ritrovarti kdebluetooth ed il manager per le connessioni installato a forza insieme a kdenetwork devi per forza usare kde-meta.
Sarebbe bello poter mescolare le due alternative (per esempio installare kdebase "normale" e non meta ed usare i meta per i rimanenti pacchetti ma i devel, bontà loro, hanno deciso di no per una serie di problemi nel gestire le dipendenze incrociate) ma non si può.
Il futuro kde4 dovrebbe vedere la sua versione meta chissà quando ma il primo problema è quando diventerà stabile.
Quindi ti consiglio di lanciare emerge kde-meta configurare xorg e poi vedere cosa vuoi togliere perchè ti da fastidio.

@Ic3M4n vedi che se togli solo il -qt4 (per esempio per installare k3b) non disabiliti qt3compat automatica che si porterà dietro le qt3 che a loro volta hanno il problema della dipendenza circolare con odbc (basta che libodbc sia installata, use o non use) e senza il -arts -kde ti becchi mezzo kde in compilazione (le stesse identiche bestemmie ci sono dall'altra parte se abiliti mono senza -gnome -esd e non ricordo quali altre esplicite in make .conf)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Tue Aug 05, 2008 7:58 pm    Post subject: Reply with quote

okok comunque ho appena fatto l'emerge xorg-x11 e mi si è bloccato al penultimo pacchetto dicendo una cosa tipo:
Code:
 x11-base/xorg-server-1.3.0.0-r6 ebuild.sh, line 49: called pkg_setup; xorg-ecc ecc.ebuild, line 342: called die. the specific snippet of code: use nptl && die "$[diemsg]"
the die message: you must build xorg-server and mesa with the same nptl USE setting


non so dove mettere mano sapete aiutarmi?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Aug 05, 2008 9:01 pm    Post subject: Reply with quote

Avrai compilato mesa con use nptl ed nptlonly (verifica che le abbia scritte bene) e xorg senza o viceversa. Con emerge -pv mesa vedi quali use sono state usate per mesa. DOvrebbe bastarti un emerge -Ndu world per rimettere a posto od un emerge -1N mesa
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Tue Aug 05, 2008 11:24 pm    Post subject: Reply with quote

grazie ho risolto! cè ma sei un grande hai la mappa delle dipendenze possibili in testa è da nn crederci xD cmq che mi dici dei conf che mi dice sempre ad ogni installazione che sono da aggiornare? mi dice di vedere il man del portage ma li sopra non ho trovato nulla in merito all'aggiornamento dei file .conf di /etc o anche dei file .conf in generale. so che si deve usare l'emerge ma non so cosa, un -sync aggiorna solo il portage e nn penso tocchi i file di configurazione giusto?

EDIT: e poi non capisco per quale caspio di motivo se metto dei moduli aggiuntivi del kernel non me li riesce a loaddare mai all'avvio. li metto in /etc/modules.autoload.d/kernl-version e all'avvio mi dice failed to load e il nome del modulo, e per l'installazione della scheda wifi con il driver iwlwifi nell'installazione che vi dicevo ora mi dice che non è valido il link di /usr/src/linux symlink che è quello del kernel. Ho controllato ma è tutto ok non so cosa sia proprio-_- mi affido alla vostra clemenza ragazzi
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Aug 06, 2008 10:19 am    Post subject: Reply with quote

GoraNz wrote:
hai la mappa delle dipendenze possibili in testa è da nn crederci
ho appena finito di ricompilare il sistema mio (per averlo cancellato, che siano sempre maledetti tutti i bastardi, parassiti sociali molesti e dannosi, di tutti i comitati di standardizzazione ed in particolare i discendenti d'indeterminabile paternità delle espressioni regolari e dei mach di shell, riaccidenti, doppio e triplo accidenti) ovvio che le conosca tutte, ho appena finito le bestemmie mentre scrivo...

Molto graziosamente quando emerge installa dei file in /etc ed altre directory (gestite dalla variabile CONF_PROTECT in make.conf, da non toccare se non sai esattamente quel che fai) invece di sovrascriverli ne crea una copia come file nascosto di modo che tu possa pensare di armonizzare le eventuali nuove voci dei file di configurazione con le tue scelte di personalizzazione.
I comandi sono etc-update o dispach-conf (il secondo è più recente ed ha qualche funzione in più) oppure puoi installare cfg-update o conf-update che sono meno essenziali. Allo stato attuale non dovresti ancora aver personalizzato nulla quindi puoi permetterti di sovrascrivere brutalmente tutti i file di configurazione, in futuro devi fare molta attenzione, in particolare se tocchi pam o inittab.

Per il kernel hai usato genkernel o il metodo manuale?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Wed Aug 06, 2008 12:45 pm    Post subject: Reply with quote

ah okok ho capito appena risolvo quest'altro problemino vedo un pò di aggiornarli. emergendo il kde-meta ecco l'errore:
Code:
ebuild.sh, line   49: called src_compile
environment, line 4221 : called kde-meta_src_compile
environment, line 2890: called kde_src_compile
environment, line 3055: called kde_src_compile 'src_compile'
environment, line 3175: called kde_src_compile 'src_compile' 'all' 'myconf'

the specific snippet of code
                              emake || die "died running emake, $FUNCNAME:make"
the die message:
           died running emake, kde_src_compile:make


prima mi aveva dato un'errore del ghost script dicendomi di riemergerlo con USE="X" ma ora non so prpr cosa fare-_- ti ringrazio cmq come sempre per la disponibilità

P.S.: comunque alla fine ho usato la configurazione manuale per il kernel perchè volevo un pò imparare a compilarlo da solo :)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Aug 06, 2008 4:51 pm    Post subject: Reply with quote

Punto primo: hai installato X cups samba ghostscript e gtk? se si lancia un emerge -NDuv world e metti a posto le dipendenze ricompilandoli con le use di cui hanno bisogno.
A questo punto e dopo aver aggiornato i file di configurazione lanci emerge kde-meta e dovrebbe funzionare tutto. Da quello che hai riportato non si capisce quale è il pacchetto che non ti è riuscito di compilare (è un paio di righe più sotto) e tantomeno l'errore (è qualche riga più sopra), diciamo che ti è riuscito di riportare la parte più inutile del messaggio di errore :lol:, sei scusato solo perchè sei alla prima installazione.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Wed Aug 06, 2008 6:13 pm    Post subject: Reply with quote

oddio scusami pensavo di aver riportato la parte piu importante :( che culo comunque che ho eh proprio quello che non serviva xD cmq adesso ho appena lanciato l'emerge -NDuv world e sta mettendo tutto apposto ti ringrazio. ma il cups e il gtk sono compresi nell'installazione del system e del world o no? perchè il cups credo sia gia stato installato ma il gtk non credo ammeno che non sia contenuto nel pacchetto x11 o nel kde.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Aug 06, 2008 9:19 pm    Post subject: Reply with quote

Se rileggi quello che ho scritto ti ho detto chiaramente che, con le impostazioni predefinite del profilo desktop (ovvero USE="X gtk gnome esd kde arts samba qt3support ...") cups implica l'installazione di samba(per via della use flag samba) e di ghostscript (che gli serve per forza) che a sua volta implica l'installazione del gtk (per la use omonima) e di xorg (per la use X) mentre xorg implica l'installazione di cups.
Quindi volendo usare kde la cosa più semplice da fare dopo aver solo estratto lo stage3, impostato le cflag e le opzioni base (tra cui aggiungere -gnome e -esd in make.conf sys-devel/gcc -gtk -fortran -jce" in /etc/portage/package.profile, modificato opportunamente locales.gen etc), è lanciare direttamente la sequenza
Code:
emerge --sync ; emerge -e system
emerge -FDNu cups kde-meta samba ghostscript-esp ufed profuse euses gentoolkit ...
USE="-*" emerge -1 ghostscript-esp ufed/profuse euses unixODBC
USE="-cups -kde -samba -X -odbc" emerge -1 xorg-server cups samba gentoo-sources syslog-ng logrotate vixie-cron  xfstools 
emerge --with-bdeps y -DNu world ; genkernel --menuconfig
emerge -DNu kde-meta iptables gentoolkit genkernel module-rebuild ; revdep-rebuild -X
ed andarsene a dormire. A meno che non hai usato cflags problematiche o l'hardening al 99% il giorno seguente dovresti avere a tue disposizione un sistema base su cui ti basta rifinire il kernel ed installare il bootloader per partire. Almeno questo è quello che ho fatto (più o meno, diverso profilo e diversi pacchetti, per esempio solo kdebase-meta e kdemultimedia-meta, il resto lo ho messo per singoli pacchetti) qualche giorno fa.

Quanto al kernel, se opportunamente configurato, genkernel fa solo quello che gli dici di fare e fondamentalmente ti scampa dal lavoro meccanico del copiare l'immagine, lanciare il depmod, etc.
Personalmente trovo più utile concentrarmi sulla configurazione del kernel che sul ripetere sempre gli stessi comandi quindi mi basta lanciare genekernel kernel ; module-rebuild rebuild ; lilo (se hai grub installa l'immagine in automatico) e giocare con le opzioni del menu di configurazione del kernel che mi spunta fuori. Il consiglio di usarlo te lo do ma quanto al come usarlo e come configurarlo è una tua scelta e mi pare che il file di configurazione sia abbondantemente commentato e chiaro
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Wed Aug 06, 2008 11:03 pm    Post subject: Reply with quote

mi servirà sicuramente per la prossima installazione per fare una cosa breve e funzionale ma visto che comunque questi pacchetti mi servono mi toccherà emergerli uno per volta ma non c'è problema non dico che amo quando mi scrive "emerging packet 1 of 280" però diciamo che per una persona che dopo mille tentativi su altri pc vede per la prima volta installato sul SUO pc gentoo, questi messaggi hanno il loro fascino :lol:

quanto al kde-meta ho fatto come dicevi tu aggiornato i file etc, lanciato l'emerge -NDuv world e poi resumato il kde-meta ma mi da piu o meno lo stesso errore con un'altro pacchetto. te lo rincollo tutto così nn mi sbaglio:
Code:
Please attach the following file when seeking support:
/var/tmp/portage/kde-base/kopete-3.5.9/work/kopete.3.5.9/config.log

ERROR: kde-base/kopete-3.5.9 failed.
call stack:
               ebuild.sh, line   49: called src_compile
environment, line 4234: called kde_src_compile
environment, line 3052: called kde_src_compile 'src_compile'
environment, line 3172: called kde_src_compile 'src_compile' 'all' 'myconf'
environment, line 3159: called econf 'configure' 'make' '--disable-jingle' '--disable-sametime-plugin' '--without-xmms' --without-external-libgadu' '--without-xscreensaver' '--disable-smsgsm' '--disable-testbed' '--with-x' '--enable-mitshm' --without-xinerama' '--with-qt-dir=/usr/qt/3' '--enable-mt' '--with-qt-libraries=/usr/qt/3/lib' '--disable-dependency-tracking' '--disable-debug' '--without-debug' '--disable-final' '--without-arts' '--prefix=/usr/kde/3.5' '--mandir=/usr/kde/3.5/share/man' '--infodir=/usr/kde/3.5/share/info'
ebuild.sh, line 513: called die
the specific snippet of code:
                                 die "econf failed"
the die message:
econf failed

the ebuild environment file is located at ' /var/tmp/portage/kde-base/kopete-3.5.9/temp/environment


ecco qui tutto l'errore. spero almeno stavolta di aver incollato bene xD ti ringrazio anticipatamente


EDIT: per chi avesse letto l'altro errore che ho riportato poco fa sulle configurazioni errate ho risolto gia :)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Aug 07, 2008 4:34 pm    Post subject: Reply with quote

GoraNz wrote:
te lo rincollo tutto così nn mi sbaglio:
Code:
Please attach the following file when seeking support:
/var/tmp/portage/kde-base/kopete-3.5.9/work/kopete.3.5.9/config.log

ERROR: kde-base/kopete-3.5.9 failed.
call stack:
               ebuild.sh, line   49: called src_compile
environment, line 4234: called kde_src_compile
environment, line 3052: called kde_src_compile 'src_compile'
environment, line 3172: called kde_src_compile 'src_compile' 'all' 'myconf'
environment, line 3159: called econf 'configure' 'make' '--disable-jingle' '--disable-sametime-plugin' '--without-xmms' --without-external-libgadu' '--without-xscreensaver' '--disable-smsgsm' '--disable-testbed' '--with-x' '--enable-mitshm' --without-xinerama' '--with-qt-dir=/usr/qt/3' '--enable-mt' '--with-qt-libraries=/usr/qt/3/lib' '--disable-dependency-tracking' '--disable-debug' '--without-debug' '--disable-final' '--without-arts' '--prefix=/usr/kde/3.5' '--mandir=/usr/kde/3.5/share/man' '--infodir=/usr/kde/3.5/share/info'
ebuild.sh, line 513: called die
the specific snippet of code:
                                 die "econf failed"
the die message:
econf failed

the ebuild environment file is located at ' /var/tmp/portage/kde-base/kopete-3.5.9/temp/environment


ecco qui tutto l'errore. spero almeno stavolta di aver incollato bene
Per niente, ancora qualche riga più sopra, in /var/log/portage ci sono una serie di file che contengono i log delle compilazioni (dovrebbe essere qualcosa del genere kde-base:kopete:data-ora.log), prova a copiarti da qualche parte il file ed editarlo, così vedi gli errori completi.
Se stai installando tutto il mattone di kde ed è kde-meta potresti pensare di andare avanti con
Code:
rm -Rf /var/tmp/portage/* ; emerge --resume --skipfirst
se su 280 pacchetti di kde-meta completo ne salti anche 50 per via di kopete (ma lo puoi scavalcare tranquillamente) comunque gli altri te li trovi già installati. Se ti capita per kdelibs o konqueror è preoccupante ma per kopete no.
Bada che il comando rm -Rf /var/tmp/portage/* è necessario per ripulire la directory temporanea altrimenti rischio di trovarti il disco riempito dai tentativi falliti di compilazione.
Molto a naso credo che sia un problema di use flag, o hai selezionato troppi protocolli o nessuno o avrai mancato di installare qualche sua strana dipendenza.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Thu Aug 07, 2008 6:41 pm    Post subject: Reply with quote

credo anch'io che sia per le useflag perchè ne ho settate poche per via del fatto che quando le avevo selezionate tutte quelle che mi servivano mi dava errori di dipendenza circolare ovunque allora ho scelto di usarne poche indispensabili. faccio come mi hai detto tu e vediamo magari lo reistallo in seguito con il make.conf munito di use flag complete. ti ringrazio ora provo e ti faccio sapere

EDIT: ho appena provato ad andare su con il pag durante il messaggio d'errore e risultava che andava installato il kdelibs per continuare l'installazione. ora è installato ho rilanciato l'installazione di kopete per vedere se tutto andava ok e sta installando senza problemi. sembra tutto momentaneamente risolto! speriamo bene grazie di tutto comunque
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Fri Aug 08, 2008 2:35 am    Post subject: Reply with quote

we raga ho provato a mettere quella configurazione li che da la guida che ho seguito ma non mi è stata per nulla utile e la vorrei togliere. ho fatto il make oldconfig con la vecchia configurazione (che ho salvato prima di fare il cambio) ma credo mi abbia lasciato dei settaggi del .config della guida e volevo rimettero proprio pari pari il mio vecchio config. ho fatto make menuconfig in /usr/src/linux e sono andato in basso dove dice load an alternative config file, ho settato il mio .config di backup e ho rifatto il make && make modules_install. credo che abbia raggiunto il mio obbiettivo a giudicare dalla lista dei moduli installati, ma volevo chiedere conferma a voi, ho fatto bene?


EDIT: ho un problema con kde. quando lo starto da root tutto ok ma se provo a farlo da user mi dice questo:
Code:
xinit: no such file or directory (errno 2): cannot register with consolekit: org.freedesktop.ckconnector.error: unable to open session: failed to connect socket /var/run/dbus/system_bus_socket: no such file or directory
/home/gion/.xinitrc: line1: exec: startkde: not found


la configurazione dello xinitrc è uguale a quella di root ma non vuole proprio partire è possibile che non ha le autorizzazioni giuste?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Aug 09, 2008 9:33 am    Post subject: Reply with quote

non devi modificare l'xinitrc, devi solo editare /etc/rc.conf o /etc/conf.d/rc ed impostare l'apposita variabile a "kde-3.5"
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Sun Aug 10, 2008 11:17 pm    Post subject: Reply with quote

ho provato come dici tu ma continua a funzionarmi solo da root da user mi da degli errori strani te li riporterei qui se riusissi a trovare il log di quella sessione di x-_- cosa potrei fare intanto?
Back to top
View user's profile Send private message
Kind_of_blue
Guru
Guru


Joined: 10 Oct 2004
Posts: 485

PostPosted: Mon Aug 11, 2008 2:58 pm    Post subject: Reply with quote

echo "exec startkde" > ~/.xinitrc

... come da manuale
_________________
"I got off the concept of Progress, it's over-rated"
Arthur Dent
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Mon Aug 11, 2008 6:38 pm    Post subject: Reply with quote

ho seguito il manuale ma non mi starta la sessione da user. da root tutto ok scrivo da li tralaltro, ma da user mi si blocca mi da alcuni errori e non riesco a trovare il log della sessione..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum