Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ntfs] impossible emerge paquet non officiel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 7:32 am    Post subject: [ntfs] impossible emerge paquet non officiel Reply with quote

Bonjour,

encore un c'hti problème

J'essaye d'installer un ebuild non officiel: sys-block/ntfs-config
http://gentoo-overlays.zugaina.org/lapis/sys-block.html.fr
http://flomertens.free.fr/ntfs-config/

J'ai suivi la méthode décrite sur cette page:
http://fr.gentoo-wiki.com/HOWTO_Installer_des_ebuilds_non_officiels
(impossible d'y aller pour l'instant, ce matin vers 3 heures c'était bon)

Tout se passe bien, sauf que l'emerge échoue:
Code:
philoo-tuxman philippe # USE="nls" emerge ntfs-config
Calculating dependencies                    ... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) sys-block/ntfs-config-1.0.1-r1 to /

....   ...   ....

checking for pygtk >= 2.6.0 installed... not found
configure: error: required pygtk version not found

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-block/ntfs-config-1.0.1-r1/work/ntfs-config-1.0.1/config.log
 *
 * ERROR: sys-block/ntfs-config-1.0.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2111:  Called econf 'src_compile'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-block/ntfs-config-1.0.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-block/ntfs-config-1.0.1-r1/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'
 *

 * Messages for package sys-block/ntfs-config-1.0.1-r1:

 *
 * ERROR: sys-block/ntfs-config-1.0.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2111:  Called econf 'src_compile'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-block/ntfs-config-1.0.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-block/ntfs-config-1.0.1-r1/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'

si je comprends bien, il me manque dev-python/pygtk, avec une version > ou = à la 2.6.0
j'emerge pygtk-2.12.0
Code:
philoo-tuxman philippe # emerge --search pygtk
Searching...
[ Results for search key : pygtk ]
[ Applications found : 3 ]

*  dev-python/pygtk
      Latest version available: 2.12.0
      Latest version installed: 2.12.0
      Size of files: 2,846 kB
      Homepage:      http://www.pygtk.org/
      Description:   GTK+2 bindings for Python
      License:       LGPL-2.1

et... :evil: :twisted:
j'ai toujours la même erreur!

Comment faire?? Merci


Last edited by philoo on Sat Jul 26, 2008 6:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Jul 26, 2008 9:26 am    Post subject: Reply with quote

Essaye de réinstaller pygtk si ce n'est pas déjà fait.
Sinon tu peux aussi vérifier dans les logs indiqués (config.log, build.log) ce qu'il se passe.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 9:41 am    Post subject: Reply with quote

'alute

une mini recherche donne ce bug.
Regrade mais ça penche vers un update de python mal négocié :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 9:44 am    Post subject: Reply with quote

J'ai déjà essayé de réinstaller pygtk: sans succès

sinon j'ai trouvé cela:
https://bugs.launchpad.net/ntfs-config/+bug/135340
Quote:
NTFS-Config v1.0.1 has a dependency bug in the source code for pygtk >=2.6.

I'm building the source on pygtk 2.10, and getting dependency errors.

Is it possible the resolution is that 2.10 is being taken as 2.1[0] which is < 2.6?

Quote:
This bug was cleared with updates to pygtk.

Wooow!

Mettre à jour pytgk, OK essayons, y a cela:
http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.12/
et si je regarde bien:
Code:
philoo-tuxman philippe # cd /usr/portage/dev-python/pygtk
philoo-tuxman pygtk # ls -al
total 72
drwxr-xr-x   3 portage portage  4096 mai 29 14:36 .
drwxr-xr-x 360 portage portage 12288 jui 26 10:38 ..
-rw-r--r--   1 portage portage 22672 mai 29 14:36 ChangeLog
drwxr-xr-x   2 portage portage  4096 mai 29 04:38 files
-rw-r--r--   1 portage portage  2802 mai 29 14:36 Manifest
-rw-r--r--   1 portage portage   934 nov 19  2005 metadata.xml
-rw-r--r--   1 portage portage  2437 mar 31 06:37 pygtk-2.10.6.ebuild
-rw-r--r--   1 portage portage  2464 jan 10  2008 pygtk-2.12.0.ebuild
-rw-r--r--   1 portage portage  2568 avr 25 19:11 pygtk-2.12.0-r1.ebuild
-rw-r--r--   1 portage portage  2019 avr 24 21:35 pygtk-2.12.1.ebuild
-rw-r--r--   1 portage portage  2172 mai 29 14:26 pygtk-2.12.1-r2.ebuild

or emerge --search pygtk ou emerge -pv pygtk ne me propose que la version 2.12.0
Code:
philoo-tuxman pygtk # emerge -pv pygtk

These are the packages that would be merged, in order:

Calculating dependencies       ... done!
[ebuild   R   ] dev-python/pygtk-2.12.0  USE="opengl -doc -examples" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage


Alors comment mettre à jour?

Sinon dans les logs, pour build.log, y a ce que j'ai mis dans le 1er post
pour config.log, y a tout de même 577 lignes... :o :o
J'ai tout de même trouvé cela:
Code:
ImportError: No module named pygtk
configure:6702: result: not found
configure:6704: error: required pygtk version not found

ça aide? :lol:
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 9:54 am    Post subject: Reply with quote

Pour ta question, regarde plus en détails et tu verras que les version >pygtk-2.12.0 sont "tild-archées" donc utilise le partage.keywords si tu en veux une. Mais je vérifierais quand même avant la version de python en cours et celle qu'utilise ton pytgtk car je pense que 2.12.0 est peut-être suffisant.

btw: pourquoi ton pygtk est-il dans ton arbre local ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Jul 26, 2008 9:54 am    Post subject: Reply with quote

Code:
philoo-tuxman pygtk # emerge -pv pygtk

These are the packages that would be merged, in order:

Calculating dependencies       ... done!
[ebuild   R   ] dev-python/pygtk-2.12.0  USE="opengl -doc -examples" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage

Déjà tu utilises un ebuild de ton overlay local, cet ebuild peut-être buggé ou de mauvaise qualité.
Commence déjà par utiliser ceux de l'arbre officiel Portage.

philoo wrote:

Alors comment mettre à jour?

Relis la partie du handbook concernant les paquets keywordés et masqués.
La version 2.12.0 est la dernière version stable disponible. Si tu veux utiliser une version plus récente, tu dois modifier le fichier package.keywords.

Edit: pfff grilled de même pas une minute :o.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 11:13 am    Post subject: Reply with quote

@ boozo
Quote:

Pour ta question, regarde plus en détails et tu verras que les version >pygtk-2.12.0 sont "tild-archées" donc utilise le partage.keywords

il ne me semble pas: je vérifie toujours avant de lancer un emerge
de toute façon, elle ne figure pas dans /etc/portage/package.keywords et elle s'est installée toute seule après avoir lancé le emerge ntfs-config
Code:
philoo-tuxman pygtk # cat /etc/portage/package.keywords
media-libs/win32codecs ~amd64
app-cdr/nero ~amd64
app-arch/q7z ~amd64
sys-block/ntfs-config ~amd64

et j'ai simplement lancé un emerge pytgk: je pense que ça ne serait pas passé, si la version pytgk-2.12.0 avait été ~-archée, non?
ntfs-config est (était) ''tild-archée" + masquée oui

Quote:
Mais je vérifierais quand même avant la version de python en cours et celle qu'utilise ton pytgtk car je pense que 2.12.0 est peut-être suffisant.

pour la version de python, je pense que c'est la 2.5.2-r5:
Code:
philoo-tuxman pygtk # emerge --info python
Portage 2.1.4.4 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: 2.6.25-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3000+
Timestamp of tree: Sat, 26 Jul 2008 08:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13, 2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r2
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/ ftp://gentoo.imj.fr/pub/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://ftp.first-world.info/ ftp://ftp.first-world.info/ "
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_FR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X acl alsa amd64 berkdb bzip2 cdparanoia cdr cli cracklib crypt cups divx4linux dri dvd dvdr fbcon fortran gdbm gif gpm hal iconv ipv6 isdnlog java kde mad matroska midi mmx mp3 mplayer mudflap multilib ncurses nls nptl nptlonly nvidia ogg oggvorbis opengl openmp pam pcre perl pppd python qt3 qt4 readline reflection samba session spl sse sse2 ssl tcpd tiff truetype unicode vorbis wmf xine xorg xosd xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================
dev-lang/python-2.4.4-r13 was built with the following:
CFLAGS="-O2 -pipe"
CXXFLAGS="-O2 -pipe"

>>> Attempting to run pkg_info() for 'dev-lang/python-2.4.4-r13'
 * pkg_info() is not defined: 'python-2.4.4-r13.ebuild'
dev-lang/python-2.5.2-r5 was built with the following:
CFLAGS="-O2 -fwrapv -march=k8 -pipe"
CXXFLAGS="-O2 -fwrapv -march=k8 -pipe"

>>> Attempting to run pkg_info() for 'dev-lang/python-2.5.2-r5'
 * pkg_info() is not defined: 'python-2.5.2-r5.ebuild'


Pour pytgk, si je me réfère à cela https://bugs.launchpad.net/ntfs-config/+bug/135340,
pytgk est installée dans /usr/lib/python2.5/site-packages, donc utilise la python-2.5.2-r5?

Code:
pourquoi ton pygtk est-il dans ton arbre local ?

j'ai voulu tenter de passer la pytgk-2.12.1, mais ça ne passe pas
c'est réparé: j'ai supprimé les dossiers

@

Quote:
La version 2.12.0 est la dernière version stable disponible. Si tu veux utiliser une version plus récente, tu dois modifier le fichier package.keywords.

ça ne passe pas :roll:
le ebuild pygtk-2.12.1.ebuild digest -- :oops: :oops: [/code]

oups, je suis pas dans le bon dossier! :oops:
Back to top
View user's profile Send private message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 11:28 am    Post subject: Reply with quote

Ok je sais pas si ça avance mais j'ai réussi le

Code:
ebuild pygtk-2.12.1.ebuild digest

et le:
Code:
echo "dev-python/pygtk ~amd64" >> /etc/portage/package.keywords


maintenant le emerge --search pygtk me propose la 2.12.1-r2.

est-ce que c'est bon, ou j'ai loupé quelque chose?

PS: si je fais un
Code:
philoo-tuxman pygtk # emerge -pv pygtk

These are the packages that would be merged, in order:

Calculating dependencies       ... done!
[ebuild     U ] dev-python/pygtk-2.12.1-r2 [2.12.0] USE="X%* -doc -examples (-opengl%*)" 0 kB

et un:
Code:
philoo-tuxman pygtk # emerge -upv pygtk

These are the packages that would be merged, in order:

Calculating dependencies       ... done!
[ebuild     U ] dev-util/pkgconfig-0.23 [0.22] USE="-hardened" 1,009 kB
[ebuild     U ] dev-python/pygtk-2.12.1-r2 [2.12.0] USE="X%* -doc -examples (-opengl%*)" 0 kB


Qu'est-ce que je fais: un emerge pytk ou un emerge -u pygtk?


Last edited by philoo on Sat Jul 26, 2008 11:35 am; edited 3 times in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Jul 26, 2008 11:30 am    Post subject: Reply with quote

Je n'ai pas vraiment tout compris, et j'ai l'impression que tu utilises Portage un peu n'importe comment ou alors tu n'expliques pas clairement ce que tu fais et pourquoi tu le fais :o.

Pourquoi regénères-tu le digest ?
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 11:35 am    Post subject: Reply with quote

Desintegr wrote:
Je n'ai pas vraiment tout compris, et j'ai l'impression que tu utilises Portage un peu n'importe comment ou alors tu n'expliques pas clairement ce que tu fais et pourquoi tu le fais :o.

Pourquoi regénères-tu le digest ?


pour emerger la pygtk-2.12.1-*?
et ensuite voir si cela résoud l'échec de l'emerge ntfs-config?
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Jul 26, 2008 11:39 am    Post subject: Reply with quote

philoo wrote:
pour emerger la pygtk-2.12.1-*?

C'est inutile de générer le digest des paquets disponibles dans l'arbre officiel de Portage.
Pour les paquets keywordés, il suffit simplement de renseigner le fichier package.keywords correctement puis d'utiliser emerge.

La commande ebuild est une commande réservées aux développeurs/mainteneurs d'ebuilds. Tu ne dois pratiquement jamais l'utiliser, sauf quand tu créés des ebuilds pour ton overlay personnel.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 11:45 am    Post subject: Reply with quote

bababaaa 8O

Desintegr wrote:
Je n'ai pas vraiment tout compris, et j'ai l'impression que tu utilises Portage un peu n'importe comment ou alors tu n'expliques pas clairement ce que tu fais et pourquoi tu le fais :o.
Pourquoi regénères-tu le digest ?

@Desintedr: je te rassure, j'ai pas tout saisi non plus :lol:

edit: bon ben j'ai essayé pour y voir plus clair :
Code:
(...)
checking for xgettext... /usr/bin/xgettext
checking for python2.4... /usr/bin/python2.4
checking whether /usr/bin/python2.4 version is >= 2.4.0... yes
checking for  version... 2.4
checking for  platform... linux2
checking for  script directory... ${prefix}/lib/python2.4/site-packages
checking for  extension module directory... ${exec_prefix}/lib/python2.4/site-packages
checking for pygtk >= 2.6.0 installed... not found
configure: error: required pygtk version not found

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-block/ntfs-config-1.0.1-r1/work/ntfs-config-1.0.1/config.log
 *
 * ERROR: sys-block/ntfs-config-1.0.1-r1 failed.


Donc je te confirme le pb en version gtk-2.10.0 et python-2.5 (c'est ton prog qui est configuré avec les pieds :p)
Donc si la solution semble être d'upgrader pygtk, c'est le même topo que pour ntfs-config :
Code:
#echo "dev-python/pygtk ~amd64" >> /etc/portage/package.keywords
#emerge -v =dev-python/pygtk-2.12.1-r2
#emerge -v ntfs-config

Je te laisse le soin de t'y coller et de nous dire :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 12:38 pm    Post subject: Reply with quote

Déjà c'est mal barré
Code:
emerge -v =dev-python/pygtk-2.12.1-r2

...

dev-util/pkgconfig
    selected: 0.22
   protected: 0.23
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

...

/usr/lib64/portage/bin/ebuild.sh: line 1492: /bin/touch: Argument list too long
 *
 * ERROR: dev-util/pkgconfig-0.22 failed.
 * Call stack:
 *               ebuild.sh, line 1641:  Called die
 * The specific snippet of code:
 *      preprocess_ebuild_env || \
 *              die "error processing environment"
 *  The die message:
 *   error processing environment
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/binpkgs/dev-util/pkgconfig-0.22/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/binpkgs/dev-util/pkgconfig-0.22/temp/environment'.
 *
!!! FAILED postrm: 1
 * The 'postrm' phase of the 'dev-util/pkgconfig-0.22' package has failed
 * with exit value 1. The problem occurred while executing the ebuild
 * located at '/var/db/pkg/dev-util/pkgconfig-0.22/pkgconfig-0.22.ebuild'.
 * If necessary, manually remove the ebuild in order to skip the execution
 * of removal phases.

emerge --search pygtk
Searching...
[ Results for search key : pygtk ]
[ Applications found : 3 ]

*  dev-python/pygtk
      Latest version available: 2.12.1-r2
      Latest version installed: 2.12.1-r2
      Size of files: 2,124 kB
      Homepage:      http://www.pygtk.org/
      Description:   GTK+2 bindings for Python
      License:       LGPL-2.1

MDR!!

pour emerge -v ntfs-config, je vois pas trop ce que cela va changer,
Code:
checking for python2.4... /usr/bin/python2.4
checking whether /usr/bin/python2.4 version is >= 2.4.0... yes
checking for  version... 2.4
checking for  platform... linux2
checking for  script directory... ${prefix}/lib/python2.4/site-packages
checking for  extension module directory... ${exec_prefix}/lib64/python2.4/site-packages
checking for pygtk >= 2.6.0 installed... not found
configure: error: required pygtk version not found

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-block/ntfs-config-1.0.1-r1/work/ntfs-config-1.0.1/config.log
 *
 * ERROR: sys-block/ntfs-config-1.0.1-r1 failed.

pas mieux que si c'était pire. 8)
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Jul 26, 2008 12:54 pm    Post subject: Reply with quote

Le script configure de ntfs-config vérifie si pygtk est installé pour Python 2.4. Sur ton système pygtk est installé uniquement pour Python 2.5. C'est pour ça qu'il ne le trouve pas.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 12:56 pm    Post subject: Reply with quote

ben... :roll: c'est dans l'ordre c'est tout. Ca ne sert à rien de re-emerger ntfs-config si tu n'as pas upgradé pygtk !

dev-util/pkgconfig-0.23 vient d'être stabilisé et doit être màj en premier. C'est indépendant de ton pb.

Par ailleurs les version ~amd64 de pygtk sont comme le nom l'indique : "unstable" donc faut pas s'étonner que çà plante - surtout avec la dernière - donc essaye déjà un version antérieure à la -r2 avant de dire que çà n'avance pas :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 1:00 pm    Post subject: Reply with quote

Desintegr wrote:
Le script configure de ntfs-config vérifie si pygtk est installé pour Python 2.4. Sur ton système pygtk est installé uniquement pour Python 2.5. C'est pour ça qu'il ne le trouve pas.

Je suis d'accord avec toi c'est pour çà que j'ai raillé dans mon post précédent :lol:
Ceci-dit, le bugreport semble indiquer que l'update de pygtk réglait le pb - Soit faut juste tester avant de réouvrir le bug
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 1:36 pm    Post subject: Reply with quote

Quote:
dev-util/pkgconfig-0.23 vient d'être stabilisé et doit être màj en premier. C'est indépendant de ton pb.

c'est... euh c'était déjà fait: je sais plus trop là, vu que:


:arrow: de toute façon c'est mort, je viens de virer python-2.5 et j'ai plus accès à emerge... alors :oops:
alors ntfs-config, c'est le cadet de mes soucis pour l'instant! :lol:

Code:
philoo-tuxman ext # emerge
bash: /usr/bin/emerge: /usr/bin/python: bad interpreter: Aucun fichier ou répertoire de ce type
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 4:05 pm    Post subject: Reply with quote

arf... dsl je m'était arrété au premier "failed" d'où mes remarques
voila ce que ça fait de tweaker le css du forum pour avoir des assenceurs partout et d'être feignant de la molette :p

En revanche comme tu as pu le constater a tes dépends depuis que tu joues avec portage sans savoir vraiment ce que tu fais :

" Unmerging Python was a Bad Thing© " cit. :mrgreen:

Suis tenté de te laisser mariner un peu dans ton jus là...



edit:=+typo Pinaise... je sens que tu va choisir la mauvaise solution...

bon allez va !
Et adapte à la version de l'archive que tu as dans ton distfiles.

Si tu n'en n'as pas ou plus, regarde par-là
détare à la racine et ré-emerge -1v python
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 4:37 pm    Post subject: Reply with quote

Minute j'y pense : tu as unmergé le 2.5 mais aurais-tu encore le slot 2.4 ?
Sinon y'a encore un moyen plus simple :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
philoo
n00b
n00b


Joined: 16 Jul 2008
Posts: 32

PostPosted: Sat Jul 26, 2008 5:22 pm    Post subject: Reply with quote

@ boozo
Quote:
Minute j'y pense : tu as unmergé le 2.5 mais aurais-tu encore le slot 2.4 ?

oui oui: c'était quoi l'astu?

J'ai réinstallé Python-2.4.5 grâce à ce topic
https://forums.gentoo.org/viewtopic-t-5746-highlight-unmerged+python.html


Merci pour les commentaires les gars, ça fait toujours plaisir :lol:
En tout cas, je constate que je ne suis pas le seul à avoir tenté l'expérience; pour un noob Gentoo comme moi, ça me rassure, je ne suis pas seul.
:D

:idea: C'est en faisant des erreurs qu'on apprend, nan :?: :?:

emerge refonctionne :P

OUF!

ceci dit emerge ntfs-config foire toujours: donc c'est pas la version de Python qui est en cause?
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jul 26, 2008 7:15 pm    Post subject: Reply with quote

philoo wrote:
Merci pour les commentaires les gars, ça fait toujours plaisir :lol:
En tout cas, je constate que je ne suis pas le seul à avoir tenté l'expérience; pour un noob Gentoo comme moi, ça me rassure, je ne suis pas seul.

C'est en faisant des erreurs qu'on apprend, nan



Ben là ça varie... la plupart en prennent pour leur grade après avoir eu "chô-les-miquettes" comme dirait notre goret national et, y'en a qui ne comprennent toujours pas à +600 posts (non, non je ne vise personne ^^ ) que la doc gentoo il faut la lire, la relire, la re-relire pour entraver qqch à ce qu'ont fait et peut-être même quand on crois savoir enfin ce qu'on fait - même les veterans s'y collent régulièrement (voire journalièrement sur des pages de man) :wink:

Et pis, fallait bien te basher un peu pour modérer tes ardeurs à l'avenir genre quand ton post ressortira à bon escient, etc :p

Content que ça refonctionne. Effectivement, c'est le configure de ton prog qui est en cause. Si veux aider la communauté, rapporter le commentaire au tracker du projet serait plutôt bénéfique pour toi et d'autres :)
/!\ Mais ne le fait pas sur b.g.o /!\ C'est un prog non supporté - éventuellement tu peux le signaler au mainteneur du package gentoo si tu veux


btw: pour l'astuce, regarde du côté de la doc de portage pour comprendre la notion de SLOT et le man de pyton-updater et tu devrais comprendre et puis y'a également petit outil chez nous qui s'appelle eselect qui a pas mal de possibilités et qui facile un peu la vie de tous les jours aussi
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum