Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Rimuovere python 2.4 [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jul 25, 2008 5:06 pm    Post subject: Rimuovere python 2.4 [risolto] Reply with quote

Esiste una qualche ragione per non farlo?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Fri Jul 25, 2008 7:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Fri Jul 25, 2008 5:13 pm    Post subject: Reply with quote

Se usi degli script o pacchetti personalizzati che NON funzionano o non sono stati adattati per funzionare su python-2.5, IMO :P
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jul 25, 2008 6:05 pm    Post subject: Reply with quote

Intendevo se sono note particolari incompatibilità tra le dipendenze in portage... personalmente odio il python
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Fri Jul 25, 2008 6:21 pm    Post subject: Reply with quote

djinnZ wrote:
Intendevo se sono note particolari incompatibilità tra le dipendenze in portage... personalmente odio il python

Io ho aggiornato proprio oggi, e python-updater fa bene il suo lavoro. Vai tranquillo :wink:
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jul 25, 2008 7:23 pm    Post subject: Reply with quote

più che altro mi pare che segua il detto chi va piano va lontano ... e non arriva mai.
Al momento solo boost e blender fanno i capricci (ma ci ho fatto il callo). Grazie.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Jul 25, 2008 9:49 pm    Post subject: Reply with quote

[TRACKER] Python 2.5 incompatible packages

Dalla 2.45 in poi blender viene rilasciato compilato con python 2.5, non dovrebbe dare problemi.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Jul 27, 2008 12:35 pm    Post subject: Reply with quote

Strana questione, finchè non ho rimosso del tutto il python 2.4 python updater continuava a riportarmi il boost e vte da ricompilare. Capitato a qualcuno?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dark_knight
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2006
Posts: 112

PostPosted: Sun Jul 27, 2008 8:16 pm    Post subject: Reply with quote

Estratto da /usr/sbin/python-updater
Code:

# PKGS_MANUAL     = packages that should be re-emerged even if they don't
#                   fit the criteria (eg. ones that have python compiled
#                   statically)
[...]
PKGS_MANUAL="app-office/gnumeric app-office/dia dev-libs/boost x11-libs/vte"

;)
_________________
You can say that you are a true Gentoo-addicted when you type emerge --update --deep --newuse happiness.
Back to top
View user's profile Send private message
skypjack
l33t
l33t


Joined: 05 Aug 2006
Posts: 884
Location: Italia - Firenze

PostPosted: Sun Jul 27, 2008 10:21 pm    Post subject: Reply with quote

djinnZ wrote:
Strana questione, finchè non ho rimosso del tutto il python 2.4 python updater continuava a riportarmi il boost e vte da ricompilare. Capitato a qualcuno?

si, ho avuto lo stesso problema durante un python-updater che saltava ogni tre per due per non ricordo quale motivo. ho ricompilato boost, vte e altri non so quante volte! poi magicamente ora tutto funziona e python-updater non fa più le bizze, ma almeno che non sia saltato a seguito di un depclean e non ci ho fatto caso credo di avere ancora anche il 2.4 nel mio sistema (ammesso e non concesso siano slotted, un po' l'ora un po' l'ignoranza non saprei dirlo adesso).
Back to top
View user's profile Send private message
!ico
Apprentice
Apprentice


Joined: 26 Oct 2005
Posts: 199
Location: Bassano del Grappa (VI)

PostPosted: Mon Jul 28, 2008 7:37 am    Post subject: Reply with quote

io invece ho dovuto ricompilare pycairo pygtk pygobject e altre robette per far funzionare il tutto dopo l'aggiornamento.. (anche se revdep-rebuild non le segnalava) :?
e nel forum internazionale sembra che altri abbiano avuto qualche problema; insomma, non proprio un aggiornamento automatico.. :roll:
ola ;)
_________________
" I tasti iniziano. I tasti finiscono. Tu sai che sono 88; su questo nessuno può fregarti. Non sono infiniti loro. Tu, tu sei infinito, e dentro quei tasti, infinita è la musica che puoi fare. Loro sono 88. Tu sei infinito".
Novecento (Baricco)
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Mon Jul 28, 2008 8:36 am    Post subject: Reply with quote

!ico wrote:
io invece ho dovuto ricompilare pycairo pygtk pygobject e altre robette per far funzionare il tutto dopo l'aggiornamento.. (anche se revdep-rebuild non le segnalava) :?

stesso comportamento anche da me dopo aver rimosso la 2.4, speriamo che i prossimi passaggi di versioni siano meno complessi...
_________________
LP
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Jul 28, 2008 11:09 am    Post subject: Reply with quote

!ico wrote:
revdep-rebuild non le segnalava
ovvio, revdep-rebuild lavora sul linking elf non sul python (anche se sarebbe comodo lo facesse)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Fri Aug 01, 2008 7:14 pm    Post subject: Reply with quote

da quel che ho capito anche leggendo i post sul forum internazionale è che i pacchetti "manual" te li ripropone ogni volta a prescindere dal fatto che tu li abbia già ricompilati, quindi direi che dopo aver eseguito con successo python-updater una volta, la volta successiva lo si può eseguire con l'opzione
--disable-manual e a quel punto (sempre se la prima esecuzione è riuscita a ricompilare tutto quel che doveva ricompilare) non ti segnalava più niente e si poteva andare direttamente di emerge --depclean (rimuovendo così il python-2.4)
Perlomeno io ho fatto esattamente così e non ho avuto problemi.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Aug 03, 2008 5:40 am    Post subject: Reply with quote

python-updater va lanciato prima o dopo avere rimosso la versione 2.4?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Aug 03, 2008 7:43 am    Post subject: Reply with quote

cloc3 wrote:
python-updater va lanciato prima o dopo avere rimosso la versione 2.4?

Io python-updater lo lancio subito dopo aver aggiornato python a prescindere se sia stata rimossa o meno la versione precedente (cosa che fra l'altro dovrebbe avvenire in automatico). Ad ogni modo penso che in qualsiasi momento lo lanci va bene, a patto che sia stata installata l'ultima versione.
Io a questo punto farei così: se hai installato già l'ultima versione (2.5.2-r5) e provieni dalla 2.4, rimuovi la 2.4 e lancia python-updater. Ma comunque penso che sia indifferente lanciarlo prima o dopo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Sun Aug 03, 2008 9:23 am    Post subject: Reply with quote

da quello che ho capito io invece va lanciato subito dopo aver installato il 2.5 e prima di rimuovere il 2.4, in questo modo pu si accorge automaticamente dei due python (quello vecchio e quello nuovo) , se lo lanci dopo aver rimosso il 2.4 senza argomenti python-updater non farà esattamente niente.
L'unico modo per fargli capire che si è rimosso il 2.4 e bisogna ricompilare i pacchetti compilati con il 2.4 è aggiungere a python-updater l'opzione -o specificando la vecchia versione di python, in questo caso 2.4 .
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Aug 03, 2008 9:29 am    Post subject: Reply with quote

Ok, ho capito ma durante l'emerge, una volta che ha installato python 2.5, il 2.4 viene rimosso da portage (almeno così ho visto io).
Poi quando ho aggiornato python ho avuto diversi problemi (non mi si avviavano alcune applicazioni sotto KDE). Mi sono ricordato di python-updater, l'ho lanciato senza alcun parametro e si è aggiustato tutto.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Sun Aug 03, 2008 9:40 am    Post subject: Reply with quote

fbcyborg wrote:
Ok, ho capito ma durante l'emerge, una volta che ha installato python 2.5, il 2.4 viene rimosso da portage (almeno così ho visto io).
Poi quando ho aggiornato python ho avuto diversi problemi (non mi si avviavano alcune applicazioni sotto KDE). Mi sono ricordato di python-updater, l'ho lanciato senza alcun parametro e si è aggiustato tutto.


non so, nel mio sistema python-2,5 si è installato in un altro slot e non ha fatto l'unmerge del 2.4, per rimuoverlo ho dovuto fare emerge --depclean .

EDIT: forse perchè ho fatto questo aggiornamento non appena è stato stabilizzato il 2.5 , magari dopo hanno fatto delle modifiche sia alla ebuild del python sia al python-updater
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Aug 03, 2008 2:06 pm    Post subject: Reply with quote

Da quel che ho visto alcuni automake balordi se c'è il 2.4 installano solo per lui od al massimo per entrambi e questo fa incasinare il python updater.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum