Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PORTAGE]Access violation summary
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
selyne
n00b
n00b


Joined: 07 May 2008
Posts: 63

PostPosted: Thu Jul 24, 2008 4:28 pm    Post subject: [PORTAGE]Access violation summary Reply with quote

coucou les gens !

bon jce qui m'amène c'est pas vraiment un problème à proprment parler, c'est surtout que je souhaiterais avoir votre avis ou au moins un conseil.

je suis embettée avec Portage.

en fait hier, j'ai voulu activer les sons systèmes dans Gnome que je n'avais pas.
j'avais tout de bon sauf j'ai lu que il fallait ajouter esd en variable USE dans make.conf.

donc j'ai ajouté tout ça, j'ai fais un emerge -uDN world et là je laisse tourner ça re-emerge 24 paquets je crois.

je vais faire dodo et ce matin ça c'etait planté parceque portage a re-emergé mozilla-firefox-2.0.0.16 que j'avais enlevé la semaine dernière et remplacé par la version 3.0.1.

alors ça s'arrete avec ce message:

Code:
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-27078.log"

unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------

 * Messages for package www-client/mozilla-firefox-2.0.0.16:

 * Setting default locale to fr
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). Add "collision-protect" to FEATURES in
 * make.conf if you would like the merge to abort in cases like this. You
 * can use a command such as `portageq owners / <filename>` to identify
 * the installed package that owns a file. If portageq reports that only
 * one package owns a file then do NOT file a bug report. A bug report is
 * only useful if it identifies at least two or more packages that are
 * known to install the same file(s). If a collision occurs and you can
 * not explain where the file came from then you should simply ignore the
 * collision since there is not enough information to determine if a real
 * problem exists. Please do NOT file a bug report at
 * http://bugs.gentoo.org unless you report exactly which two packages
 * install the same file(s). Once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *    /usr/bin/firefox
 * Please remember to rebuild any packages that you have built
 * against Firefox. Some packages might be broken by the upgrade; if this
 * is the case, please search at http://bugs.gentoo.org and open a new bug
 * if one does not exist. Before filing any bugs, please move or remove
 *  ~/.mozilla and test with a clean profile directory.
 * GNU info directory index is up-to-date.


alors je ne suis pas sure de ce que je dois faire, je voudrais pas tout casser.

je pensais virer firefox 3.0.1 virer la version 2.0.16 et le ~/.mozilla et relancer le emerge -uDN world.

(et apres discretement enlever le 2.0.16 et remettre le 3.0.1)

j'ai bon?
Back to top
View user's profile Send private message
selyne
n00b
n00b


Joined: 07 May 2008
Posts: 63

PostPosted: Thu Jul 24, 2008 4:29 pm    Post subject: Re: [PORTAGE]Access violation summary Reply with quote

selyne wrote:
coucou les gens !

bon ce qui m'amène c'est pas vraiment un problème à proprement parler, c'est surtout que je souhaiterais avoir votre avis ou au moins un conseil.

je suis embettée avec Portage.

en fait hier, j'ai voulu activer les sons systèmes dans Gnome que je n'avais pas.
j'avais tout de bon sauf j'ai lu que il fallait ajouter esd en variable USE dans make.conf.

donc j'ai ajouté tout ça, j'ai fais un emerge -uDN world et là je laisse tourner ça re-emerge 24 paquets je crois.

je vais faire dodo et ce matin ça c'etait planté parceque portage a re-emergé mozilla-firefox-2.0.0.16 que j'avais enlevé la semaine dernière et remplacé par la version 3.0.1.

alors ça s'arrete avec ce message:

Code:
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-27078.log"

unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------

 * Messages for package www-client/mozilla-firefox-2.0.0.16:

 * Setting default locale to fr
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). Add "collision-protect" to FEATURES in
 * make.conf if you would like the merge to abort in cases like this. You
 * can use a command such as `portageq owners / <filename>` to identify
 * the installed package that owns a file. If portageq reports that only
 * one package owns a file then do NOT file a bug report. A bug report is
 * only useful if it identifies at least two or more packages that are
 * known to install the same file(s). If a collision occurs and you can
 * not explain where the file came from then you should simply ignore the
 * collision since there is not enough information to determine if a real
 * problem exists. Please do NOT file a bug report at
 * http://bugs.gentoo.org unless you report exactly which two packages
 * install the same file(s). Once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *    /usr/bin/firefox
 * Please remember to rebuild any packages that you have built
 * against Firefox. Some packages might be broken by the upgrade; if this
 * is the case, please search at http://bugs.gentoo.org and open a new bug
 * if one does not exist. Before filing any bugs, please move or remove
 *  ~/.mozilla and test with a clean profile directory.
 * GNU info directory index is up-to-date.


alors je ne suis pas sure de ce que je dois faire, je voudrais pas tout casser.

je pensais virer firefox 3.0.1 virer la version 2.0.16 et le ~/.mozilla et relancer le emerge -uDN world.

(et apres discretement enlever le 2.0.16 et remettre le 3.0.1)

j'ai bon?


merci en tout cas
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Thu Jul 24, 2008 6:49 pm    Post subject: Reply with quote

Pour la question de l'access violation, essaie peut-être de reemerger gnome-doc-utils (sans garantie : je n'utilise pas gnome ;) )

Il y a aussi un "file collision".
C'est peut-être lié au problème d'access violation mais si ce n'est pas le cas, vérifie que "collision-protect" ne figure pas dans la variable FEATURES (voir /etc/make.conf)

Concernant la version de firefox, ça ne sert à rien d'essayer de contourner le downgrade en forçant l'installation de la version 3 car tu ne ferais que reporter le problème au prochain emerge world !

Il faut découvrir le paquet qui réclame un firefox 2.*
Une méthode serait de faire un emerge -uDN world --pretend --tree

Cela dit, une autre cause possible au downgrade serait que tu sois en "stable" et que tu aies malgré tout forcé un firefox3 d'une manièe inavouable ;)
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Thu Jul 24, 2008 8:32 pm    Post subject: Reply with quote

Hello,
pour ce problème de mise à jour de firefox-3* en tildarché qui veut revenir en v2 après un "emerge -uDvaN world":
met le USE flag "xulrunner" dans ton make.conf, ça évitera ce downgrade de firefox :twisted:
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Thu Jul 24, 2008 8:52 pm    Post subject: Reply with quote

Kazuya wrote:
USE flag "xulrunner"

Argh j'y pensais plus à celui-là ! :oops:
Back to top
View user's profile Send private message
selyne
n00b
n00b


Joined: 07 May 2008
Posts: 63

PostPosted: Thu Jul 24, 2008 9:45 pm    Post subject: Reply with quote

merci beaucoup, encore un truc que je pouvais pas deviner 8O

j'ai refait mon emerge -uDN world, j'avoue que j'ai pas surveillé et que j'ai pas eu le reflexe de faire un --pretend pour voir ce qui allait être emergé mais j'ai l'impression que ça a marché.

l'upgrade s'est fini j'ai pas eu d'erreur :P

voila je suis heureuse je vais bien dormir !

merci à vous 2 !
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Fri Jul 25, 2008 12:01 pm    Post subject: Reply with quote

(résolu), donc ? ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum