Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Проблема с modprobe saa7134
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
sfx
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2006
Posts: 92

PostPosted: Mon Jul 21, 2008 5:33 pm    Post subject: Проблема с modprobe saa7134 Reply with quote

День добрый.
Имеется ТВ тюнер, Aver Studio 508. до 2,6,23-r8 работал идеально, на r8 и последующих возникла проблема,
я так полагаю даже не в ядре.
модуль подрубался так modprobe saa7134 card=102 tuner=38 secam=dk
и все работало, после обновления приходится грохать модуль, и грузить его заного, ибо
после первого раза тюнер не видется, точнее сказать параметры card=102 tuner=38 secam=dk не передаются модулю.
1раз:
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:05:02.0, rev: 209, irq: 18, latency: 32, mmio: 0xfa000000
saa7133[0]: subsystem: 1461:a14b, board: UNKNOWN/GENERIC [card=0,autodetected]

2раз:
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:05:02.0, rev: 209, irq: 18, latency: 32, mmio: 0xfa000000
saa7133[0]: subsystem: 1461:a14b, board: Avermedia AVerTV Studio 507 [card=102,insmod option]

помогите решить проблемку ;-)
Back to top
View user's profile Send private message
masikimy
n00b
n00b


Joined: 05 Jul 2007
Posts: 2

PostPosted: Tue Jul 22, 2008 10:34 am    Post subject: Reply with quote

Можно попробовать прописать модуль в автозагрузку с параметрами. Сейчас это файл /etc/conf.d/modules (для baselayout2). Синтаксис в отличие от /etc/modules.conf поменялся, но разобраться несложно. У меня тюнер нормально работает только, когда параметры прописаны в автозагрузку.
Back to top
View user's profile Send private message
sfx
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2006
Posts: 92

PostPosted: Sun Jul 27, 2008 9:35 am    Post subject: Reply with quote

бэйслайоуты первые, но попробую со вторыми.
может и поможет..
Back to top
View user's profile Send private message
s0L
n00b
n00b


Joined: 03 Aug 2008
Posts: 1

PostPosted: Sun Aug 03, 2008 10:55 am    Post subject: Re: Проблема с modprobe saa7134 Reply with quote

в новых ядрах дрова на saa7134 немного изменили. вот мой конфиг для 507-го, все работает.

Code:

#AverTV Studio 507
alias char-major-81 videodev
options i2c-algo-bit bit_test=1
alias char-major-81-0 saa7134
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 off

options saa7134 card=102 tuner=38 i2c_scan=1 secam=dk
Back to top
View user's profile Send private message
sfx
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2006
Posts: 92

PostPosted: Sat Sep 13, 2008 7:58 am    Post subject: Reply with quote

Спасибо! Обязательно опробую.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum