Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-portage] pb avec emerge kde(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
amroth
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2008
Posts: 123

PostPosted: Mon Jul 21, 2008 2:53 pm    Post subject: [kde-portage] pb avec emerge kde(résolu) Reply with quote

Bonjour,
J'ai des problèmes pour installer kde avec emerge et je ne comprends pas pourquoi ca bloque. (je crois qu'il y a des problemes en mélangeant les différentes installations de kde : kdebase, kdebase-meta ... et je n'arrive pas a corriger ca).
voici ce que j'obtiens après "emerge kdebase" :


Calculating dependencies ##... done!
[ebuild N ] x11-apps/xsetroot-1.0.2 USE="-debug"
[ebuild N ] sys-devel/gdb-6.7.1-r3 USE="nls -test -vanilla"
[ebuild N ] x11-libs/libXfontcache-1.0.4 USE="-debug"
[ebuild N ] x11-apps/xset-1.0.3 USE="-debug"
[ebuild N ] kde-base/kdebase-3.5.9-r3 USE="cups hal pam -arts -branding -debug -ieee1394 -java -joystick -kdeenablefinal -kdehiddenvisibility -ldap -lm_sensors -logitech-mouse -openexr -opengl -samba -xcomposite -xinerama -xscreensaver"
[blocks B ] kde-base/kcminit:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kcontrol:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kdebase-kioslaves:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kdebase-data:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kdesu:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kdm:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kdialog:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kdesktop:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/libkonq:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kcheckpass:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/konqueror:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] =kde-base/kdebase-3.5* (is blocking kde-base/khotkeys-3.5.9, kde-base/kdesktop-3.5.9-r1, kde-base/khelpcenter-3.5.9, kde-base/kicker-3.5.9, kde-base/kdialog-3.5.9-r1, kde-base/kdebase-data-3.5.9, kde-base/libkonq-3.5.9, kde-base/kdepasswd-3.5.9, kde-base/kcontrol-3.5.9, kde-base/kdebase-kioslaves-3.5.9, kde-base/kdesu-3.5.9, kde-base/kfind-3.5.9, kde-base/kcheckpass-3.5.9, kde-base/kdm-3.5.9, kde-base/konqueror-3.5.9, kde-base/kcminit-3.5.9)
[blocks B ] kde-base/kdepasswd:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/khelpcenter:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kicker:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/khotkeys:3.5 (is blocking kde-base/kdebase-3.5.9-r3)
[blocks B ] kde-base/kfind:3.5 (is blocking kde-base/kdebase-3.5.9-r3)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Merci pour vote aide


Last edited by amroth on Mon Jul 21, 2008 9:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Mon Jul 21, 2008 3:00 pm    Post subject: Re: [kde-portage] pb avec emerge kde Reply with quote

amroth wrote:
(je crois qu'il y a des problemes en mélangeant les différentes installations de kde

Exact : tu essaies de mélanger kde monolithique avec la version modulaire, ce qui ne se peut pas !
Voir ici ! ;)
Il faut choisir la version modulaire : le monolithique est dépassé et sera supprimé dans les versions suivantes...
Back to top
View user's profile Send private message
amroth
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2008
Posts: 123

PostPosted: Mon Jul 21, 2008 3:17 pm    Post subject: Reply with quote

Merci pour ta reponse, il n'y a pas de probleme alors ?
Je dois tout simplement installer les paquets que je veux un par un ? enfin c'est ce que je pense avoir compris.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Mon Jul 21, 2008 3:31 pm    Post subject: Reply with quote

En effet !
Commence par kde-base/kdebase-startkde et complète suivant tes besoins.
Si tu veux installer toutes les applis qui étaient anciennement installées par la version monolithique, utilises les ebuilds suffixé "-meta" (ex : kde-meta). Mais c'est fortement déconseillé, sauf si on cherche à avoir la plus grosse ;)
Back to top
View user's profile Send private message
amroth
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2008
Posts: 123

PostPosted: Mon Jul 21, 2008 3:49 pm    Post subject: Reply with quote

Ok ,
Mais comment est-ce que je peux supprimer tous les anciens paquets utilisés par kde, car si je je fais "emerge --unmerge kdebase" par exemple et ben quasiment rien ne sera supprimé.
Merci,
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Mon Jul 21, 2008 4:07 pm    Post subject: Reply with quote

Essaie de nettoyer avec:
Code:
emerge --depclean

mais fait bien attention à ce qu'il supprime
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Mon Jul 21, 2008 4:23 pm    Post subject: Reply with quote

amroth wrote:
car si je je fais "emerge --unmerge kdebase" par exemple et ben quasiment rien ne sera supprimé

Heu, bein si : tous les fichiers installés par kdebase devraient normalement être supprimés :?
Pour avoir la liste des fichiers : equery f kdebase
Si tu veux savoir de quelles apllications il s'agit, elles sont données par l'ebuild kdebase-meta :
Code:
 ~ # emerge -pq kdebase-meta
[ebuild  N    ] kde-base/knetattach-3.5.9
[ebuild  N    ] kde-base/ksysguard-3.5.9-r1
[ebuild  N    ] kde-base/kpager-3.5.9
[ebuild  N    ] kde-base/ktip-3.5.9
[ebuild  N    ] kde-base/kdebugdialog-3.5.9
[ebuild  N    ] kde-base/kscreensaver-3.5.9
[ebuild  N    ] app-text/psutils-1.17-r1
[ebuild  N    ] kde-base/kghostview-3.5.9
[ebuild  N    ] app-text/enscript-1.6.4-r3
[ebuild  N    ] sys-devel/gdb-6.8-r1
[ebuild  N    ] kde-base/drkonqi-3.5.9
[ebuild  N    ] kde-base/kdeprint-3.5.9
[ebuild  N    ] kde-base/kdebase-meta-3.5.9

Même raisonnement pour les autres monolithes ...
Back to top
View user's profile Send private message
amroth
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2008
Posts: 123

PostPosted: Mon Jul 21, 2008 9:05 pm    Post subject: Reply with quote

Ok !
Je pense que c'est bon!
Merci pour vote aide!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum