Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[alsa] carte son semble ok mais pas de son[abandon]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
tdyp
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 154

PostPosted: Wed Sep 10, 2008 10:49 pm    Post subject: [alsa] carte son semble ok mais pas de son[abandon] Reply with quote

bonsoir,
je viens d installer une gentoo sur un ibm X40, bon j ai plusieurs soucis, je vais donc y aller par petits bouts.

aujourd hui je voudrais m attaquer au soucis du son.

j ai suivi ce post cependant je n arrive pas a resoudre mon soucis. bon au contraire de l auteur j ai gardé les modules alsa dans mon kernel.

mon lsmod:
Code:

Module                  Size  Used by
snd_seq_oss            23936  0
snd_seq_device          5128  1 snd_seq_oss
snd_seq_midi_event      5376  1 snd_seq_oss
snd_seq                36272  4 snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            30624  0
snd_mixer_oss          12032  1 snd_pcm_oss
snd_intel8x0           25500  0
snd_ac97_codec         86564  1 snd_intel8x0
snd_pcm                49288  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              15364  2 snd_seq,snd_pcm
snd                    37284  9 snd_seq_oss,snd_seq_device,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
snd_page_alloc          7048  2 snd_intel8x0,snd_pcm
i915                   24064  2
ac97_bus                1536  1 snd_ac97_codec
soundcore               4960  1 snd
yenta_socket           20620  1
rsrc_nonstatic          8192  1 yenta_socket


mon lswh:
Code:

*-multimedia
             description: Multimedia audio controller
             product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
             vendor: Intel Corporation
             physical id: 1f.5
             bus info: pci@0000:00:1f.5
             version: 01
             width: 32 bits
             clock: 33MHz
             capabilities: pm bus_master cap_list
             configuration: driver=Intel ICH latency=0 module=snd_intel8x0


voila si quelqu un a besoin d autres infos...

merci d avance!


Last edited by tdyp on Mon Sep 15, 2008 12:54 am; edited 1 time in total
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Sep 11, 2008 9:24 am    Post subject: Reply with quote

EDIT 2 : à vérifier en premier : es tu dans le groupe audio?

Salut donne nous la dernière ligne de ce fichier stp : less /etc/modprobe.d/alsa

Normalement alsa compte à partir de 1,
Quote:
# Set this to the correct number of cards.
options snd cards_limit=1


Que dit un /etc/init.d/alsasound start ou restart stp.

EDIT : ce lien te sera très utile. https://forums.gentoo.org/viewtopic-t-704585-highlight-alsa+intel+ac97.html
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
tdyp
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 154

PostPosted: Thu Sep 11, 2008 6:56 pm    Post subject: Reply with quote

bonjour
merci pour ton aide.
-la commande " less /etc/modprobe.d/alsa" me renvoit une erreur le fichier alsa n existe pas.
-la commande "/etc/init.d/alsasound restart" donne:

Code:

* WARNING:  you are stopping a boot service.
* Storing ALSA Mixer Levels ... ok
* Killing processes using ALSA ... ok
* Unloading ALSA modules ... ok
* Loading ALSA modules ... ok
* Loading: snd-card-0 ...ok
* Loading: snd-mixer-oss ...ok
* Loading: snd-pcm-oss ...ok
* Loading: snd-seq-oss ...ok
ok
* Restoring Mixer Levels ...ok
Back to top
View user's profile Send private message
tdyp
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 154

PostPosted: Fri Sep 12, 2008 7:05 am    Post subject: Reply with quote

Mickael wrote:
EDIT : ce lien te sera très utile. https://forums.gentoo.org/viewtopic-t-704585-highlight-alsa+intel+ac97.html


j y suis allé faire un tour, j ai tenté de faire le "make clean" et de recompiler derriere mais ca ne semble pas apporter de grands changements... enfin pour ma part
Back to top
View user's profile Send private message
profy
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jun 2005
Posts: 96
Location: Sophia Antipolis

PostPosted: Fri Sep 12, 2008 12:20 pm    Post subject: Reply with quote

Salut,

Les drivers du kernel et de alsa-drivers ne sont pas les même, ça pourrait résoudre ton problème d'utiliser alsa-drivers.
_________________
Plus je connais les hommes, plus j'aime mon pc.
Back to top
View user's profile Send private message
bidibule
n00b
n00b


Joined: 02 Apr 2006
Posts: 21

PostPosted: Fri Sep 12, 2008 2:50 pm    Post subject: Reply with quote

As-tu vérifié les levels avec la commande suivante :
Code:
alsamixer

Peux tu nous envoyer le retour de celle-ci
Code:
amixer

Remarque : Tu dois emerger le package alsa-utils pour ces deux outils
Back to top
View user's profile Send private message
tdyp
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 154

PostPosted: Fri Sep 12, 2008 6:10 pm    Post subject: Reply with quote

bonjour,

voila ce que me renvoit la commande "amixer":
Code:

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [-12.00dB] [on]
  Front Right: Playback 23 [74%] [-12.00dB] [on]
Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 23 [74%] [-12.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [-12.00dB] [on]
  Front Right: Playback 23 [74%] [-12.00dB] [on]
Simple mixer control 'Headphone Jack Sense',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 27 [87%] [6.00dB] [on] Capture [off]
  Front Right: Playback 27 [87%] [6.00dB] [on] Capture [off]
Simple mixer control 'Line Jack Sense',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 27 [87%] [6.00dB] [on] Capture [off]
  Front Right: Playback 27 [87%] [6.00dB] [on] Capture [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [-34.50dB] [off]
  Front Left: Capture [on]
  Front Right: Capture [on]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Mic Select',0
  Capabilities: enum
  Items: 'Mic1' 'Mic2'
  Item0: 'Mic1'
Simple mixer control 'Video',0
  Capabilities: cswitch cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 26 [84%] [4.50dB] [on]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 28 [90%] [7.50dB] [on] Capture [off]
  Front Right: Playback 28 [90%] [7.50dB] [on] Capture [off]
Simple mixer control 'Mono Output Select',0
  Capabilities: enum
  Items: 'Mix' 'Mic'
  Item0: 'Mix'
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Stereo Mic',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]


je vais quand meme tenter avec les pilotes alsa voir...
Back to top
View user's profile Send private message
tdyp
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 154

PostPosted: Sat Sep 13, 2008 8:41 am    Post subject: Reply with quote

bon j ai essayer avec les pilotes, j ai du les démasqués, mais leur installation n a quand meme pas resolu mon soucis.

en plus de ca maintenant les modules de son ne se lancent plus... donc j enleve tout et je m occupe des modules.
Back to top
View user's profile Send private message
tdyp
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 154

PostPosted: Mon Sep 15, 2008 12:53 am    Post subject: Reply with quote

bonsoir,
je pense avoir malheureusement trouvé la cause de mon soucis.
je pense que c est tout simplement un soucis materiel.
je m explique: ce portable est une occasion, je l ai recu sans OS (c etait peut etre la mon erreur).
etant donné que mes manipulations etaient toutes correctes je voulais en avoir le coeur net (serieusement tout le monde arrive a se depatouiller et pas moi...?)
j ai donc reinstaller un windows, la carte son etant bien installé (pilotes fournis par lenovo) l icone apparait bien pres de l heure mais aucuns sons ne s echappe, ni de la carte son ni du casque... =/

bref je pense que je devrais me faire une raison pour ce pc la!
Back to top
View user's profile Send private message
bidibule
n00b
n00b


Joined: 02 Apr 2006
Posts: 21

PostPosted: Mon Sep 15, 2008 12:08 pm    Post subject: Reply with quote

Bonjour,

J'ai un portable ThinkPad et il y a une combinaison de touches (Fn+Backspace) pour activer le son.
Fn+PgUp/PgDown pour monter et descendre le volume.
Back to top
View user's profile Send private message
tdyp
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 154

PostPosted: Tue Sep 16, 2008 12:41 am    Post subject: Reply with quote

bidibule wrote:
Bonjour,

J'ai un portable ThinkPad et il y a une combinaison de touches (Fn+Backspace) pour activer le son.
Fn+PgUp/PgDown pour monter et descendre le volume.


bonsoir j ai deux thinkpad. mais je ne pense pas que cela vienne d un oubli de ma part:
de un parce que cette combinaison n apparait pas sur le clavier (je parle bien sur des etiquettes coller sur les touches)
et de deux je pense reellement a un soucis materiel car que ce soit sou windows ou linux, haut parleur ou casque, rien ne sort. au pire c est pas grave je ferait tester ca a mon taffe pour une confirmation ^^
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Tue Sep 16, 2008 9:05 am    Post subject: Reply with quote

tdyp wrote:
de un parce que cette combinaison n apparait pas sur le clavier (je parle bien sur des etiquettes coller sur les touches)

Par contre, d'après la notice d'installation, il y a trois boutons dédiés au sommet du clavier, dont un bouton "silence".
D'après la notice, si l'ordinateur a été éteint en "mode silence", il restera en "mode silence" au démarrage suivant.
Pour désactiver le mode silence, il faut utiliser une des 2 autres touches (volume+/volume-)
Ces réglages sont "matériels" et, à mon avis, ne dépendent pas du système d'exploitation.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum