Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Nautilus] Nautilus ne démarre plus en root [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Footkill
n00b
n00b


Joined: 06 Nov 2007
Posts: 27

PostPosted: Fri Jul 04, 2008 9:31 am    Post subject: [Nautilus] Nautilus ne démarre plus en root [résolu] Reply with quote

Bonjour à tous,

Visiblement dernièrement j'enchaîne les problèmes. Après la correction orthographique voici le problème suivant:
Depuis la dernière actualisation de nautilus à 2.22.4 je ne peux plus lancer nautilus en root. J'ai l'erreur suivante:

(nautilus:14176): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
seahorse nautilus module initialized

puis rien... :(

Ce n'est pas indispensable mais quelques fois c'est utile. Avec nautilus-2.22.3, pas de problème. Je n'ai rien vu dans bugzilla et je n'ai rien trouvé d'intéressant en googlant.
Donc si quelqu'un a une idée, merci pour votre aide!


Last edited by Footkill on Sat Jul 05, 2008 11:09 am; edited 1 time in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Jul 04, 2008 9:36 am    Post subject: Reply with quote

Une dépendance cassée (une lib qui foire). T'es essayés un revdep-rebuild?
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Fri Jul 04, 2008 9:55 am    Post subject: Reply with quote

ton nautilus lancé en root, c'est depuis une session graphique en user ?

Au passage, j'ai le même message d'erreur quand je lance nautilus en root, mais il s'affiche quand même
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8080
Location: ~Brussels - Belgique

PostPosted: Fri Jul 04, 2008 10:03 am    Post subject: Reply with quote

Est-ce que la config de X ou du login manager a changé (genre : + de sécurité et désactivation de flags du genre "allow remote logins", ...)

Sous ton user, tente "xhost +", puis passe en root.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Footkill
n00b
n00b


Joined: 06 Nov 2007
Posts: 27

PostPosted: Fri Jul 04, 2008 11:27 am    Post subject: Reply with quote

revdep-rebuild ne donne rien.
xhost + non plus

je me suis aperçu que de temps en temps le message d'erreur change:

(nautilus:24721): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
seahorse nautilus module initialized
nautilus: xcb_lock.c:77: _XGetXCBBuffer: La declaración `((int) ((xcb_req) - (dpy->request)) >= 0)' no se cumple.
Multiple segmentation faults occurred; can't display error dialog

J'ai essayé de repasser à nautilus-2.22.3 qui marchait très bien avant et j'ai le même problème, donc ça ne vient pas de nautilus mais d'autre chose.
Gdmsetup de démarre pas non plus. La fenêtre apparaît une seconde puis disparaît sans message d'erreur.
Back to top
View user's profile Send private message
Footkill
n00b
n00b


Joined: 06 Nov 2007
Posts: 27

PostPosted: Fri Jul 04, 2008 11:46 am    Post subject: Reply with quote

J'ai essayé de passer à des versions antérieurs des derniers paquets gnome actualisés (gdm, gnome-session, gnome-keyring, seahorse) et rien.
J'ai démarré gnome en root et tout va bien, donc le problème se manifeste quand je suis connecté en tant qu'utilisateur et que je veux utiliser nautilus en tant que root. Les autres programmes gnome (gedit, evince, fil-roller, gnome-terminal, etc..) marche sans problème en root. Donc je ne vois vraiment pas d'oú ça peut venir.
Une idée?
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Fri Jul 04, 2008 5:49 pm    Post subject: Reply with quote

Salut,
J'ai déjà eu ce problème il y a très longtemps, que j'avais réglé en lançant mon nautilus ainsi :

dbus-launch nautilus
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
Footkill
n00b
n00b


Joined: 06 Nov 2007
Posts: 27

PostPosted: Fri Jul 04, 2008 8:29 pm    Post subject: Reply with quote

Effectivement, merci pour l'info, ça fonctionne... Bizarre :? Cependant j'aimerais bien comprendre le pourquoi. Quelqu'un peut-il m'éclairer un peu? Serai-je obligé toujours de lancer nautilus de cette manière?
Merci
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Fri Jul 04, 2008 9:02 pm    Post subject: Reply with quote

Chez moi le problème a fini par se régler tout seul... et un jour ça a remarché sans "préfixer" ma commande par dbus-launch (ça ne le faisait pas qu'avec nautilus mais avec gdmsetup aussi et j'avais du éditer le lanceur du menu pour qu'il fonctionne...) j'ai la flemme de chercher mais à l'époque j'avais trouvé des rapports de bogues là dessus sur ubuntu...à creuser donc...
J'ai toujours gnome 2.20 et j'ai pas cet ennui en ce moment.(ça datait du 2.18 au moins...)
Essaies peut être de recompiler tout ce qui dépend de dbus (sert toi de la commande equery) puis nautilus... :wink:

Edit : Mon post sur le sujet quand ça m'est arrivé : https://forums.gentoo.org/viewtopic-t-534357-highlight-.html
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Fri Jul 04, 2008 9:26 pm    Post subject: Reply with quote

Footkill wrote:
Serai-je obligé toujours de lancer nautilus de cette manière?

En même temps, t'es pas obligé de le lancer en root... pourquoi tu tiens à lancer Nautilus en root en fait, ça te sert à quoi ? Parce que lancer des applications X en root, ça rajoute énormement plus de risques de sécurité, faut pas le faire à la légère, surtout que les applications X interagissent entre elle, donc suffit d'une faille avec ton user pour que ça se propagent dans les apps X qui tournent en root et tout... bon ok on se dit que ça n'arrive jamais, jusqu'au jour où ça arrive vraiment, sans prévenir... ;)
C'est pas pour t'en empêcher de le faire hein, tu fais ce que tu veux, mais je veux que tu sois conscient des risques que ça implique, pour le faible intérêt que ça a de faire tourner des apps X en root (les applications graphiques, c'est fait pour le user, pour utiliser la machine, et non pas pour l'administrer, la seule chose que root est censé faire).
Back to top
View user's profile Send private message
Footkill
n00b
n00b


Joined: 06 Nov 2007
Posts: 27

PostPosted: Sat Jul 05, 2008 11:08 am    Post subject: Reply with quote

Oui je suis conscient des risques et je ne lance nautilus en root que dans de rares cas. Je ne suis pas un grand spécialiste de la ligne de commande et quelque fois je préfère nautilus en root.
Merci pour vos réponses rapides et utiles.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum