Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SQUID] Auth ntlm qui echoue...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Fri Jul 04, 2008 9:26 am    Post subject: [SQUID] Auth ntlm qui echoue... Reply with quote

Bonjour, me revoila après mon souçi avec Kerberos, me revoila avec un souçi avec SQUID que je dois utiliser avec une auth sur un DC (pô bien)

En fait tout fonctionne sans auth, des que je place celle-ci je me fais bouler,

que la machine soit intégrée au domaine ou non j'ai beau taper
MONDOMAINE/USER
ou
USER
puis le password, rien y fait j'ai une erreur :
http://img359.imageshack.us/img359/7428/lolvj5.png

Je vous soumets mes fichiers de config :

/etc/hosts :
Code:
127.0.0.1   localhost
172.28.6.145   proxy.cg2a.org   ubuntu
172.28.6.142   srv1.cg2a.org srv1


/etc/krb5.conf :
Code:
[libdefaults]
        default_realm = CG2A.ORG

[realms]
        CG2A.ORG = {
                kdc = SRV1.CG2A.ORG
        }
[domain_realms]
        .kerberos.server = SRV1.CG2A.ORG


/etc/nsswitch.conf :
Code:
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat winbind
group:          compat winbind
shadow:         compat winbind

hosts:          files dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis


/etc/samba/smb.conf :
Code:
[global]
   workgroup = CG2A
   realm = CG2A.ORG
   security = ads
   encrypt passwords = yes

   password server = SRV1.CG2A.ORG

   idmap uid = 10000-20000
   idmap gid = 10000-20000
   winbind enum groups = yes
   winbind enum users = yes
   winbind use default domain = yes
   
   dns proxy = No
   
   syslog = 0
   log file = /var/log/samba/log.%m
   max log size = 1000
   
   invalid users = root


/etc/squid/squid.conf :
Code:
auth_param ntlm program /usr/bin/ntlm_auth --helper-protocol=squid-2.5-ntlmssp

auth_param ntlm children 5



acl all src 0.0.0.0/0.0.0.0

acl manager proto cache_object

acl localhost src 127.0.0.1/255.255.255.255

acl to_localhost dst 127.0.0.0/8

acl SSL_ports port 443

acl Safe_ports port 80      # http

acl Safe_ports port 21      # ftp

acl Safe_ports port 443      # https

acl Safe_ports port 70      # gopher

acl Safe_ports port 210      # wais

acl Safe_ports port 1025-65535   # unregistered ports

acl Safe_ports port 280      # http-mgmt

acl Safe_ports port 488      # gss-http

acl Safe_ports port 591      # filemaker

acl Safe_ports port 777      # multiling http

acl CONNECT method CONNECT

acl LocalNet src 172.28.6.0/24



acl password proxy_auth REQUIRED



http_access allow manager localhost

http_access deny manager

http_access deny !Safe_ports

http_access deny CONNECT !SSL_ports

http_access allow localhost



http_access allow LocalNet password



http_access allow all

icp_access allow all

http_port 3128

hierarchy_stoplist cgi-bin ?

access_log /var/log/squid/access.log squid

acl QUERY urlpath_regex cgi-bin \?

cache deny QUERY

refresh_pattern ^ftp:      1440   20%   10080

refresh_pattern ^gopher:   1440   0%   1440

refresh_pattern .      0   20%   4320

icp_port 3130

coredump_dir /var/spool/squid


Voila sinon sur l'AD j'ai juste un utilisateur "web" qui devrait avoir le droit de surfer, il est dans le groupe "WEBOK" qui est le groupe autorisé a surfer...
Bref j'attends patiemment vos réponses merci d'avance
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Tue Jul 08, 2008 6:39 am    Post subject: Reply with quote

Salut, dit y'a une passerelle, samba avec winbin ou un truc dans le genre,(EDIT 5 : j'étais pas réveillé jeviens de voir ta conf samba sorry..) parce que l'erreur elle dit tout et rien en même temps. Y'a quoi dans les logs :
Quote:
access_log /var/log/squid/access.log squid

Mais je mise sur une erreur d'authentification avec la conf de squid :
exemple ici
ou une autre qui lui ressemble :
Quote:
Je crois que j'avais laissé au début la ligne :

"auth_param basic realm Squid AD" dans le /etc/squid/squid.conf
que j'ai simplement remplacée par
"auth_param basic realm DOMAINE.MACHIN.COM".

mais avec la même erreur on peut avoir :
Quote:
Ok merci pour ta reponse... ca n'avait rien a voir pour moi, seulement le /var/run/samba/winbindd_pam qui n'appartenait pas au groupe proxy...

Bon ca roule maintenant.
++

Tout ça extrait du réseau qui regorge d'erreurs de ce type et d'autant d'appels à l'aide. :lol:

EDIT : Haaa : un un lien très intéressant tu y verras que ta première ligne de ton squid.conf ne pointe pas au même endroit. Moi je peux pas t'en dire plus j'ai pas de squid truc machin chose sous la main. (regarde le liend'EDIT 3 qui plus clair)

EDIT 2 : faut vérifier les permissions de ce fichier : #chmod 750 /var/lib/samba/winbindd_privileged ou équivalent.

EDIT 3 : http://www.citefa.gov.ar/SitioSI6_EN/downloads/Squid-NTLM-EN.pdf
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum