Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200807-01 ] Python: Multiple integer overflows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Tue Jul 01, 2008 12:26 pm    Post subject: [ GLSA 200807-01 ] Python: Multiple integer overflows Reply with quote

Gentoo Linux Security Advisory

Title: Python: Multiple integer overflows (GLSA 200807-01)
Severity: normal
Exploitable: remote
Date: July 01, 2008
Bug(s): #216673, #217221
ID: 200807-01

Synopsis

Multiple integer overflows may allow for Denial of Service.

Background

Python is an interpreted, interactive, object-oriented programming language.

Affected Packages

Package: dev-lang/python
Vulnerable: < 2.4.4-r13
Unaffected: >= 2.3.6-r6 < 2.3.7
Unaffected: >= 2.4.4-r13
Architectures: All supported architectures


Description

Multiple vulnerabilities were discovered in Python:
  • David Remahl reported multiple integer overflows in the file imageop.c, leading to a heap-based buffer overflow (CVE-2008-1679). This issue is due to an incomplete fix for CVE-2007-4965.
  • Justin Ferguson discovered that an integer signedness error in the zlib extension module might trigger insufficient memory allocation and a buffer overflow via a negative signed integer (CVE-2008-1721).
  • Justin Ferguson discovered that insufficient input validation in the PyString_FromStringAndSize() function might lead to a buffer overflow (CVE-2008-1887).


Impact

A remote attacker could exploit these vulnerabilities to cause a Denial of Service or possibly the remote execution of arbitrary code with the privileges of the user running Python.

Workaround

There is no known workaround at this time.

Resolution

The imageop module is no longer built in the unaffected versions. All Python 2.3 users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.3.6-r6"
All Python 2.4 users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.4.4-r13"


References

CVE-2008-1679
CVE-2008-1721
CVE-2008-1887
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum