Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[WIFI] configuration de iwl4965 avec wpa_supplicant
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lermit
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2005
Posts: 141

PostPosted: Mon Jun 30, 2008 8:02 am    Post subject: [WIFI] configuration de iwl4965 avec wpa_supplicant Reply with quote

Bonjour,

je n'arrive pas a configuré ma carte wifi avec une clef WPA.
ma carte fonctionne correctement. j'ai quelque difficulté a la faire fonctionne avec une clef WEP.

voici mon fichier /etc/conf.d/net
Code:
#cat /etc/conf.d/net
dns_domain_lo="theforce"
modules=( "dhcpcd" )
config_eth0=( "dhcp" )
dhcp_eth0="release"

# Use dhcp for the wireless interface
config_wlan0=("dhcp")

# Declare wpa_supplicant module
modules=( "wpa_supplicant" )
modules=("iwconfig")
wpa_supplicant_wlan0="-Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd"
dhcpcd_wlan0="-t 20"


voici mon fichier wpa_supplicant.conf
Code:
cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=0
network={
        ssid="NativeSpeaker"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk="MyPassword"
        priority=2
}


quand je relance ma carte wifi voici se qu'il me donne
Code:
 /etc/init.d/net.wlan0 restart
 * Stopping wlan0
 *   Bringing down wlan0
 *     Shutting down wlan0 ...                                            [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Starting wlan0
 *   Wireless radio has been killed for interface wlan0
 *   wpa_supplicant will launch, but not associate until
 *   wireles radio is re-enabled for interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='wheel' (DEPRECATED)
ap_scan=0
Line: 10 - start of a new network block
ssid - hexdump_ascii(len=13):
     4e 61 74 69 76 65 53 70 65 61 6b 65 72            NativeSpeaker   
proto: 0x1
key_mgmt: 0x2
pairwise: 0x8
group: 0x8
PSK (ASCII passphrase) - hexdump_ascii(len=13): [REMOVED]
priority=2 (0x2)
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 2
   id=0 ssid='NativeSpeaker'
Initializing interface (2) 'wlan0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:13:e8:85:79:71
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - wpa_driver_wext_set_drop_unencrypted
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Setting scan request: 0 sec 100000 usec
ctrl_interface_group=10 (from group name 'wheel')
Added interface wlan0
Daemonize..                                                               [ ok ]
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *     Backgrounding ...


voici se que donne après le iwconfig l'a carte n'ai pas du tout configuré pas le bon ssid, frécence , pas de clef,...
Code:
iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:12:17:D5:40:1B   
          Tx-Power=off   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


voici mon ifconfig
Code:
ifconfig wlan0
wlan0     Lien encap:Ethernet  HWaddr 00:13:E8:85:79:71 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:15 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1994 (1.9 Kb)  TX bytes:2032 (1.9 Kb)


en gros ma carte wifi n'est pas configuré par wpa_supplicant
quelqu'un aurai une idée pour faire fonctionne connecté a carte wifi avec le wpa

merci bien
Back to top
View user's profile Send private message
tmasscool
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 151

PostPosted: Mon Jun 30, 2008 9:16 am    Post subject: Reply with quote

Essaie avec ton /etc/conf.d/net comme ceci
Code:
dns_domain_lo="theforce"
config_eth0="dhcp"
dhcp_eth0="release"

modules_wlan0="wpa_supplicant"
wpa_supplicant_wlan0="-Dwext"
config_wlan0="dhcp"
dhcpcd_wlan0="-t 20"

Et /etc/wpa_supplicant/wpa_supplicant.conf comme ceci
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0 
fast_reauth=1

network={
        ssid="NativeSpeaker"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk="MyPassword"
        priority=2
}
Back to top
View user's profile Send private message
lermit
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2005
Posts: 141

PostPosted: Mon Jun 30, 2008 12:53 pm    Post subject: Reply with quote

quand j'utilise la configuration que tu ma donné
j'ai ceux ci
Code:
 /etc/init.d/net.wlan0 restart
 * Stopping wlan0
 *   Bringing down wlan0
 *     Shutting down wlan0 ...                                            [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Starting wlan0
 *   Wireless radio has been killed for interface wlan0
 *   wpa_supplicant will launch, but not associate until
 *   wireles radio is re-enabled for interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported        [ ok ]th param 5 value 0x1 -
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *     Backgrounding ...
Back to top
View user's profile Send private message
yangranger87
n00b
n00b


Joined: 30 Jun 2008
Posts: 3

PostPosted: Mon Jun 30, 2008 3:58 pm    Post subject: Reply with quote

salut,

cela ne t'aidera peut etre pas complètement, mais pour faire fonctionner mon iwl3945 qui donne exactement le meme pb, je dois faire un
dhcpcd wlan0, et même parfois un modprobe -r suivi d un modprobe, avant le dhcpcd.

je suis moi aussi en attente d'une solution, qui se trouve peut etre deja sur le forum :D


++
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Jul 01, 2008 3:26 am    Post subject: Reply with quote

lermit wrote:
quand j'utilise la configuration que tu ma donné
j'ai ceux ci
Code:
 /etc/init.d/net.wlan0 restart
 * Stopping wlan0
 *   Bringing down wlan0
 *     Shutting down wlan0 ...                                            [ ok ]
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Starting wlan0
 *   Wireless radio has been killed for interface wlan0
 *   wpa_supplicant will launch, but not associate until
 *   wireles radio is re-enabled for interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported        [ ok ]th param 5 value 0x1 -
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *     Backgrounding ...


Après cela, que te retourne la commande suivante :

Code:

# wpa_cli status
# ifconfig -a
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Jul 01, 2008 3:27 am    Post subject: Re: [WIFI] configuration de iwl4965 avec wpa_supplicant Reply with quote

lermit wrote:
je n'arrive pas a configuré ma carte wifi avec une clef WPA.
ma carte fonctionne correctement. j'ai quelque difficulté a la faire fonctionne avec une clef WEP.


En passant, c'est bien une clé WPA ou une clé WEP, car c'est pas la même config dans wpa_supplicant qu'il faut utiliser.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Jul 01, 2008 3:31 am    Post subject: Reply with quote

Est-tu certain que ton bouton sur ton laptop est bien à on côté wifi ?

Quote:

Wireless radio has been killed for interface wlan0


On dirait que ta switch est off ...donc c'est pour ça que ça plante.
Back to top
View user's profile Send private message
yangranger87
n00b
n00b


Joined: 30 Jun 2008
Posts: 3

PostPosted: Tue Jul 01, 2008 6:55 am    Post subject: Reply with quote

salut
dans ton /etc/conf.d/net, ajoute un -w :
Code:
wpa_supplicant_wlan0="-w -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd"
:

man wpa_supplicant :
-w
wait for interface to be added, if needed. normally, wpa_supplicant will exit if the interface is not there yet.


++
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum