Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KRB] Preauthentication failed while getting initial credent
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Thu Jun 26, 2008 8:01 am    Post subject: [KRB] Preauthentication failed while getting initial credent Reply with quote

Bonjour tout le monde voila je mets un proxy Squid sur une gentoo utilisée en serveur local, et on m'a demandé de le faire fonctionner avec Active Directory...

https://forums.gentoo.org/viewtopic-t-361301.html

J'ai suivi ce tuto mais lors du kinit :
Code:
Kerios davidou # kinit Administrateur
Password for Administrateur@CG2A.ORG:
kinit(v5): Preauthentication failed while getting initial credentials


Si quelqu'un a une idée car la je seche

FQDN Serveur AD/Kerberos : srv1.cg2a.org
Domaine AD : cg2a.org

Voiçi mes fichiers confs :

krb5.conf
Code:
Kerios davidou # cat /etc/krb5.conf
[libdefaults]
        default_realm = CG2A.ORG

[realms]
        CG2A.ORG = {
                kdc = CG2A.ORG
        }
[domain_realms]
        .kerberos.server = SRV1.CG2A.ORG


smb.conf
Code:
Kerios davidou # cat /etc/samba/smb.conf
[global]
   log file = /var/log/samba/log.%m
   load printers = yes
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   map to guest = bad user
   encrypt passwords = yes
   public = yes
   dns proxy = no
   netbios name = Kerios
   printing = cups
   writeable = yes
   path = /home/davidou/Partages/UPLOADS
   workgroup = Workgroup
   os level = 20
   comment = Envois de fichiers
   printcap name = cups
   guest only = yes
   security = user
   max log size = 50

[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = no
   writable = no
   printable = yes

[print$]
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   write list = @adm root
   guest ok = yes

[UPLOADS]

[DOWNLOADS]
   comment = T�l�chargement de fichiers
   path = /home/davidou/Partages/DOWNLOADS


Merçi a vous
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Jun 26, 2008 10:07 am    Post subject: Reply with quote

Salut j'ai trouvé ceci :
Quote:
Matthijs> A couple of days ago i've got this error:
Matthijs> matthijs at server:~$ kinit Password for
Matthijs> matthijs at ACTIVE2.HOMELINUX.ORG: kinit(v5):
Matthijs> Preauthentication failed while getting initial
Matthijs> credentials matthijs at server:~$



Password incorrect or time stamp errors are almost always what is
going on in this case. We have improved the error messages for both
cases in the upcoming Kerberos 1.3 release.


There are some other things that can cause this problem if your KDC
and client have an incompatible set of enctypes. However, I believe
that the 1.2.4-5woody4 packages have enough of the bug fixes for this
problem that you should not see it under normal circumstances unless
you have very old clients talking to your Debian KDC--clients older
than were ever shipped with Debian. Again, these issues are fixed in
the upcoming Kerberos 1.3 release. Installing a new KDC once it is
released should cause old clients to start working.


le lien

EDIT : il n'y a pas de ligne renseignant : realm = DOMAIN.COM dans ton smb.conf, mais cela ne doit pas avoir de rapport puisque d'après le tuto, on configure samba après krb....

EDIT 2 :
y'a pas une erreur là :
Quote:
Kerios davidou # cat /etc/krb5.conf
[libdefaults]
default_realm = CG2A.ORG

[realms]
CG2A.ORG = {
kdc = ServeurKRB.CG2A.ORG
}
[domain_realms]
.kerberos.server = SRV1.CG2A.ORG

_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Fri Jun 27, 2008 7:00 am    Post subject: Reply with quote

ah j'avais pas fait gaffe... je vais essayer ça je tiens au courant des que je peux merci :)
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Mon Jun 30, 2008 7:19 am    Post subject: Reply with quote

Bon et bien ça fonctionne, merçi a toi :)
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum