Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Avviare Gentoo da Usb
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Fri Jun 20, 2008 10:56 am    Post subject: Avviare Gentoo da Usb Reply with quote

Salve a tutti. Devo installare gentoo su un pc che non ha il cdrom, ho seguito questa guida x partire da usb: http://www.gentoo.org/doc/it/liveusb.xml
Tutto bene fino in fondo, quando vado a effettuare il boot da usb però mi dice: Could not find kernel image. Dove sbaglio?

Grazie a tutti


Last edited by Karhot87 on Sun Jun 22, 2008 10:12 am; edited 2 times in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jun 20, 2008 11:33 am    Post subject: Reply with quote

non è facile rispondere, perché le cause possono essere molte.
l'errore è generato dal tuo bootloader (syslinux, credo) che non trova il kernel.

può essere che tu abbia configurato male syslinux, istruendolo a non cercare il kernel nel posto giusto.
può essere che il kernel non ci sia.
può essere che la bios della scheda madre sia male impostata o mal funzionante (talora bisogna aggiornare le bios) e trasmetta informazioni scorrette al bootloader.

prova a vedere se, tra queste cause, ne trovi una che faccia al caso tuo, e ritorna magari con nuove informazioni.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Jul 01, 2008 8:11 pm    Post subject: Reply with quote

Ciao a tutti,

anche io ho un problema a far partire una Gentoo installata su un disco esterno USB.
Ho creato il file initrd, ho creato anche la directory /initrd, ma l'errore che ottengo è:

Code:
mount: error 6 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
Freeing unused kernel memory: 216k freed
Kernel panic - not syncing: No init found. Try passing init= option to kernel

Non so, magari ho sbagliato il grub.conf, magari il disco usb viene visto come /dev/sdb invece che come /dev/sda ... ma non capisco.
Oltretutto non funziona nemmeno ALT-STAMP-B.
Il mio grub.conf è il seguente:
Code:
title=Gentoo Linux (USB) Linux 2.6.24-r8
root (hd1,0)
kernel /kernel-2.6.24-gentoo-r8 root=/dev/sda3 video=vesafb:ywrap,mtrr:3,1024x768-32@60 acpi_sleep=s3_bios pci=assign-busses
initrd (hd1,0)/initrd-2.6.24-gentoo-r8

C'è un howto ufficiale "o quasi" che spieghi come installare la Gentoo su USB esterno?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Tue Jul 01, 2008 9:03 pm    Post subject: Reply with quote

potrebbe essere un problema di initrd. Io ho installato gentoo su usb (/dev/sdb4), utilizzo l'initrd generato con genkernel, di seguito il mio menu-lst:
Code:
title      Gentoo 2.6.24-gentoo-r4 (on /dev/sdb4)
root      (hd1,1)
kernel      /kernel-genkernel-x86-2.6.24-gentoo-r4 root=/dev/ram0 ramdisk=8192 real_root=LABEL=GENTOO quiet init=/linuxrc vga=791 CONSOLE=/dev/tty1 pci=nomsi
initrd      /initramfs-genkernel-x86-2.6.24-gentoo-r4
savedefault
boot

Funziona bene!
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Jul 02, 2008 7:04 am    Post subject: Reply with quote

Non riesco a capire.. Non funziona!
Considera che io il file initrd me lo faccio con mkinitrd (ancora mi chiedo come mai non sia presente mkinitramfs nel portage).
Ho provato a impostare il grub.conf secondo quanto mi hai detto, ma ora ottengo dei messaggi in più rispetto a prima:
Code:
Creating block devices
failed to create /dev/sda
failed to create /dev/sda1
failed to create /dev/sda2
failed to create /dev/sda5
failed to create /dev/sda6
failed to create /dev/sda7
failed to create /dev/sda8
Creating root device
mkrootdev: mknod failed: 30
Mounting root filesystem
mount: error 6 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
Freeing unused kernel memory: 216k freed
Kernel panic - not syncing: Attempted to kill init!

(Ho un'altra Gentoo installata sul disco interno, in /dev/sda ma non capisco come possa andare a leggersi le sue partizioni)
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Jul 02, 2008 9:08 am    Post subject: Reply with quote

Il consiglio che posso darti è di provare a ricompilare con genkernel ed utilizzare il suo initrd, in modo da vedere se il problema è quello (ma dai messaggi, direi proprio di si).
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Jul 02, 2008 9:21 am    Post subject: Reply with quote

La cosa strana è che proprio nemmeno un paio di mesi fa ho fatto le stesse cose con una debian e ho avuto meno problemi.. compilazione del kernel sempre manuale.

Se ci fai caso però, quando dice "failed to create /dev/sda*" è come se stesse cercando di montare le partizioni che sono sul disco interno. Non capisco perché debba andare a cercarsele, visto che la root è un'altra.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Jul 02, 2008 9:28 am    Post subject: Reply with quote

fbcyborg wrote:
La cosa strana è che proprio nemmeno un paio di mesi fa ho fatto le stesse cose con una debian e ho avuto meno problemi.. compilazione del kernel sempre manuale.

Se ci fai caso però, quando dice "failed to create /dev/sda*" è come se stesse cercando di montare le partizioni che sono sul disco interno. Non capisco perché debba andare a cercarsele, visto che la root è un'altra.

Infatti, è come se non riuscisse a creare i node per i /dev/sda, è per questo che sospetto un problema di moduli inseriti nell'initrd.
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Jul 02, 2008 9:34 am    Post subject: Reply with quote

Ok, allora mi sorgono alcune questioni, fra cui:
1) per caso mkinitrd non funziona bene? Su Debian utilizzai mkinitramfs, in quanto mkinitrd era deprecato.
2) forse è possibile (e mi pare proprio che si possa fare) dire esplicitamente quali moduli inserire nell'initrd tramite alcuni parametri da passare a mkinitrd
3) il fatto che tenti di montare /dev/sda* con i numeri che ho riportato non è segno positivo: il mio disco usb esterno ha solo /dev/sdb{1|2|3}. Cosa gliene frega di andare a montare cose che non gli competono?
Scusami ma non vorrei utilizzare genkernel, visto che da sempre compilo manualmente e ad ogni modo deve funzionare lo stesso! Con o senza genkernel.
Grazie per il supporto.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Jul 02, 2008 9:50 am    Post subject: Reply with quote

Prego, ti consiglio di guardare questo articolo per creare un initrd inserendo dentro il necessario per avviare il S.O.. Io l'ho provato con slackware e funziona perfettamente. Magari puoi trarre spunto da lì. :wink:
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Jul 02, 2008 12:22 pm    Post subject: Reply with quote

io uso l'immagine standard di genkernel usando real_root=/dev/disk/... e funziona.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Jul 06, 2008 9:35 am    Post subject: Reply with quote

Quindi non c'è modo di farlo con la compilazione manuale!?

non ci credo! :oops:
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jul 06, 2008 11:18 am    Post subject: Reply with quote

fbcyborg wrote:
Quindi non c'è modo di farlo con la compilazione manuale!?

perché no?

in prima approssimazione, basterebbe compilare i moduli per l'usb builtin nel kernel e aggiungere un ritardo nella linea di boot.
però a volte sorgono problemi di comunicazione tra la bios (magari impostata male, non aggiornata o diffettosa) e il kernel, simili a quelli che stai trovando. dai un occhio qui, che spesso i guasti nascono da conflitti di denominazione dei dischi.
in quei casi torna utile generare una initramfs, come quella di genkernel o un prodotto personalizzato.

tempo fa, avevo prodotto delle elucubrazioni mentali sul tema, adattabili al caso dell'usb e comprensive di uno script automatico per produrre le initramfs.
non è professionale come quello di Tigerwalk, ma contiene dei commenti esplicativi in più.

vedi se ti può dare qualche idea.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Jul 06, 2008 1:26 pm    Post subject: Reply with quote

Grazie.

Ho dato un'occhiata ai link che mi hai suggerito, solo che credo che la mia situazione sia forse un po' più semplice.
In realtà non penso sia un problema di fstab (il disco USB al massimo può essere rilevato come /dev/sda o /dev/sdb, e ho provato a impostarli entrambi), e i moduli per l'USB erano già compilati come built-in.

La cosa strana che non mi torna è che comunque sembra che in qualche modo vada a leggere la tabella delle partizioni del disco interno.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jul 06, 2008 6:22 pm    Post subject: Reply with quote

fbcyborg wrote:

La cosa strana che non mi torna è che comunque sembra che in qualche modo vada a leggere la tabella delle partizioni del disco interno.

alla peggio, staccalo e stai a vedere.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Jul 06, 2008 6:47 pm    Post subject: Reply with quote

mmh.. Non vorrei smontare il portatile...
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jul 07, 2008 2:11 am    Post subject: Reply with quote

fbcyborg wrote:
mmh.. Non vorrei smontare il portatile...

ah, bè.
togliere il disco, nei portatili, è molto più semplice.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Mon Jul 07, 2008 6:22 am    Post subject: Reply with quote

di solito c'è uno sportellino dietro per hdd e ram, basta svitare un paio di viti, non c'è bisogno di aprirlo completamente, e la garanzia (se è questo che ti preoccupa) permane
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Jul 07, 2008 7:28 am    Post subject: Reply with quote

Sì lo so che è facile. So anche come si fa, solo che vorrei evitare di farlo, tutto quì.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jul 07, 2008 6:16 pm    Post subject: Reply with quote

fbcyborg wrote:
solo che vorrei evitare di farlo, tutto quì.

ok. ma sei tu che devi dare un senso compiuto a quella affermazione, che ti va a leggere la tabella delle partizioni sbagliata.
da cosa deduci che accada proprio questo?
chi lo fa? grub, la bios, l'SO?
se grub, il grub del disco rigido o quello della chiavetta? hai provato a usare bootloader diversi, tipo lilo di qua e grub di là?

cosa succede provando a usare le uuid per definire le partizioni?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Jul 07, 2008 6:31 pm    Post subject: Reply with quote

cloc3 wrote:
fbcyborg wrote:
solo che vorrei evitare di farlo, tutto quì.

ok. ma sei tu che devi dare un senso compiuto a quella affermazione, che ti va a leggere la tabella delle partizioni sbagliata.
da cosa deduci che accada proprio questo?
Lo deduco da quanto riportato quì
cloc3 wrote:

chi lo fa? grub, la bios, l'SO?
se grub, il grub del disco rigido o quello della chiavetta? hai provato a usare bootloader diversi, tipo lilo di qua e grub di là?

cosa succede provando a usare le uuid per definire le partizioni?


Comunque mi sono deciso a provare con genkernel.. mi avete convinto. Provo e vi faccio sapere.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Jul 07, 2008 8:31 pm    Post subject: Reply with quote

Ho utilizzato genkernel solo per creare l'initrd e tutto è andato perfettamente.

Comando utilizzato:
Code:
genkernel initrd --slowusb


Ora si avvia che è una meraviglia.

Per fortuna non ho dovuto smontare tutto!

PS: grazie maurs per il suggerimento in pvt.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Tue Jul 08, 2008 7:07 am    Post subject: Reply with quote

fbcyborg wrote:
Ho utilizzato genkernel solo per creare l'initrd e tutto è andato perfettamente.

Comando utilizzato:
Code:
genkernel initrd --slowusb


Ora si avvia che è una meraviglia.

Per fortuna non ho dovuto smontare tutto!

PS: grazie maurs per il suggerimento in pvt.

Finalmente :lol:
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum