Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
utf-8 e il simbolo dell'euro - font per la console
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mirtexxan
n00b
n00b


Joined: 11 Jun 2008
Posts: 2

PostPosted: Thu Jun 12, 2008 2:02 am    Post subject: utf-8 e il simbolo dell'euro - font per la console Reply with quote

Ciao ragazzi! Sono un nuovo utente del forum, ma già da tempo cultore di Gentoo.
Ho una questione riguardante un fastidioso problemino con la codifica utf-8 ed il simbolo dell'euro.
Posto che dopo mille bestemmie sono riuscito ad implementare tutto correttamente (anche seguendo alcuni topic di questo forum), mi rimane un piccolo problemino.

Nelle console "stupide" (quindi non xterm o simili) ho caricato quello che sembra essere l'unico font che traduce correttamente la codifica utf-8, ovvero
LatArCyrHeb-16, che non mi dà nessun problema nelle pagine del man (altri font non mi visualizzavano correttamente i trattini - o gli apostrofi '), mi visualizza correttamente tutte le lettere accentate, ma non ha il font per il simbolo dell'euro,
Lo so che è una sciocchezza ma sono un perfezionista e mi chiedevo se conosceste un font che abbia tutti gli indubbi vantaggi di quello che uso adesso ma che visualizzi anche €.

Oppure, in alternativa, se potreste darmi una mano per modificare un consolefont già esistente.

Ringrazio in anticipo tutti per l'aiuto.

Mirto
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Thu Jun 12, 2008 4:12 pm    Post subject: Reply with quote

Benvenuto!

Hai già letto http://www.gentoo.org/doc/it/utf-8.xml e http://www.gentoo.org/doc/it/guide-localization.xml#doc_chap7 ?
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)


Last edited by .:deadhead:. on Thu Jun 12, 2008 5:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Jun 12, 2008 5:07 pm    Post subject: Reply with quote

le variabili UNICODE in rc.conf e CONSOLETRANSLATION in consolefont come sono impostate? Hai configurato tutto (locale.gen , locales etc.)?
prova lat0-16 come font.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
mirtexxan
n00b
n00b


Joined: 11 Jun 2008
Posts: 2

PostPosted: Thu Jun 12, 2008 10:16 pm    Post subject: Reply with quote

Grazie ragazzi delle risposte puntuali e del benvenuto.
Quote:
Hai già letto http://www.gentoo.org/doc/it/utf-8.xml e http://www.gentoo.org/doc/it/guide-localization.xml#doc_chap7 ?

I suddetti manuali li ho letti e li ho seguiti per quanto mi serviva. In rc.conf:
Code:
UNICODE = yes

Mentre in /etc/conf.d/keymaps:
Code:
CONSOLEFONT="LatArCyrHeb-16"
CONSOLETRANSLATION="8859-15_to_uni"

I locali sono a posto. Lang e i vari Lc sono tutti settati a it_IT.UTF-8 come da guida.
Comunque vi ripeto per il resto tutto funziona alla perfezione, i documenti che salvo sono utf-8, visualizzo tutti i caratteri accentati senza errori compreso anche il man (ma ho dovuto installare man-db).
Il problema è che non trovo un font che mi visualizzi il simbolino dell'euro,
Lat9w-16 ce l'ha ma credo segue 8859-15.
Quote:
prova lat0-16 come font.

lat0-16 ha gli stessi problemi di lat9w-16: mi sbaglia la visualizzazione dei trattini e degli apostrofi (per intenderci " ' " e " - ") nelle pagine del manuale.
Qualche altra idea?
Si può personalizzare il proprio font di caratteri magari aggiungendo a mano il simbolino dell'euro?

Grazie ancora
Mirto
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Apr 20, 2009 10:20 am    Post subject: Reply with quote

Io mi sto configurando UTF8 e dopo aver letto questa guida:
mi sono bloccato al punto dove si chiede di ricompilare il kernel così
Code:

Codice 3.1: Configurazione del Kernel per UTF-8 NLS

File Systems -->
  Native Language Support -->
    (utf8) Default NLS Option
    <*> NLS UTF8
    ( <*> anche altri set di caratteri che sono utilizzati nei filesystem FAT e nei CD-ROM Joilet.)


Ma io nel kernel come Default option mi ritrovo non selezionabile e predefinita una ISO8859-1
Forse è perchè dopo aver sistemato locale devo riemergere le sorgenti ?
Io ho appena seguito le istruzioni per configurare locale e poi mi son fermato a quel punto della guida... boh...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum