Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SAMBA] Problème de partage d'une imprimante (rés)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
VikingB
Apprentice
Apprentice


Joined: 19 May 2006
Posts: 263
Location: ~Brussels (B)

PostPosted: Sat Jan 27, 2007 2:23 pm    Post subject: [SAMBA] Problème de partage d'une imprimante (rés) Reply with quote

Bonjour .
Voici mon problème .
Je suis sous Gentoo, et nous avons une imprimante Canon laser LBP5000 reliée à un PC sous WindowsXP . Les 2 PC sont reliés en réseau .
L'imprimante fonctionne correctement sous WinXP, et je voulais l'utiliser moi aussi depuis mon PC sous Gentoo.
-CUPS configuré, imprimante présente.
-pilotes de Canon : (Canon CAPT printer driver 1.30 ) http://fr.software.canon-europe.com/software/0023675.asp?model=
Je n'ai pas suivi le howto Ubuntu décrit ici
http://doc.ubuntu-fr.org/materiel/imprimante_canon_lbp_2900
https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/CanonPrinters/Canon_LBP_2900
J'ai recopié les fichiers contenus dans les tar.gz du pilote Canon, dans les fichiers correspondants. (/usr et /etc ....)
Dans CUPS, les imprimantes supportées avec ces pilotes apparaissent effectivement lors de la configuration de l'installation de l'imprimante.

Le statut imprimante a l'air correct , et la page de test est correctement envoyée à l'imprimante, mais l'imprimante ne démarre pas, rien ne s'imprime et dans le gestionnaire de l'imprimante du PC Win , aucun document à imprimer n'apparaît .

Voila le contenu de /var/log/cups/error.log

Quote:
I [27/Jan/2007:15:22:04 +0100] Adding start banner page "none" to job 132.
I [27/Jan/2007:15:22:04 +0100] Adding end banner page "none" to job 132.
I [27/Jan/2007:15:22:04 +0100] Job 132 queued on "CanonLBP5000" by "marc".
I [27/Jan/2007:15:22:04 +0100] Started filter /usr/libexec/cups/filter/pstops (PID 32483) for job 132.
I [27/Jan/2007:15:22:04 +0100] Started filter /usr/libexec/cups/filter/pstocapt2 (PID 32484) for job 132.
I [27/Jan/2007:15:22:04 +0100] Started backend /usr/libexec/cups/backend/smb (PID 32485) for job 132.
E [27/Jan/2007:15:22:05 +0100] PID 32484 (/usr/libexec/cups/filter/pstocapt2) stopped with status 1!
I [27/Jan/2007:15:22:05 +0100] Hint: Try setting the LogLevel to "debug" to find out more.
E [27/Jan/2007:15:22:05 +0100] [Job 132] pstocapt2 write error,32.
E [27/Jan/2007:15:22:05 +0100] [Job 132] No ticket cache found for userid=1000
E [27/Jan/2007:15:22:05 +0100] [Job 132] Can not get the ticket cache for marc


Y at-il une commande qui permette par exemple de tester si le pilote est correctement installé ?

Merci de votre aide .


Last edited by VikingB on Sat Jun 14, 2008 10:06 am; edited 3 times in total
Back to top
View user's profile Send private message
VikingB
Apprentice
Apprentice


Joined: 19 May 2006
Posts: 263
Location: ~Brussels (B)

PostPosted: Sat Feb 03, 2007 10:41 am    Post subject: Reply with quote

Quelqu'un a une idée ? Merci !
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1729
Location: 127.0.0.1

PostPosted: Sat Feb 03, 2007 10:53 am    Post subject: Reply with quote

Salut,

J'ai récemment partagé une imprimante laser Canon installée sous WinXP vers une gentoo (je ne me souviens pas du modèle).
Je n'ai absolument rien eu à installer côté gentoo. J'ai simplement suivi le guide d'impression, en particulier ce passage :
Quote:

Configuring a Linux Client for a Windows Print Server

First of all, make sure that the printer is shared on your Windows system.

Next, in the CUPS web interface, configure your printer as described previously. You will notice that CUPS has added another driver called Windows Printer via SAMBA. Select it and use the smb://username:password@workgroup/server/printername or smb://server/printername syntax for the URI.

Malgré cela, çà ne voulait pas imprimer... tout simplement à cause du firewall d'XP qui bloquait ce service sur le réseau local :wink:
Back to top
View user's profile Send private message
VikingB
Apprentice
Apprentice


Joined: 19 May 2006
Posts: 263
Location: ~Brussels (B)

PostPosted: Sun Feb 04, 2007 12:27 pm    Post subject: Reply with quote

Le pare-feu de XP a été désactivé .
Et la configuration a été faite suivant le passage que tu cites.
Back to top
View user's profile Send private message
VikingB
Apprentice
Apprentice


Joined: 19 May 2006
Posts: 263
Location: ~Brussels (B)

PostPosted: Sat Jun 14, 2008 10:06 am    Post subject: Reply with quote

Entre temps et pour ceux que cela intéresse, un wiki sur la lbp5000 et lbp2900 a été publié ici :
http://gentoo-wiki.com/HOWTO_Canon_LBP_5000_using_proprietary_Canon_drivers
http://gentoo-wiki.com/HOWTO_Canon_LBP_2900_using_proprietary_Canon_drivers
Nous avions résolu le problème en envoyant au serveur un fichier ps, converti via ghostscript en imprimable par l'imprimante . Mais j'essaierai la méthode ci-dessus aussi.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum