Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[udev]: udev démarre un service supprimé du runlevel(Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Wed Jun 04, 2008 6:30 am    Post subject: [udev]: udev démarre un service supprimé du runlevel(Résolu) Reply with quote

Bonjour,
Je viens d'installer une carte wifi et j'ai donc supprimé ma carte net.eth1 du runlevel default.
Mais lorsque Gentoo démarre, udev me lance quand même ma connexion eth1 :

Code:
[...]
net.eth1 udev-postmount OK
[...]


J'ai donc 2 interfaces réseau démarrées et pas de connexion. Je suis obligé de faire manuellement un /etc/init.d/net.eth1 stop et là tout rentre dans l'ordre.

Je pensais qu'udev servait au montage des unitées de stockages...

Pouvez-vous m'éclairer sur le problème.

Merci d'avance !


Last edited by anti-conformiste on Thu Jun 05, 2008 5:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Wed Jun 04, 2008 7:36 am    Post subject: Reply with quote

udev ça gère tout le matos, pas que le stockage ;) (et c'est HAL, qui se base sur les évenements d'udev, qui fait le montage auto, pas udev lui-même).

Pour pas que le wifi démarre auto, tu peux mettre un RC_PLUG_SERVICES="!net.eth1" dans /etc/conf.d/rc (si je me souviens bien, ou au pire c'est dans le genre, suffit de chercher un peu), ou rc_plug_services="!net.eth1" dans /etc/rc.conf si t'as openrc.

Sinon, tu peux aussi mettre un wpa_supplicant pour ton wifi, comme ça passe en background direct et ça gène rien au boot :) (et ifplugd pour avoir pareil pour l'ethernet ;p).
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Wed Jun 04, 2008 8:49 pm    Post subject: Reply with quote

geekounet wrote:
udev ça gère tout le matos, pas que le stockage ;) (et c'est HAL, qui se base sur les évenements d'udev, qui fait le montage auto, pas udev lui-même).

Pour pas que le wifi démarre auto, tu peux mettre un RC_PLUG_SERVICES="!net.eth1" dans /etc/conf.d/rc (si je me souviens bien, ou au pire c'est dans le genre, suffit de chercher un peu), ou rc_plug_services="!net.eth1" dans /etc/rc.conf si t'as openrc.

Sinon, tu peux aussi mettre un wpa_supplicant pour ton wifi, comme ça passe en background direct et ça gène rien au boot :) (et ifplugd pour avoir pareil pour l'ethernet ;p).


C'est bien que le wifi démarre automatiquement, c'est la carte réseau rj45 (net.eth1) qui démarre toute seule, lancé par udev.

Comment dire à udev qu'il ne faut pas la démarrer ?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Jun 05, 2008 12:12 pm    Post subject: Reply with quote

Tu as ajouté le !net.eth1 dans le fichier qui va bien comme conseillé ?
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Thu Jun 05, 2008 5:32 pm    Post subject: Reply with quote

J'ai décommenté et adapté la ligne RC_PLUG_SERVICES="!net.eth1" dans le fichier /etc/conf.d/rc et udev ne lance plus la connexion, tout fonctionne comme je le souhaite :D

En fait ce que tu m'a dit geekounet c'est parfait, mais comme a faitu une pitite erreur dans ta phrase "Pour pas que le wifi démarre auto..." et que moi c'était plutôt "Pour pas que le net démarre auto..." je me suis dit que ça n'irait pas donc j'avais pas suivi ton excellent conseil.

Merci à vous 2 pour votre précieuse aide, c'est sympa.
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Thu Jun 05, 2008 5:54 pm    Post subject: Reply with quote

Mais j'insiste pour ifplugd, ça rend la vie plus facile, l'interface démarre en background au boot, donc elle n'en ralenti rien, et dés que tu branches un cable ethernet, ça lance le dhcp tout seul, c'est convi, tu devrais en profiter ;)
Back to top
View user's profile Send private message
RaX
Apprentice
Apprentice


Joined: 16 Aug 2007
Posts: 166

PostPosted: Fri Jun 06, 2008 6:09 am    Post subject: Reply with quote

Sympathique ifplugd, je crois que pour mon portable ça va être nickel.
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Fri Jun 06, 2008 4:39 pm    Post subject: Reply with quote

geekounet wrote:
Mais j'insiste pour ifplugd, ça rend la vie plus facile, l'interface démarre en background au boot, donc elle n'en ralenti rien, et dés que tu branches un cable ethernet, ça lance le dhcp tout seul, c'est convi, tu devrais en profiter ;)


Pourquoi pas, pour l'instant tout fonctionne bien comme ça et je dois dire qu'un /etc/init.d/net.eht1 start n'est pas trop compliqué...
Cela dit, je ne suis pas en dhcp et je ne sais pas si ça fonctionnerait de ce fait. En plus si eth1 démarre alors que wlan0 est lancé aussi, je vais avoir soit un conflit d'ip, soit un Pc avec 2 Ip différentes, impossible donc plantage et on en reviendrait à mon problème de base ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum