Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Перестал работать Eclipse-3.3 (3.2 работает..)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
WebXDev
n00b
n00b


Joined: 15 May 2007
Posts: 54

PostPosted: Wed Jun 04, 2008 3:44 am    Post subject: Перестал работать Eclipse-3.3 (3.2 работает..) Reply with quote

С каких-то пор отрубился Eclipse-3.3 и более не запускается. (раньше 100% работал).
А eclipse-3.2 по сих пор работает.

В чем может быть проблема запуска 3.3?
Вот запуск:
Code:

$ eclipse-3.3
Performing workaround for bug #215150
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f5ef19f463d, pid=6185, tid=1103145296
#
# Java VM: Java HotSpot(TM) 64-Bit Server VM (10.0-b22 mixed mode linux-amd64)
# Problematic frame:
# C  [libc.so.6+0x5e63d]  fgets+0x2d
#
# An error report file with more information is saved as:
# /home/denis/hs_err_pid6185.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#


Сам лог ошибки вот: http://ifolder.ru/6483550

Java-vm такие версии:
Code:
$ eselect java-vm show
Current system-vm
  blackdown-jdk-1.4.2
Current user-vm
  sun-jdk-1.6


sun-jdk-1.6 - компилит и успешно запускает мои небольшие java-программы.

У меня amd64 (Core2Duo).

Что ещё можно привести для попытки решения проблемы?
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Wed Jun 04, 2008 12:05 pm    Post subject: Reply with quote

Поставь system и user vm в одно значение, лучше sun-jdk

И пересобери eclipse
Back to top
View user's profile Send private message
user11
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2005
Posts: 149

PostPosted: Wed Jun 04, 2008 10:26 pm    Post subject: Reply with quote

Отдалённо похожая ситуация (схожий java-стек) из гугла: http://ndion.livejournal.com/13060.html
Если описанный выше рецепт не поможет, то, может, какой workaround придумать, чтобы избежать обращения к принтерам?
Back to top
View user's profile Send private message
WebXDev
n00b
n00b


Joined: 15 May 2007
Posts: 54

PostPosted: Thu Jun 05, 2008 4:18 am    Post subject: Reply with quote

Пересобрал эклипс, поставил:
Code:
$ eselect java-vm list
Available Java Virtual Machines:
  [1]   blackdown-jdk-1.4.2
  [2]   emul-linux-x86-java-1.6
  [3]   sun-jdk-1.6  system-vm user-vm

но нет, не помогло. Я это уже пробовал :) Всё тоже самое остаётся.

А что ещё за принтеры?? нафига он к принтерам подключается? У меня действительно установлен CUPS и принтеры выключены...

Попробовал включить /etc/init.d/cupsd start, эклипс не запустился.. ну эт я так, на всякий случай попробовать :D

А чего же теперь мне можно ещё предпринять?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum