Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[WEP] avec wpa_supplicant(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Tue Jun 03, 2008 11:54 pm    Post subject: [WEP] avec wpa_supplicant(résolu) Reply with quote

Salut les musclés!

Bon j'attque direct, j'ai un problème grave... j'suis chez des gens là avec une freebox, y'a du wifi "protégé" par une clée WEP, (pas la peine de commencer un long débat sur ça hein? ;) ), et j'arrive à m'y connecter lorsque je le fais manuellement:

Pour les besoins de l'exercice, la clée wep est très simple: aaaaa11111, j'avais déjà eu le même problème chez d'autres personnes sans jamais être parvenu à le résoudre, donc j'en appelle à vous...

Code:
iwconfig wlan0 essid freeklynn
iwconfig wlan0 key aaaaa11111

et en général en rebalançant la première de ces deux commandes je me connecte bien:
Code:
wlan0     IEEE 802.11g  ESSID:"freeklynn" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 76:C6:65:20:07:44   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:AAAA-A111-11
          Link Quality=62/100  Signal level=-70 dBm  Noise level=-94 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Ne reste plus après qu'a faire les requètes dhcp, blabalbal.

Donc c'est bien joli, mais avec le script qui va bien, wpa_supplicant, et wpa_cli, on peut avoir tout ça automatiquement normalement (le dhcp aussi dès que le status du 'media' passe à CONNECTED). D'après ce que j'ai pu voir, on peut dire de faire du WEP dans le wpa_supplicant.conf, voici la partie interessante de ce fichier:

Code:
network={
        ssid="freeklynn"
        key_mgmt=NONE
        wep_key0="aaaaa11111"
        wep_tx_keyidx=0
        #auth_alg=SHARED
        #group=WEP40
}


Avec ça, je me connecte apparement bien, pourtant la sortie de iwconfig wlan0 est différente (notamment la clée de chiffrement):
Code:
wlan0     IEEE 802.11g  ESSID:"freeklynn" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 76:C6:65:20:07:44   
          Bit Rate=24 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:6161-6161-6131-3131-3131
          Link Quality=61/100  Signal level=-71 dBm  Noise level=-68 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Mais par contre, le dhcp ne passe pas:
Code:
06/04/08 01:43:14 DHCPREQUEST on wlan0 to 255.255.255.255 port 67
06/04/08 01:43:22 DHCPREQUEST on wlan0 to 255.255.255.255 port 67
06/04/08 01:43:32 option_space_encapsulate: option space agent does not exist, but is configured.
06/04/08 01:43:32 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
06/04/08 01:43:38 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
06/04/08 01:43:52 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
06/04/08 01:44:07 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
06/04/08 01:44:16 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
06/04/08 01:44:32 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
06/04/08 01:44:33 No DHCPOFFERS received.

et En fait rien ne passe tout court, même en fixant les IPs manuellement etc... J'me dis juste que je ne dois pas avoir les bonnes options dans wpa_supplicant.conf, mais j'ai beau chercher, je ne trouve pas ce que je devrais mettre!

I need some help :!: :wink:


Last edited by truc on Wed Jun 04, 2008 10:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
tmasscool
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 151

PostPosted: Wed Jun 04, 2008 1:04 pm    Post subject: Reply with quote

essaie comme ceci dans ton wpa_supplicant.conf

Code:
network={
        ssid="ton_ssid"
        key_mgmt=NONE
        wep_key0="ta_cle_wep"
        wep_tx_keyidx=0
        auth_alg=OPEN
}



et regarde si ton /etc/conf.d/net ressembles à peu près à cela :

Code:

modules_wlan0="wpa_supplicant"
wpa_supplicant_wlan0="-Dwext"
config_wlan0="dhcp"
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Wed Jun 04, 2008 1:25 pm    Post subject: Reply with quote

Je tente le auth_alg=OPEN ce soir, j'vous tiens au courant. merci bien pour cette suggestion!
_________________
The End of the Internet!
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Jun 04, 2008 1:26 pm    Post subject: Reply with quote

Salut, regarde ceci stp :
http://www.neskaya.fr/dotclear/index.php?post/2007/10/24/Jai-quitte-Free

j-2H30 (tictactic les vacances :)
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Wed Jun 04, 2008 1:35 pm    Post subject: Reply with quote

Surtout essaie comme ça dans ton wpa_supplicant.conf :
Code:
network={
        ssid="freeklynn"
        key_mgmt=NONE
        wep_key0=aaaaa11111
        wep_tx_keyidx=0
        #auth_alg=SHARED
        #group=WEP40
}

sans les guillements autour de la clé, sinon c'est considéré comme une chaine de charactères et pas comme une clé hexadécimale, d'où ton résultat dans iwconfig
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Wed Jun 04, 2008 1:41 pm    Post subject: Reply with quote

En fait j'avais essayé aussi sans les guillemets, pour cette raison, mais ça me donnait une erreur de conf, lorsque je lui disais de relire son fichier de conf.

Mais c'est vrai pourtant que ça semblerait plus logique, j'avais peut-être fait une erreur (l'était tard étou..) (l'inconvénient des clées faciles est que tu veux les rentrer manuellement au lieu d'utiliser un bon vieu copier&coller..)

Merci encore :)
_________________
The End of the Internet!
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Wed Jun 04, 2008 2:01 pm    Post subject: Reply with quote

Et si tu mets les lettres en majuscules ?
Chezmoiçamarchecommeça.com
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Wed Jun 04, 2008 10:20 pm    Post subject: Reply with quote

bon, bah je comprends pas tout, j'étais persuadé d'avoir essayé ça déjà hier, mais bon... Donc, en supprimant les guillemets, ça fonctionne effectivement :)


Ce qui reste curieux, c'est que je semblait associé tout de même avec la clée mise entre guillemets (et donc non donnée en Hexa), mais bon... si quelqu'un a une explication, je suis preneur, sinon, je vais classer l'affaire dans les vieux dossiers direct! :)



Merci tout le monde pour le coup de main :)
_________________
The End of the Internet!
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Jun 05, 2008 7:50 am    Post subject: Reply with quote

Me semble qu'on peut être associé à l'AP sans avoir accès à la connexion. Si tu donnes la bonne clef, tu as accès à la connexion... À vérifier.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Jun 05, 2008 11:47 am    Post subject: Reply with quote

kopp wrote:
Me semble qu'on peut être associé à l'AP sans avoir accès à la connexion. Si tu donnes la bonne clef, tu as accès à la connexion... À vérifier.


En effet, on peut s'associé sans être authentifié sur un AP.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum