Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Broken grace package?
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

PostPosted: Mon Apr 22, 2002 11:24 am    Post subject: Broken grace package? Reply with quote

I've just tried to install grace. Typing

emerge --pretend grace

gives me

Calculating dependencies \!!! depgraph.create() error: string format: {'/': 'virtual/x11 >=x11-libs/openmotif-2.1 media-libs/libpng-0.96 >=media-libs/tiff-3.5 pdflib? ( >=media-libs/pdflib-3.0.2 ) virtual/x11 >=x11-libs/openmotif-2.1 media-libs/libpng-0.96 >=media-libs/tiff-3.5 pdflib? ( >=media-libs/pdflib-3.0.2 )'}
[ebuild N ] media-gfx/grace-5.1.7-r1 to /

I went ahead and installed anyway, but got a message that the install was broken.

I don't have time to learn how the package sytem works otherwise I'd have a go at fixing it myself.

Back to top

Joined: 29 May 2002
Posts: 23

PostPosted: Mon Jun 03, 2002 5:12 pm    Post subject: Broken installation Reply with quote

I just had the same problem and went here looking for answers. Which I couldn't find. Luckily, this is handled in the grace FAQ. The installation isn't broken, per se, it's just not complete. Specifically, grace needs to know where to look for fonts. All you need to do is define the environment variable GRACE_HOME. If you're using bash:


export GRACE_HOME="/usr/share/grace"

and everything should work fine after this. Add a similar line to your .bashrc and you should be good to go.

Good luck!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum