Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Impossibile risolvere domain names in IP
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Lo_ou_bien_lola
n00b
n00b


Joined: 31 May 2008
Posts: 4

PostPosted: Sat May 31, 2008 5:08 pm    Post subject: Impossibile risolvere domain names in IP Reply with quote

Salve!
Stiamo affrontando un problema piuttosto ingarbugliato con la nostra piccola rete domestica.
(alleghiamo uno schema, consigliamo di consultarlo :lol: )

http://www.fotoshare.info/image.shtml?image=rete.gif

Stiamo cercando di condividere la connessione ad internet tramite interfaccia IEEE 1394 tra due macchine Gentoo (quelle nel riquadro azzurro).

La prima macchina nel blue box è connessa ad una LAN privata che presenta un singolo accesso ad internet tramite router (che funge anche da DNS); questa macchina (che ha accesso completamente al web) dovrebbe (nelle nostre intenzioni) condividere la connessione internet con la seconda macchina.

Tale seconda macchina non riesce ancora perfettamente ad ottenere la connessione.

Abbiamo installato dnsmasq sul portatile "multihomed" (Gentoo kernel 2.6.24-r8 ).
In questo modo siamo in grado, dalla seconda macchina (Gentoo 2.6.24-r4), di fare il ping di tutti i computer della nostra rete e di tutti i domini internet ma *solo tramite IP address*. Non riusciamo ancora a pingare i domini con i loro nomi o a raggiungerli tramite browser.
Sospettiamo si tratti di un problema circa la definizione e l'uso del corretto DNS, ma non abbiamo idea di come risolverlo.

Riportiamo le righe con cui abbiamo personalizzato il nostro dnsmasq.conf:
Code:
dhcp-range=10.12.1.2,10.12.1.10,infinite
interface=eth2


Seguendo un wiki (http://www.gentoo.org/doc/en/home-router-howto.xml) abbiamo apportato alcuni cambiamenti alla nostra iptable ma senza alcuna cognizione di causa (ammettiamo l'ignoranza ed ammettiamo che potrebbe essere buona parte del problema :roll: )

Code:

First we flush our current rules
# iptables -F
# iptables -t nat -F

Setup default policies to handle unmatched traffic
# iptables -P INPUT ACCEPT
# iptables -P OUTPUT ACCEPT
# iptables -P FORWARD DROP

Copy and paste these examples ...
# export LAN=eth0
# export WAN=eth1

Then we lock our services so they only work from the LAN
# iptables -I INPUT 1 -i ${LAN} -j ACCEPT
# iptables -I INPUT 1 -i lo -j ACCEPT
# iptables -A INPUT -p UDP --dport bootps -i ! ${LAN} -j REJECT
# iptables -A INPUT -p UDP --dport domain -i ! ${LAN} -j REJECT

Drop TCP / UDP packets to privileged ports
# iptables -A INPUT -p TCP -i ! ${LAN} -d 0/0 --dport 0:1023 -j DROP
# iptables -A INPUT -p UDP -i ! ${LAN} -d 0/0 --dport 0:1023 -j DROP

Finally we add the rules for NAT
# iptables -I FORWARD -i ${LAN} -d 192.168.0.0/255.255.0.0 -j DROP
# iptables -A FORWARD -i ${LAN} -s 192.168.0.0/255.255.0.0 -j ACCEPT
# iptables -A FORWARD -i ${WAN} -d 192.168.0.0/255.255.0.0 -j ACCEPT
# iptables -t nat -A POSTROUTING -o ${WAN} -j MASQUERADE
Tell the kernel that ip forwarding is OK
# echo 1 > /proc/sys/net/ipv4/ip_forward
# for f in /proc/sys/net/ipv4/conf/*/rp_filter ; do echo 1 > $f ; done

This is so when we boot we don't have to run the rules by hand
# /etc/init.d/iptables save
# rc-update add iptables default
# nano /etc/sysctl.conf
Add/Uncomment the following lines:
net.ipv4.ip_forward = 1
net.ipv4.conf.default.rp_filter = 1

If you have a dynamic internet address you probably want to enable this:
net.ipv4.ip_dynaddr = 1



Qualcuno è in grado di illuminarci sulle cause e soluzioni di questo problema?

Grazie

Lola
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Jun 01, 2008 3:07 pm    Post subject: Reply with quote

mmh, a parte la mia curiosità sul perchè di una rete simile, sul 10.12.1.2 in /etc/resolv.conf che cosa c'è?
Back to top
View user's profile Send private message
gioi
Apprentice
Apprentice


Joined: 14 Feb 2006
Posts: 236

PostPosted: Tue Jun 03, 2008 6:57 am    Post subject: Reply with quote

Io non vedo da nessuna parte un'istruzione che dica come comportarsi con i DNS... dovresti mettere in /etc/resolv.conf almeno una riga con un DNS server (locale o, se lo raggiungi tramite IP ADDRESS, pubblico).
_________________
--
My blog http://gioitech.wordpress.com
Back to top
View user's profile Send private message
Lo_ou_bien_lola
n00b
n00b


Joined: 31 May 2008
Posts: 4

PostPosted: Fri Jun 06, 2008 7:00 pm    Post subject: Reply with quote

Allora...
per rispondere a The Extremer, questa soluzione di rete è nata semplicemente per aggiungere un portatile ad una rete in cui avevamo un hub a 4 uscite tutte occupate e volevamo risparmiare sull'hardware :lol: visto che avevamo già un cavo e due schede firewire mentre ci mancavano i componenti ethernet.

Poi è diventata una specie di crociata, visto che non è ammissibile che sotto Windows la cosa funzioni perfettamente e sotto il nostro amato Gentooino no :roll: (sì, è vero... c'è un po' di maniacalità in questa frase)

Sul 10.12.1.2 in /etc/resolv.conf c'è solo

Code:

nameserver 10.12.1.1


Ancora, sul 10.12.1.2 in /etc/conf.d/net ci sono le linee seguenti
Code:

config_eth0=("192.168.1.136 netmask 255.255.255.0")
routes_eth0=("default gw 192.168.1.1")

che risalgono a quando quel portatile era al posto dell'attuale 192.168.1.101

Inoltre c'è la linea

Code:
config_eth1=("dhcp")


--------------------------------------------------------------

Per rispondere a gioi, invece, posso dire che nel /etc/resolv.conf del 10.12.1.2 abbiamo provato a mettere un paio di soluzioni
Code:

nameserver 10.12.1.1

(pensavamo funzionasse visto che su 10.12.1.1 abbiamo dnsmasq, invece nulla...)

Code:

nameserver 192.168.1.1

(ugualmente non funziona il ping by name, ma solo by IP-add)

Se il resolv.conf è vuoto dnsmasq popola di default il file con la riga
Code:

nameserver 10.12.1.1

o con la
Code:

nameserver 192.168.1.1

a seconda delle impostazioni che scegliamo sul laptop 10.12.1.1.
Le abbiamo provate entrambe ma senza risultati!
:cry:

Lola
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 837
Location: Villach, Austria

PostPosted: Sat Jun 07, 2008 8:46 am    Post subject: Reply with quote

togli tutto da /etc/resolv.conf e metti solo
nameserver 208.67.222.222

oppure investi 20€ e prendi uno switch :)
Back to top
View user's profile Send private message
gioi
Apprentice
Apprentice


Joined: 14 Feb 2006
Posts: 236

PostPosted: Mon Jun 09, 2008 6:48 am    Post subject: Reply with quote

Premesso che non conosco dnsmasq (preferisco usare Bind, anche se più complesso), com'è configurato? è in grado di accettare connessioni da parte del pc gentoo?
_________________
--
My blog http://gioitech.wordpress.com
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Mon Jun 09, 2008 1:32 pm    Post subject: Reply with quote

Buttando l'occhio così non mi pare ne un problema della configurazione del firewall ne della rete complessa, se ho capito bene il portatile "multihomed" non ha alcun problema e la seconda macchina ha l'unico problema di non risolvere i nomi.

Date queste premesse il problema è unicamente di dnsmasq, cerca di recuperare qualche info da lui.

/EDIT: puoi postare il /etc/resolv.conf e /etc/hosts del portatile "multihomed" ?
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum