Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Module autoloading weirdness
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Abraxa
Apprentice
Apprentice


Joined: 14 Jun 2005
Posts: 172
Location: Germany

PostPosted: Thu Jun 12, 2008 9:37 pm    Post subject: Module autoloading weirdness Reply with quote

Hey all,

I'm facing some difficulties with module autoloading and would be glad if someone could provide me with some clues. My goal is to autoload the thinkpad_acpi module with the "fan_control=1" parameter. For this reason, I added the line

Code:
thinkpad_acpi fan_control=1


to /etc/modules.autoload.d/kernel-2.6 - after a reboot, I can see that the "fan_control=1" parameter was ignored however, as I get a "permission denied" when setting the fan speed. Also, lsmod shows me that the backlight module is loaded and used by thinkpad_acpi. I can unload neither module.

When I do not load the module from within /etc/modules.autoload.d/kernel-2.6, thinkpad_acpi still gets loaded (udev?) but it does not load the backlight module on top of it. So I can unload it and do a "modprobe thinkpad_acpi fan_control=1" manually. When doing that I can set the fan speed, too.

Now I obviously want to do this properly and want to make use of the module autoloading mechanism. The man page for it even says:

Quote:
Arguments can be given on the same line as the module name.


However, they are obviously discarded.
I also tried building the module into the kernel and adding the parameter to the kernel command line - same result, the parameter has no effect.

Am I hitting a bug of some kind or am I missing something here? I'd be happy to get some help.

-Soeren
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6581

PostPosted: Fri Jun 13, 2008 6:25 am    Post subject: Reply with quote

http://www.gentoo.org/doc/en/openrc-migration.xml

something more looking like that

modules="thinkpad_acpi"
module_thinkpad_acpi_args="fan_control=1"
Back to top
View user's profile Send private message
Abraxa
Apprentice
Apprentice


Joined: 14 Jun 2005
Posts: 172
Location: Germany

PostPosted: Fri Jun 13, 2008 6:14 pm    Post subject: Reply with quote

Thanks, but OpenRC is ~x86 and I'd like to stay on stable.

-Soeren
Back to top
View user's profile Send private message
manaka
Apprentice
Apprentice


Joined: 23 Jul 2007
Posts: 178
Location: Spain

PostPosted: Mon Jun 16, 2008 8:00 pm    Post subject: Reply with quote

If I remember well, module autoloading order has changed in the boot process... Now udev processes the events before /etc/modules.autoload.d/ modules are loaded...

I think you best option would be adding a file called /etc/modprobe.d/thinkpad containing the line:
Code:

options thinkpad_acpi fan_control=1


And then running update-modules in order to update /etc/modprobe.conf.
_________________
Javier Miqueleiz

"Listen to your heart. It knows all things, because it came from the Soul of the World, and it will one day return there."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum