Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[wpa_supplicant] Perte de la connexion Wifi (abandon)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Tue May 27, 2008 8:33 am    Post subject: [wpa_supplicant] Perte de la connexion Wifi (abandon) Reply with quote

Bonjour à tous,
je suis face à un problème que je n'avais pas encore rencontré et je ne vois pas bien comment il est arrivé _o_ .

Je perds la connexion Wifi dès que je l'utilise un peu trop.
Si je lance wpa_gui j'ai ce message :
Code:
Could not get status from wpa_supplicant

Si je fais iwconfig j'obtient :
Code:
eth1      unassociated  ESSID:off/any
          Mode:Managed  Frequency=2.457 GHz  Access Point: Not-Associated
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:3  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Si je relance /etc/init.d/net.eth1 je récupère le wifi jusqu'a la prochaine coupure.

Mon conf.d/net :
Code:
dns_domain_lo="mousur.org"

modules=("dhcpd" "!iwconfig" "wpa_supplicant")

config_eth0=( "dhcp" )

wpa_supplicant_eth1="-Dwext"
config_eth1=( "dhcp" )


Mon wpa_supplicant.conf :
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

ap_scan=0
update_config=1
fast_reauth=1

network={
        ssid="mousur_dot_org"
        psk="*******************"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
}


Les modules chargées :
Code:
ieee80211_crypt_tkip     8576  2
ieee80211_crypt_wep     3840  0
ieee80211_crypt_ccmp     5248  0
ipw2200               114608  0


Si vous avez des idées je suis preneur :( .


Last edited by SnowBear on Sun Jun 01, 2008 5:55 am; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu May 29, 2008 11:37 am    Post subject: Reply with quote

Salut, tout d'abord, tu utilises quel kernel ?

De plus, quand ta connexion tombe tu as quoi dans dmesg.

J'ai quelques problèmes des fois avec le kernel 2.6.24 avec le driver Iwl3945, par contre c'est supposé se régler avec le kernel 2.6.25.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu May 29, 2008 1:00 pm    Post subject: Reply with quote

Avec iwl3945 et 2.6.25 j'ai aussi des problèmes, je sais pas si ça vient du routeur ou de mon truc. Parfois je suis obligé de unload/reload le module
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Thu May 29, 2008 4:20 pm    Post subject: Reply with quote

Mon kernel : 2.6.24-tuxonice-r4
Pour le dmesg... je répondrais quand ça aura replanté, ce qui n'est pas le cas actuellement :( mais à première vue il n'y a rien dans le dmesg.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Thu May 29, 2008 4:30 pm    Post subject: Reply with quote

Bon... ayé ça a coupé, résultat rien dans le dmesg.
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Thu May 29, 2008 4:33 pm    Post subject: Reply with quote

Tu peux aussi essayer de sniffer avec Wireshark pour ce qu'il se passe.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Jun 01, 2008 3:31 am    Post subject: Reply with quote

Tu devrais avoir au moins quelque chose du genre Desautotification ou quelque chose qui dit que tu n'est plus associé au routeur.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Sun Jun 01, 2008 5:55 am    Post subject: Reply with quote

d2_racing wrote:
Tu devrais avoir au moins quelque chose du genre Desautotification ou quelque chose qui dit que tu n'est plus associé au routeur.


Absolument rien de rien ;) .

Je suis repassé sur une ancienne sauvegarde d'une gentoo qui été sur cette machine et ça marche _o_ .

Donc pour ce topic : abandon.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Jun 02, 2008 12:04 pm    Post subject: Reply with quote

Tu devrais essayer le kernel 2.6.25-Gentoo-r4 qui est en testing, car moi je n'ai plus de déconnection depuis que roule avec ce kernel.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Mon Jun 02, 2008 12:11 pm    Post subject: Reply with quote

En fait,
sur ma sauvegarde c'est exactement le même noyau que (2.6.24-r4 tuxonice) avec le même .config et ça marche.
Le problème devait venir d'ailleurs.
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Tue Jun 03, 2008 11:35 am    Post subject: Reply with quote

Pas vraiment de réponses concrètes à apporter, je voudrais juste ajouter un petit HS concernant les versions de noyau et le wireless.
Sur mon portable, la carte pcmcia wifi m'impose l'usage de ndiswrapper.
J'utilise aussi wpa_supplicant pour la couche d'authentification.
Kernel 2.6.22 : wifi ok, tout baigne
Kernel 2.6.24 + 2.6.25, nombreuses versions testées : le wifi bloque la plupart du temps au niveau de l'authentification, cela passe très rarement...
Y a t'il un lien de donc relatif concernant le support des kernels récents pour le wifi ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum