Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200805-16 ] OpenOffice.org: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed May 14, 2008 6:26 pm    Post subject: [ GLSA 200805-16 ] OpenOffice.org: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: OpenOffice.org: Multiple vulnerabilities (GLSA 200805-16)
Severity: normal
Exploitable: remote
Date: May 14, 2008
Bug(s): #218080
ID: 200805-16

Synopsis


Multiple vulnerabilities have been reported in OpenOffice.org, possibly
allowing for user-assisted execution of arbitrary code.


Background


OpenOffice.org is an open source office productivity suite, including
word processing, spreadsheet, presentation, drawing, data charting,
formula editing, and file conversion facilities.


Affected Packages

Package: app-office/openoffice
Vulnerable: < 2.4.0
Unaffected: >= 2.4.0
Architectures: All supported architectures

Package: app-office/openoffice-bin
Vulnerable: < 2.4.0
Unaffected: >= 2.4.0
Architectures: All supported architectures


Description


iDefense Labs reported multiple vulnerabilities in OpenOffice.org:

  • multiple heap-based buffer overflows when parsing the "Attribute" and
    "Font" Description records of Quattro Pro (QPRO) files
    (CVE-2007-5745),

  • an integer overflow when parsing the EMR_STRETCHBLT record of an EMF
    file, resulting in a heap-based buffer overflow (CVE-2007-5746),

  • an integer underflow when parsing Quattro Pro (QPRO) files, resulting
    in an excessive loop and a stack-based buffer overflow
    (CVE-2007-5747),

  • and a heap-based buffer overflow when parsing the
    "DocumentSummaryInformation" stream in an OLE file (CVE-2008-0320).

Furthermore, Will Drewry (Google Security) reported vulnerabilities in
the memory management of the International Components for Unicode
(CVE-2007-4770, CVE-2007-4771), which was resolved with GLSA 200803-20.
However, the binary version of OpenOffice.org uses an internal copy of
said library.


Impact


A remote attacker could entice a user to open a specially crafted
document, possibly resulting in the remote execution of arbitrary code
with the privileges of the user running OpenOffice.org.


Workaround


There is no known workaround at this time.


Resolution


All OpenOffice.org users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-office/openoffice-2.4.0"

All OpenOffice.org binary users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-office/openoffice-bin-2.4.0"


References

CVE-2007-4770
CVE-2007-4771
CVE-2007-5745
CVE-2007-5746
CVE-2007-5747
CVE-2008-0320
GLSA 200803-20


Last edited by GLSA on Mon Jun 10, 2013 4:28 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum