Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
не работает сеть
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
geloo
n00b
n00b


Joined: 29 Mar 2008
Posts: 33

PostPosted: Wed May 14, 2008 11:32 am    Post subject: не работает сеть Reply with quote

у меня такая вот проблема с сетью, никак не могу понят в чем же дело.

после пересборки ядра (с 2.6.23-г6 на 2.6.24-г7) перестала работать сеть, проводная. у меня ноут, т.о. Wifi (eth1) и кабель (eth0).

после загрузки системы dmesg пишет
Code:
r8169: eth0: link up
. но сеть не работает. dhclient eth0 ниче не делает, только
Code:
option_space_encapsulate: option space agent doesn't exist, but its configured

и увеличивает интервалы

ifconfig eth0 пишет, что интерфейс АП но нет никакого ip-адреса.

посоветуйте пожалуйста )

спс
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Thu May 15, 2008 6:17 am    Post subject: Reply with quote

Какая версия dhcp-клиента, что за железо?

Вот еще посмотри: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=460837
Back to top
View user's profile Send private message
geloo
n00b
n00b


Joined: 29 Mar 2008
Posts: 33

PostPosted: Thu May 15, 2008 6:59 am    Post subject: Reply with quote

да похожее я уже это гдето видел. У меня стоит пару ядер, и на 2.6.23 все работает, а вот на 2.6.24-г7 вот такая фигня. У меня Asus A6Tc
http://gentoo-wiki.com/HARDWARE_Asus_A6T#Hardware.

Заметил еше такую вещь: когда грузятся службы, вылитает и netmount eth0.bluetouth starting . Может какая-нить коллизия происходит между устройствами или их идентификацией?
Back to top
View user's profile Send private message
_Sir_
Guru
Guru


Joined: 17 Jan 2005
Posts: 337
Location: Russia, Togliatti

PostPosted: Wed May 21, 2008 11:16 am    Post subject: Reply with quote

Насчет имен eth? посмотри /etc/udev/rules.d/70-persistent-net.rules
У меня на Acer Aspire 5101 была на 23-х ядрах фигня, что при попытке инициализации eth0 (ethernet) вообще все висло. Вынеси bluetooth в модули, так кстати HOWTO по голубозубу рекомендует. Ну а я проблему решил при очередном обновлении -- ядро собралось и загрузилось :) А вот из твоего сообщения похоже, что разные сетевые подсистемы решили одно и то же имя устройства себе присвоить :)
_________________
(Sir) * Life is placeholder for Love *
Back to top
View user's profile Send private message
asm64
n00b
n00b


Joined: 25 Apr 2008
Posts: 27
Location: г.Кемерово

PostPosted: Wed Jun 11, 2008 12:27 pm    Post subject: Reply with quote

С MAC адресом сетевой всё нормально или нули? Смотреть dmesg.

Если нули интерфейс не поднимется. Нужно ставить macchanger и в /etc/conf.d/net править адрес, например mac_eth0="00:11:22:33:44:55" или mac_eth0="random-ending". Но в последнем варианте возможно, что udev каждый раз будет переименовывать сетевой интерфейс.
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Fri Jun 13, 2008 2:14 am    Post subject: Reply with quote

asm64 wrote:
Но в последнем варианте возможно, что udev каждый раз будет переименовывать сетевой интерфейс.

Нет, не будет. Он смотри на основной мак-адрес, а не на заменённый.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum