Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Problème avec curl-7.17.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
dentifrice
n00b
n00b


Joined: 12 May 2008
Posts: 1

PostPosted: Mon May 12, 2008 3:13 pm    Post subject: [emerge] Problème avec curl-7.17.1 Reply with quote

La mise à jour via emerge --ask --update world reste bloqué sur curl-7.17.1

Code:
 # emerge --ask --update world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
virtual/dev-manager
                                                                                                      ..           . done!
[ebuild     U ] net-misc/curl-7.17.1 [7.16.4]
[ebuild     U ] net-fs/nfs-utils-1.1.0-r1 [1.0.6-r6] USE="kerberos%* -nonfsv4%"
[ebuild     U ] www-client/links-2.1_pre33 [2.1_pre28-r1] USE="zlib%* -bzip2%"
[ebuild  NS   ] dev-db/phpmyadmin-2.11.5.2  USE="-vhosts"
[ebuild     U ] app-editors/vim-7.1.266 [6.4] USE="acl* -vim-pager%"
[ebuild     U ] sys-apps/slocate-3.1-r1 [2.7-r8]
[ebuild  NS   ] sys-devel/gcc-4.1.2  USE="fortran mudflap nls (-altivec) -bootstrap -build -d -doc -gcj            -gtk (-hardened) -ip28 -ip32r10k -libffi (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc           -gc -test -vanilla"
[ebuild     U ] sys-libs/glibc-2.3.6-r5 [2.3.6-r3] USE="nptlonly*"
[ebuild     U ] dev-perl/Crypt-SSLeay-0.57 [0.55]
[ebuild     U ] dev-perl/libwww-perl-5.805 [5.803-r1]
[ebuild     U ] sys-apps/baselayout-1.12.11.1 [1.11.14-r8] USE="unicode*"
[ebuild     U ] sys-apps/module-init-tools-3.4 [3.2.1] USE="-old-linux%"
[ebuild  N    ] sys-fs/udev-119  USE="(-selinux)"
[ebuild  N    ] sys-kernel/gentoo-sources-2.6.24-r7  USE="-build -symlink"
[ebuild     U ] net-firewall/iptables-1.3.8-r3 [1.3.4] USE="-imq% -l7filter%"

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 15) net-misc/curl-7.17.1 to /
 * curl-7.17.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                            [ ok ]
 * checking ebuild checksums ;-) ...                                                              [ ok ]
 * checking auxfile checksums ;-) ...                                                             [ ok ]
 * checking miscfile checksums ;-) ...                                                            [ ok ]
 * checking curl-7.17.1.tar.bz2 ;-) ...                                                           [ ok ]
>>> Unpacking source...
>>> Unpacking curl-7.17.1.tar.bz2 to /var/tmp/portage/net-misc/curl-7.17.1/work
 * Applying curl-7.16.2-strip-ldflags.patch ...                                                   [ ok ]
 * Applying curl-7.17.1-null-handler-segfault.patch ...                                           [ ok ]
 * Running elibtoolize in: curl-7.17.1
 *   Applying install-sh-1.5.patch ...
 *   Applying portage-1.5.10.patch ...
 *   Applying sed-1.5.6.patch ...
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/net-misc/curl-7.17.1/work/curl-7.17.1 ...
 *
 * ERROR: net-misc/curl-7.17.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2348:  Called die
 * The specific snippet of code:
 *           die 'ldap and kerberos (gssapi) not playing nicely try version >=7.18.1';
 *  The die message:
 *   ldap and kerberos (gssapi) not playing nicely try version >=7.18.1
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/environment'.
 *

 * Messages for package net-misc/curl-7.17.1:

 *
 * ERROR: net-misc/curl-7.17.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2348:  Called die
 * The specific snippet of code:
 *           die 'ldap and kerberos (gssapi) not playing nicely try version >=7.18.1';
 *  The die message:
 *   ldap and kerberos (gssapi) not playing nicely try version >=7.18.1
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/environment'.
 *


Dans le /var/tmp/portage/net-misc/curl-7.17.1/temp/build.log

Code:
>>> Unpacking source...
>>> Unpacking curl-7.17.1.tar.bz2 to /var/tmp/portage/net-misc/curl-7.17.1/work
 ^[[32;01m*^[[0m Applying curl-7.16.2-strip-ldflags.patch ...
^[[A^[[96C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Applying curl-7.17.1-null-handler-segfault.patch ...
^[[A^[[96C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running elibtoolize in: curl-7.17.1
 ^[[32;01m*^[[0m   Applying install-sh-1.5.patch ...
 ^[[32;01m*^[[0m   Applying portage-1.5.10.patch ...
 ^[[32;01m*^[[0m   Applying sed-1.5.6.patch ...
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/net-misc/curl-7.17.1/work/curl-7.17.1 ...
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m ERROR: net-misc/curl-7.17.1 failed.
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m               ebuild.sh, line   49:  Called src_compile
 ^[[31;01m*^[[0m             environment, line 2348:  Called die
 ^[[31;01m*^[[0m The specific snippet of code:
 ^[[31;01m*^[[0m           die 'ldap and kerberos (gssapi) not playing nicely try version >=7.18.1';
 ^[[31;01m*^[[0m  The die message:
 ^[[31;01m*^[[0m   ldap and kerberos (gssapi) not playing nicely try version >=7.18.1
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m If you need support, post the topmost build error, and the call stack if relevant.
 ^[[31;01m*^[[0m A complete build log is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/build.log'.
 ^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/environment'.
 ^[[31;01m*^[[0m


Comment résoudre le problème ?

Je débute avec gentoo

Merci^^


Last edited by dentifrice on Mon May 12, 2008 4:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Mon May 12, 2008 3:23 pm    Post subject: Reply with quote

Commence déjà par mettre un titre conforme aux règles du forum.

Ensuite, essaye simplement de faire ce que l'ebuild demande :
Quote:
ldap and kerberos (gssapi) not playing nicely try version >=7.18.

Sinon, si tu veux absolument garder la version 7.17.1, n'active pas les USE ldap et kerberos.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum