Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hylafax is blocking mgetty [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
snIP3r
l33t
l33t


Joined: 21 May 2004
Posts: 808
Location: germany

PostPosted: Thu Jan 10, 2008 7:30 pm    Post subject: hylafax is blocking mgetty [solved] Reply with quote

hi all!

the recent update of my gentoo box showed my a package conflict of hylafax and mgetty (this package should be updated to 1.1.36-r1). so i deinstalled hylafax, upgraded mgetty and the i wanted to install hylafax again - but i can't

Code:

area52_2 ~ # emerge --pretend hylafax

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] net-misc/hylafax-4.3.0  USE="pam -faxonly -html -jbig -mgetty"
[blocks B     ] net-misc/hylafax (is blocking net-dialup/mgetty-1.1.36-r1)


is there a way to fix this issue? does anyone know why hylafax is compiled with the "-mgetty" use flag? i think i need mgetty to run hylafax?

any help would be appreciated.

greets
snIP3r
_________________
Intel G3220 on ASUS P9D-X
Gentoo Base System 2.2
Kernel 4.12.12-gentoo SMP
-----------------------------------------------
if your problem is fixed please add something like [solved] to the topic!


Last edited by snIP3r on Mon May 12, 2008 7:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
V-Li
Retired Dev
Retired Dev


Joined: 03 Jan 2006
Posts: 604

PostPosted: Fri Jan 11, 2008 5:50 pm    Post subject: Reply with quote

Not necessarily they are both needed...hylafax and mgetty block each other because they conflict in files (file with same name in both packages) on the following conditions:

mgetty build with USE=fax

Disable USE=fax on mgetty (either globally or by package.use).
Back to top
View user's profile Send private message
a_me
n00b
n00b


Joined: 21 Jan 2006
Posts: 43

PostPosted: Mon May 12, 2008 6:17 pm    Post subject: Reply with quote

V-Li wrote:

mgetty build with USE=fax

Disable USE=fax on mgetty (either globally or by package.use).


thanks, that solved it for me as well :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum