Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Madwifi] Problème lors de la compilation (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
krankkatze
n00b
n00b


Joined: 11 May 2008
Posts: 4

PostPosted: Sun May 11, 2008 5:32 pm    Post subject: [Madwifi] Problème lors de la compilation (résolu) Reply with quote

Bonsoir,
Ayant fait l'aquisition d'une carte D-Link DWL G520, je souhaite la faire reconnaître par mon système.
Après m'être renseigné, j'en suis venu à la conclusion qu'il me fallait installer madwifi.
J'ai donc lancé emerge madwifi-ng, et je me suis en premier lieu heurté à des problèmes de configurations du noyau que je suis parvenu à résoudre.
Mais, lors de la compilation, j'obtiens une erreur.
Voici mon build.log :
Code:
>>> Compiling source in /var/tmp/portage/net-wireless/madwifi-ng-0.9.3.3/work/madwifi-0.9.3.3 ...
 * Preparing ath_hal module
../scripts/get_arch.mk:44: *** ARCH mismatch: supplied "x86", determined "i386". Arrêt.
 *
 * ERROR: net-wireless/madwifi-ng-0.9.3.3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3152:  Called linux-mod_src_compile
 *             environment, line 2401:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                                               CC=\"$(get-KERNEL_CC)\"                         
                        LDFLAGS=\"$(get_abi_LDFLAGS)\"                                          ${BUILD_FIXES}                                          ${BUI
LD_PARAMS}                                                 ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAG
S="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS=  KERNELPATH=/lib/modules/2.6.24-gentoo-r7/build all
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-wireless/madwifi-ng-0.9.3.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/madwifi-ng-0.9.3.3/temp/environment'.
 *


Mon emerge --info :
Code:
ortage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.1.1, glibc-2.5-r0, 2.6.24-gentoo-r7 i686)
=================================================================
System uname: 2.6.24-gentoo-r7 i686 Intel(R) Pentium(R) 4 CPU 1.50GHz
Timestamp of tree: Sun, 11 May 2008 16:34:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LANG="fr_FR.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl avahi berkdb cli cracklib crypt cups dbus dri fortran gdbm gnome gpm gtk hal iconv ipv6 isdnlog midi mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl pppd python readline reflection session spl ssl tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvdia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Et enfin le résultat de cat /proc/cpuinfo :
Code:
processor   : 0
vendor_id   : GenuineIntel
cpu family   : 15
model      : 1
model name   : Intel(R) Pentium(R) 4 CPU 1.50GHz
stepping   : 2
cpu MHz      : 1495.168
cache size   : 256 KB
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 2
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm up pebs bts sync_rdtsc
bogomips   : 2993.70
clflush size   : 64


Merci pour votre aide !


Last edited by krankkatze on Sun May 11, 2008 8:52 pm; edited 2 times in total
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun May 11, 2008 6:17 pm    Post subject: Reply with quote

Bienvenue ! :)

Avant tout, voudrais-tu mettre ton titre en conformité avec les règles du forum (voir ma signature) ;)

Pour madwifi-ng : un rapport d'erreur a été soumis sur bugzilla.
Je n'ai fait que parcourir en diagonale mais il semblerait que la version 0.9.4 règle le problème.
Toutefois, cette version est masquée (~x86].
Il faut donc la démasquer en utilisant le fichier /etc/portage/package.keywords ...
Back to top
View user's profile Send private message
krankkatze
n00b
n00b


Joined: 11 May 2008
Posts: 4

PostPosted: Sun May 11, 2008 7:05 pm    Post subject: Reply with quote

Merci beaucoup !
J'ai ajouté les lignes suivantes dans /etc/portage/package.keywords et ça a compilé sans problème.
Code:
net-wireless/madwifi-ng ~x86
net-wireless/madwifi-ng-tools ~x86
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun May 11, 2008 8:34 pm    Post subject: Reply with quote

Puisque ton problème est réglé, tu nous mets un p'tit (résolu) à la fin de ton titre ? ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum