Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Banshee emerge wanting mono
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 05 Jun 2004
Posts: 44

PostPosted: Sat May 03, 2008 9:12 pm    Post subject: [solved] Banshee emerge wanting mono Reply with quote

Out of 102 packages Banshee depended on in order to install, mono (#95) just hangs there using 99.9% of the CPU and I let it run for over 12 hrs with no status change (on a 2.66GHz celeron x86_64).

if test -w ../mcs; then :; else chmod -R +w ../mcs; fi
cd ../mcs && make PROFILES='default net_2_0' CC='x86_64-pc-linux-gnu-gcc' all-profiles
make[3]: Entering directory `/var/tmp/portage/dev-lang/mono-'
make profile-do--default--all profile-do--net_2_0--all
make[4]: Entering directory `/var/tmp/portage/dev-lang/mono-'
make PROFILE=basic all
make[5]: Entering directory `/var/tmp/portage/dev-lang/mono-'
make[6]: *** [build/deps/basic-profile-check.exe] Error 1
make[6]: Entering directory `/var/tmp/portage/dev-lang/mono-'
*** The compiler 'false' doesn't appear to be usable.
*** Trying the 'monolite' directory.
make[7]: Entering directory `/var/tmp/portage/dev-lang/mono-'

Exiting on signal 2

There also seems to be an issue with the source extraction:
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-lang/mono- ...
touch: cannot touch `/var/tmp/portage/dev-lang/mono-': No such file or directory

This is the package listing:
[ebuild N ] gnome-base/libglade-2.6.2 USE="-debug -doc"
[ebuild N ] media-libs/libart_lgpl-2.3.20 USE="-debug"
[ebuild N ] media-libs/gstreamer-0.10.14
[ebuild N ] dev-perl/XML-NamespaceSupport-1.09
[ebuild N ] x11-libs/startup-notification-0.9
[ebuild N ] app-text/build-docbook-catalog-1.2
[ebuild N ] dev-libs/liboil-0.3.12 USE="-doc"
[ebuild N ] sys-apps/dbus-1.1.20 USE="-X -debug -doc (-selinux)"
[ebuild N ] gnome-base/gail-1.20.2 USE="-debug -doc"
[ebuild N ] perl-core/Storable-2.16
[ebuild N ] perl-core/Test-Simple-0.70
[ebuild N ] sys-apps/eject-2.1.5-r1 USE="nls"
[ebuild N ] dev-libs/libxslt-1.1.22 USE="crypt python -debug -examples"
[ebuild N ] dev-libs/libusb-0.1.12-r1 USE="-debug -doc"
[ebuild N ] gnome-base/gnome-common-2.20.0 USE="-debug"
[ebuild N ] gnome-base/gnome-mime-data-2.18.0 USE="-debug"
[ebuild N ] net-misc/neon-0.26.4 USE="nls ssl zlib -expat -kerberos -socks5"
[ebuild NS ] sys-devel/automake-1.8.5-r3
[ebuild N ] dev-libs/libIDL-0.8.10 USE="-debug"
[ebuild N ] app-admin/gamin-0.1.9 USE="-debug"
[ebuild N ] x11-themes/hicolor-icon-theme-0.10
[ebuild N ] dev-perl/XML-LibXML-Common-0.13
[ebuild N ] media-libs/musicbrainz-2.1.4
[ebuild N ] media-libs/audiofile-0.2.6-r3
[ebuild N ] media-libs/libexif-0.6.16-r1 USE="nls -doc"
[ebuild N ] dev-perl/Locale-gettext-1.05
[ebuild N ] dev-python/numeric-24.2-r6 USE="-doc -lapack"
[ebuild N ] dev-python/pycairo-1.4.0 USE="-examples"
[ebuild N ] dev-util/desktop-file-utils-0.14-r1 USE="-emacs"
[ebuild NS ] sys-devel/automake-1.5
[ebuild N ] dev-libs/libcroco-0.6.1 USE="-debug"
[ebuild N ] sys-fs/device-mapper-1.02.22-r5 USE="(-selinux)"
[ebuild N ] sys-apps/pciutils-2.2.10 USE="zlib -network-cron"
[ebuild N ] sys-apps/dmidecode-2.9
[ebuild N ] app-text/iso-codes-1.5
[ebuild N ] sys-devel/bc-1.06-r6 USE="readline -static"
[ebuild N ] net-print/libgnomecups-0.2.2 USE="-debug"
[ebuild N ] media-sound/alsa-headers-1.0.14
[ebuild N ] dev-db/sqlite-3.5.6 USE="threadsafe -debug -doc -soundex -tcl"
[ebuild N ] dev-libs/dbus-glib-0.74 USE="-debug -doc (-selinux)"
[ebuild N ] media-libs/gst-plugins-base-0.10.14 USE="-X -alsa -debug -esd -oss -xv"
[ebuild N ] gnome-base/orbit-2.14.12 USE="-debug -doc"
[ebuild N ] gnome-base/libgnomecanvas- USE="-X -debug -doc"
[ebuild N ] gnome-base/gnome-keyring-2.20.3 USE="pam -debug -doc -hal -test"
[ebuild N ] dev-perl/XML-SAX-0.16
[ebuild N ] app-text/sgml-common-0.6.3-r5
[ebuild N ] app-text/docbook-xsl-stylesheets-1.73.2
[ebuild N ] x11-libs/libwnck-2.20.3 USE="-debug -doc"
[ebuild N ] virtual/perl-Test-Simple-0.70
[ebuild N ] virtual/perl-Storable-2.16
[ebuild N ] sys-apps/help2man-1.36.4 USE="nls"
[ebuild N ] app-text/rarian-0.6.0-r1 USE="-debug"
[ebuild N ] sys-apps/usbutils-0.73 USE="zlib -network-cron"
[ebuild N ] sys-fs/cryptsetup-1.0.5-r1 USE="nls -build -dynamic (-selinux)"
[ebuild N ] x11-libs/libsexy-0.1.11 USE="-debug -doc"
[ebuild N ] gnome-base/libgnomeprint-2.18.4 USE="cups -debug -doc"
[ebuild N ] gnome-base/gconf-2.20.1-r1 USE="-debug -doc -ldap"
[ebuild N ] gnome-base/libbonobo-2.20.4 USE="-debug -doc"
[ebuild NS ] sys-devel/automake-1.9.6-r2
[ebuild N ] dev-perl/XML-LibXML-1.65
[ebuild N ] app-text/scrollkeeper-9999
[ebuild N ] app-text/docbook-xml-dtd-4.4-r1
[ebuild N ] app-text/docbook-xml-dtd-4.1.2-r6
[ebuild N ] media-libs/gst-plugins-good-0.10.6 USE="-debug"
[ebuild N ] media-plugins/gst-plugins-cdparanoia-0.10.14
[ebuild N ] media-libs/gst-plugins-ugly-0.10.6 USE="-debug"
[ebuild N ] gnome-base/gnome-vfs-2.20.1-r1 USE="acl ipv6 ssl -avahi -debug -doc -gnutls -hal -kerberos -samba"
[ebuild N ] dev-python/pygobject-2.14.1 USE="-debug -doc -examples"
[ebuild N ] app-text/gnome-doc-utils-0.12.1 USE="-debug"
[ebuild N ] dev-perl/XML-Simple-2.18
[ebuild N ] x11-misc/notification-daemon-0.3.7 USE="-debug"
[ebuild N ] media-libs/alsa-lib-1.0.14a-r1 USE="midi -alisp -debug -doc" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm"
[ebuild N ] media-plugins/gst-plugins-gconf-0.10.6 USE="-debug"
[ebuild N ] gnome-base/libgnome- USE="-debug -doc -esd"
[ebuild N ] x11-misc/icon-naming-utils-0.8.6
[ebuild N ] dev-python/pygtk-2.12.0 USE="-doc -examples -opengl"
[ebuild N ] gnome-extra/libgsf-1.14.7 USE="bzip2 python -debug -doc -gnome"
[ebuild N ] x11-libs/libnotify-0.4.4 USE="-doc"
[ebuild N ] media-plugins/gst-plugins-gnomevfs-0.10.14
[ebuild N ] media-plugins/gst-plugins-alsa-0.10.14
[ebuild N ] gnome-base/libbonoboui-2.20.0 USE="-X -debug -doc"
[ebuild N ] x11-themes/gnome-icon-theme-2.20.0 USE="-debug"
[ebuild N ] gnome-base/gnome-menus-2.20.3 USE="python -debug"
[ebuild N ] gnome-base/librsvg-2.20.0 USE="zlib -debug -doc -gnome"
[ebuild N ] gnome-base/libgnomeui- USE="-debug -doc -jpeg"
[ebuild N ] gnome-base/libgnomeprintui-2.18.2 USE="-debug -doc"
[ebuild N ] gnome-base/gnome-desktop-2.20.3 USE="-debug -doc"
[ebuild N ] gnome-base/eel-2.20.0 USE="-X -debug"
[ebuild N ] gnome-base/gnome-panel-2.20.3 USE="-debug -doc -eds"
[ebuild N ] gnome-base/nautilus-2.20.0-r1 USE="-X -beagle -debug -esd -gnome -tracker"
[ebuild N ] sys-apps/hal- USE="acpi crypt -debug -dell -disk-partition -doc -pcmcia (-selinux)"
[ebuild N ] app-misc/hal-info-20070618
[ebuild N ] gnome-base/gnome-mount-0.6 USE="-debug -gnome"
[ebuild N ] gnome-extra/nautilus-cd-burner-2.20.0 USE="-cdr -debug -dvdr"
[ebuild N ] dev-lang/mono- USE="nptl -X"
[ebuild N ] dev-dotnet/pe-format-0
[ebuild N ] dev-dotnet/gtk-sharp-2.10.0 USE="-doc"
[ebuild N ] dev-dotnet/gnomevfs-sharp-2.16.0
[ebuild N ] dev-dotnet/art-sharp-2.16.0
[ebuild N ] dev-dotnet/glade-sharp-2.10.0
[ebuild N ] dev-dotnet/gnome-sharp-2.16.0
[ebuild N ] dev-dotnet/gconf-sharp-2.16.0
[ebuild N ] media-sound/banshee-0.12.1 USE="-aac -boo -daap -debug -doc -encode -flac -ipod -mad -njb -vorbis"

:arrow: Does banshee really need mono in order to run?

Last edited by sectoid on Sun May 04, 2008 6:45 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 12 Feb 2005
Posts: 49

PostPosted: Sat May 03, 2008 11:46 pm    Post subject: Reply with quote

Yep. Banshee is written in C# and .NET, so you'll need a runtime for it. Technically mono's not the only one for Linux, but I'm not sure how Portable.NET works out, or how to tell emerge that's the one you plan to use.

I think emerging mono without CFLAGS works. I have the version you need currently installed and I think I had to do CFLAGS="" emerge mono or something like that. Unfortunately I don't know what config file I'd use to set CFLAGS for specific compiles...
Back to top
View user's profile Send private message

Joined: 05 Jun 2004
Posts: 44

PostPosted: Sun May 04, 2008 12:27 am    Post subject: Reply with quote

CFLAGS="" emerge mono hangs at the same spot with process "mono" taking up 99.9% of the cpu...
I'll let it continue to run for a while and maybe it'll do something useful but I don't see why it should be taking so long when everything else completed quickly.
Back to top
View user's profile Send private message

Joined: 05 Jun 2004
Posts: 44

PostPosted: Sun May 04, 2008 6:45 am    Post subject: Reply with quote

Turns out I had enabled CONFIG_SYSVIPC (General Setup -> System V IPC) in the kernel but forgot to copy it over to /boot and restart. :oops: So most likely if you run into a similar issue during the mono compile where "mono" just sits there and eats 99.9% of the CPU, you're missing the above.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum