Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]emerging gcc-4.1.2 immediately after install from...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
peaceful
Apprentice
Apprentice


Joined: 06 Jun 2003
Posts: 287
Location: Utah

PostPosted: Thu May 01, 2008 9:47 pm    Post subject: [solved]emerging gcc-4.1.2 immediately after install from... Reply with quote

I just finished a successful base-installation of Gentoo on a Mac Pro using the amd64 2008_beta2 minimal cd.

Now I've synced and tried to emerge gcc 4.1.2 after turning on my doc and gtk USE flags and get this:

Code:
# emerge -uNpvD gcc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-devel/gcc-4.1.2  USE="doc* fortran gtk* mudflap (multilib) nls (-altivec) -bootstrap -build -d -gcj (-hardened) -ip28 -ip32r10k -libffi% -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 0 kB

...and when actually emerging...


checking for x86_64-pc-linux-gnu-gcc... /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -B/usr/x86_64-pc-linux-gnu/lib/ -isystem /usr/x86_64-pc-linux-gnu/include -isystem /usr/x86_64-pc-linux-gnu/sys-include  -m32
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
make[2]: *** [configure-target-libstdc++-v3] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.1.2/work/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.1.2/work/build'
make: *** [profiledbootstrap] Error 2
 *
 * ERROR: sys-devel/gcc-4.1.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4600:  Called toolchain_src_compile
 *             environment, line 5071:  Called gcc_src_compile
 *             environment, line 2926:  Called gcc_do_make
 *             environment, line 2756:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
 *  The die message:
 *   emake failed with profiledbootstrap
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/environment'.
 *

 * Messages for package sys-devel/gcc-4.1.2:

 *
 * ERROR: sys-devel/gcc-4.1.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4600:  Called toolchain_src_compile
 *             environment, line 5071:  Called gcc_src_compile
 *             environment, line 2926:  Called gcc_do_make
 *             environment, line 2756:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
 *  The die message:
 *   emake failed with profiledbootstrap
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/environment'.
 *
 * GNU info directory index is up-to-date.


I can email or personal-message the build.log and environment files upon request.

Help!?


Last edited by peaceful on Thu May 01, 2008 10:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2391
Location: Wisconsin (USA)

PostPosted: Thu May 01, 2008 10:02 pm    Post subject: Reply with quote

it's trying to use -m32, which compiles 32 bit code (and apparently it compiles ok), but it can't run it. Do you have 32 bit executable support in your kernel?
Back to top
View user's profile Send private message
peaceful
Apprentice
Apprentice


Joined: 06 Jun 2003
Posts: 287
Location: Utah

PostPosted: Thu May 01, 2008 10:58 pm    Post subject: Reply with quote

BradN wrote:
it's trying to use -m32, which compiles 32 bit code (and apparently it compiles ok), but it can't run it. Do you have 32 bit executable support in your kernel?


That was it! For some reason the 32-bit executable stuff was not checked in the kernel. I recompiled it, and now gcc successfully emerges. Thanks!
Back to top
View user's profile Send private message
Darius4all
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jun 2003
Posts: 128
Location: France

PostPosted: Tue May 06, 2008 2:59 pm    Post subject: Reply with quote

edit :
wrong post sorry :p
_________________
Athlon64 3700+ | GeForce 6800GS | 2Go RAM | 2*300Go/Raid 0 | Shuttle SN26P
Core2 Duo T7500 | GeForce 8700M GT | 2Go RAM | 200Go 7200rpm | Clevo M570RU
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum