Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ERROR: kde-base/kdelibs-3.5.9-r3 failed. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bjlockie
Veteran
Veteran


Joined: 18 Oct 2002
Posts: 1186
Location: Canada

PostPosted: Wed Apr 30, 2008 5:01 am    Post subject: ERROR: kde-base/kdelibs-3.5.9-r3 failed. [SOLVED] Reply with quote

/bin/sh ../../libtool --silent --tag=CXX --mode=link x86_64-pc-linux-gnu-g++ -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -pipe -march=k8 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o libartskde.la -rpath /usr/kde/3.5/lib64 -L/usr/kde/3.5/lib64 -L/usr/qt/3/lib64 -L/usr/lib64 -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -version-info 3:0:2 artskde.lo kioinputstream_impl.lo kplayobject.lo kplayobjectfactory.lo kartsfloatwatch.lo kartsdispatcher.lo kaudiorecordstream.lo kaudioplaystream.lo kartsserver.lo kdatarequest_impl.lo kaudioconverter.lo kvideowidget.lo kplayobjectcreator.lo kaudiomanagerplay.lo ../../kio/libkio.la -lqtmcop -lsoundserver_idl
grep: /usr/lib64/libmad.la: No such file or directory
/bin/sed: can't read /usr/lib64/libmad.la: No such file or directory
libtool: link: `/usr/lib64/libmad.la' is not a valid libtool archive
make[3]: *** [libartskde.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r3/work/kdelibs-3.5.9/arts/kde'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r3/work/kdelibs-3.5.9/arts'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r3/work/kdelibs-3.5.9'
make: *** [all] Error 2
*
* ERROR: kde-base/kdelibs-3.5.9-r3 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 4257: Called kde_src_compile
* environment, line 2927: Called kde_src_compile 'all'
* environment, line 3047: Called kde_src_compile 'myconf' 'configure' 'make'
* environment, line 3043: Called die
* The specific snippet of code:
* emake || die "died running emake, $FUNCNAME:make"
* The die message:
* died running emake, kde_src_compile:make
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/kde-base/kdelibs-3.5.9-r3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-3.5.9-r3/temp/environment'.


Last edited by bjlockie on Fri Jun 13, 2008 2:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5997
Location: Pomona, California.

PostPosted: Wed Apr 30, 2008 5:23 am    Post subject: Reply with quote

emerge libmad should get that fixed. You might also want to add 'mad' (without apostrophes) to your USE flags.

Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 411

PostPosted: Wed Apr 30, 2008 7:53 am    Post subject: Reply with quote

Same error here.
(re-)emerge libmad doesn't fix that problem because there is only libmad.a but not libmad.la installed !
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5997
Location: Pomona, California.

PostPosted: Wed Apr 30, 2008 8:38 am    Post subject: Reply with quote

Funny, it's installed for me, and I don't have a problem with my KDE. Perhaps, as I suggested to the originator of this thread, you could put the mad USE flag into your /etc/make.conf and try to compile libmad again.

EDIT:I just finished compiling the newest version of libmad and guess what; libmad.la was installed where it belongs. Now I get to see if revdep-rebuild is going to hork up a fur ball over that upgrade.

EDIT 2: Yep, it sure did!

Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 352
Location: Den Haag, Netherlands

PostPosted: Wed Apr 30, 2008 9:39 pm    Post subject: Reply with quote

drizzt wrote:
Same error here.
(re-)emerge libmad doesn't fix that problem because there is only libmad.a but not libmad.la installed !

Here also.
So i copied libmad.la from the portage temp dir myself.
But...
now I get another error:
Code:
/bin/sh ../../libtool --silent --tag=CXX --mode=link i686-pc-linux-gnu-g++  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=athlon-xp -O2 -pipe -msse -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o libartskde.la -rpath /usr/kde/3.5/lib -L/usr/kde/3.5/lib -L/usr/qt/3/lib     -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -version-info 3:0:2 artskde.lo kioinputstream_impl.lo kplayobject.lo kplayobjectfactory.lo kartsfloatwatch.lo kartsdispatcher.lo kaudiorecordstream.lo kaudioplaystream.lo kartsserver.lo kdatarequest_impl.lo kaudioconverter.lo kvideowidget.lo kplayobjectcreator.lo kaudiomanagerplay.lo ../../kio/libkio.la -lqtmcop -lsoundserver_idl
libtool: link: warning: `/lib/libacl.la' seems to be moved
libtool: link: warning: `/lib/libattr.la' seems to be moved
i686-pc-linux-gnu-g++: /usr/lib/.libs/libmad.so: No such file or directory
make[3]: *** [libartskde.la] Fout 1
make[3]: Map '/mnt/data/tmp/portage/kde-base/kdelibs-3.5.9-r3/work/kdelibs-3.5.9/arts/kde' wordt verlaten


/usr/lib/.libs/.. ???



--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
dpshak
Apprentice
Apprentice


Joined: 05 May 2005
Posts: 170
Location: Wisconsin

PostPosted: Thu May 01, 2008 3:40 am    Post subject: Reply with quote

I ran into the same problem with libmad. What worked for me was re-emerging alsa, libmad then kdelibs. Problem solved. And yep, revdep-rebuild coughed up a WHOLE BUNCH of of stuff that needed to be redone! Hopefully it works for you!
Back to top
View user's profile Send private message
younker
Apprentice
Apprentice


Joined: 18 Feb 2004
Posts: 273
Location: China

PostPosted: Thu May 01, 2008 5:40 am    Post subject: Reply with quote

I encountered the same problem, I have checked the ebuild of libmad while it deletes the .la file when install, so maybe kdelibs ebuild need do some modification?
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5997
Location: Pomona, California.

PostPosted: Thu May 01, 2008 7:45 am    Post subject: Reply with quote

What's troubling is I think that updating libmad made my alsa go bye-bye. I tried re-emerging all the alsa goodies, and still, no sound. Finally, I went back to the previous version, and voila, sound came back. I'm going to try it again tomorrow to see if it's a bug-report-worthy thing.

Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2535

PostPosted: Sun May 04, 2008 7:31 pm    Post subject: Reply with quote

I'm struggling with this same problem. The only advice on this thread I haven't tried yet is to add USE=mad. I'm doing that right now, but IMO if the MAD ebuild doesn't keep the files around, it won't matter if USE=mad right?

Thanks.

Edit:

My build just failed with USE=mad. As well, of all the things which needed to be updated, none of them had a mad USE flag.
Back to top
View user's profile Send private message
energyman76b
Advocate
Advocate


Joined: 26 Mar 2003
Posts: 2045
Location: Germany

PostPosted: Sun May 04, 2008 9:14 pm    Post subject: Reply with quote

well, only install the stable libmad - that solves the 'problem' or install the latest libmad, the revdep-rebuilt, then kdelibs. If that does not help, open a bug reports. b.g.o is there for a reason.
_________________
Study finds stunning lack of racial, gender, and economic diversity among middle-class white males

I identify as a dirty penismensch.
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2535

PostPosted: Sun May 04, 2008 10:18 pm    Post subject: Reply with quote

Shoot.

I for some reason enabled ~x86 globally, and forgot why. I must have had some sort of emergency, because I would never do that on a production box.

Thanks for the heads-up. I have a lot of rebuilding to do, I think.
Back to top
View user's profile Send private message
chil
n00b
n00b


Joined: 08 Jul 2006
Posts: 9

PostPosted: Mon May 05, 2008 10:20 am    Post subject: Reply with quote

From the libmad changelog...

Quote:
18 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+libmad-0.15.1b-r5.ebuild:
Revision bump to drop libtool .la files.


I masked the r5 ebuild, emerged libmad-0.15.1b-r4 and kdelibs now builds successfully.
Back to top
View user's profile Send private message
energyman76b
Advocate
Advocate


Joined: 26 Mar 2003
Posts: 2045
Location: Germany

PostPosted: Mon May 05, 2008 10:52 am    Post subject: Reply with quote

esearch libmad
[ Results for search key : libmad ]
[ Applications found : 1 ]

* media-libs/libmad
Latest version available: 0.15.1b-r5
Latest version installed: 0.15.1b-r5

ls /var/db/pkg/kde-base/kdelibs-*
/var/db/pkg/kde-base/kdelibs-3.5.9-r3:
/var/db/pkg/kde-base/kdelibs-4.0.3-r1:

;)
_________________
Study finds stunning lack of racial, gender, and economic diversity among middle-class white males

I identify as a dirty penismensch.
Back to top
View user's profile Send private message
enito
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2005
Posts: 79

PostPosted: Wed May 07, 2008 5:09 pm    Post subject: Reply with quote

HI same here, still have trouble in emerge kdelibs :(

Making all in kfile
make[4]: Entering directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r4/work/kdelibs-3.5.9/kio/misc/kfile'
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../dcop -I../../../kdecore -I../../../kio/kssl -I../../../kjs -I../../.. -I../../../kio/kio -I../../../dcop -I../../../libltdl -I../../../kdefx -I../../../kdecore -I../../../kdecore -I../../../kdecore/network -I../../../kdeui -I../../../kio -I../../../kio/kio -I../../../kio/kfile -I../../.. -I/usr/qt/3/include -I. -I/usr/kde/3.5/include -DQT_THREAD_SUPPORT -D_REENTRANT -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=athlon64 -mmmx -m3dnow -pipe -O2 -fomit-frame-pointer -mfpmath=sse -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -c -o fileprops.o fileprops.cpp
/bin/sh ../../../libtool --silent --tag=CXX --mode=link x86_64-pc-linux-gnu-g++ -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=athlon64 -mmmx -m3dnow -pipe -O2 -fomit-frame-pointer -mfpmath=sse -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o kfile -L/usr/kde/3.5/lib64 -L/usr/qt/3/lib64 -L/usr/lib64 -R /usr/kde/3.5/lib64 -R /usr/kde/3.5/lib64 -R /usr/qt/3/lib64 -R /usr/lib64 fileprops.o ../../../kio/libkio.la
fileprops.o: In function `printSupportedMimeTypes()':
fileprops.cpp:(.text+0xd77): undefined reference to `std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, long)'
fileprops.cpp:(.text+0xe22): undefined reference to `std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, long)'
fileprops.cpp:(.text+0xe94): undefined reference to `std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, long)'
fileprops.o: In function `printList(QStringList const&)':
fileprops.cpp:(.text+0xf84): undefined reference to `std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, long)'
fileprops.o: In function `processMetaDataOptions(QPtrList<FileProps>, KCmdLineArgs*)':
fileprops.cpp:(.text+0x1253): undefined reference to `std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, long)'
fileprops.o:fileprops.cpp:(.text+0x1290): more undefined references to `std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, long)' follow
collect2: ld returned 1 exit status
make[4]: *** [kfile] Error 1
make[4]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r4/work/kdelibs-3.5.9/kio/misc/kfile'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r4/work/kdelibs-3.5.9/kio/misc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r4/work/kdelibs-3.5.9/kio'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.9-r4/work/kdelibs-3.5.9'
make: *** [all] Error 2
*
* ERROR: kde-base/kdelibs-3.5.9-r4 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 4244: Called kde_src_compile
* environment, line 2914: Called kde_src_compile 'all'
* environment, line 3034: Called kde_src_compile 'myconf' 'configure' 'make'
* environment, line 3030: Called die
* The specific snippet of code:
* emake || die "died running emake, $FUNCNAME:make"
* The die message:
* died running emake, kde_src_compile:make
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/kde-base/kdelibs-3.5.9-r4/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-3.5.9-r4/temp/environment'.
*

* GNU info directory index is up-to-date.


any tip?
thx a lot
Back to top
View user's profile Send private message
bjlockie
Veteran
Veteran


Joined: 18 Oct 2002
Posts: 1186
Location: Canada

PostPosted: Fri Jun 13, 2008 2:28 pm    Post subject: Reply with quote

Fixed, I downgraded libmad.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum