Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200804-27 ] SILC: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu Apr 24, 2008 5:26 pm    Post subject: [ GLSA 200804-27 ] SILC: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: SILC: Multiple vulnerabilities (GLSA 200804-27)
Severity: normal
Exploitable: remote
Date: April 24, 2008
Bug(s): #212362, #214116, #214812
ID: 200804-27

Synopsis

Multiple vulnerabilities were found in SILC Client, Server, and Toolkit, allowing for Denial of Service and execution of arbitrary code.

Background

SILC (Secure Internet Live Conferencing protocol) Toolkit is a software development kit for use in clients, SILC Server is a communication server, and SILC Client is an IRSSI-based text client.

Affected Packages

Package: net-im/silc-toolkit
Vulnerable: < 1.1.7
Unaffected: >= 1.1.7
Architectures: All supported architectures

Package: net-im/silc-client
Vulnerable: < 1.1.4
Unaffected: >= 1.1.4
Architectures: All supported architectures

Package: net-im/silc-server
Vulnerable: < 1.1.2
Unaffected: >= 1.1.2
Architectures: All supported architectures


Description

  • Nathan G. Grennan reported a boundary error in SILC Toolkit within the silc_fingerprint() function in the file lib/silcutil/silcutil.c when passing overly long data, resulting in a stack-based buffer overflow (CVE-2008-1227).
  • A vulnerability has been reported in SILC Server which is caused due to an error in the handling of "NEW_CLIENT" packets that do not contain a nickname (CVE-2008-1429).
  • Ariel Waissbein, Pedro Varangot, Martin Mizrahi, Oren Isacson, Carlos Garcia, and Ivan Arce of Core Security Technologies reported that SILC Client, Server, and Toolkit contain a vulnerability in the silc_pkcs1_decode() function in the silccrypt library (silcpkcs1.c), resulting in an integer underflow, signedness error, and a buffer overflow (CVE-2008-1552).


Impact

A remote attacker could exploit these vulnerabilities to cause a Denial of Service or execute arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All SILC Toolkit users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/silc-toolkit-1.1.7"
All SILC Client users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/silc-client-1.1.4"
All SILC Server users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/silc-server-1.1.2"


References

CVE-2008-1227
CVE-2008-1429
CVE-2008-1552
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum