Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
need help restoring
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
panik08
n00b
n00b


Joined: 18 Apr 2008
Posts: 9

PostPosted: Sat Apr 19, 2008 5:46 am    Post subject: need help restoring Reply with quote

So, I accidently emerge -C coreutils and managed to get some of the files back, but when I boot I see the message
INIT: switching to runlevel 3:
but instead of seeing a lot of messages and a green OK after them, I directly get a login prompt with the
text: unknown host at unknown domain etc.
and the login says:
login: (IIRC?)
and I enter "root" but then nothing happens.
So... I think I need to reemerge stuff to fix things, but how do I do that?
My only access to the system right now is through the RIP Linux boot CD (great stuff!) and mounting the / partition.
So, any ideas?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Sat Apr 19, 2008 6:02 am    Post subject: Reply with quote

Do not try to recover it piecemeal, restore the whole package.

Download the package appropriate for the architecture of the system from tinderbox, unpack it into the root directory, then reinstall the package.

Moved from Portage & Programming to Duplicate Threads, refer to topic "Killed my coreutils -- HELP".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum