Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[fglrx] Pas d'accélération 3D
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Thu Apr 17, 2008 9:10 pm    Post subject: [fglrx] Pas d'accélération 3D Reply with quote

Bonsoir,
je vous expose mon problème en espérant trouver une solution ici ! :)
Alors voilà, je suis sous Gentoo donc avec un kernel 2.6.23.
J'ai un ordinateur Dell Inspiron 1501, tout marche très bien sauf l'accélération 3D (je dispose d'une carte graphique ATI Xpress 1150).
J'ai installé le paquet "x11-drivers/ati-drivers" version 8.471.3 mais celà ne marche toujours pas.
Avant j'avais le 8.455.2-r1 mais je n'avais toujours pas d'accélération 3D.
Je me retrouve avec le même message d'erreur dans mon dmesg :
Code:
[fglrx] Maximum main memory to use for locked dma buffers: 803 MBytes.
[fglrx] ASYNCIO init succeed!
[fglrx] PAT is enabled successfully!
[fglrx] module loaded - fglrx 8.42.3 [Oct 19 2007] on minor 0
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
ACPI: PCI Interrupt 0000:01:05.0[A] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
[fglrx:firegl_init_pcie] *ERROR* Invalid GART type 0.
Clocksource tsc unstable (delta = -150026880 ns)

J'ai essayé de chercher à quoi ça correpondrait, mais je n'ai vraisembablement rien trouvé.
Je précise que je suis avec un xorg-server en version 1.4.0.90-r3 et de xorg-x11 en version 7.3 !
En vous remerciant d'avance ! :D
Back to top
View user's profile Send private message
nokernel
n00b
n00b


Joined: 19 Jul 2004
Posts: 18
Location: Québec

PostPosted: Fri Apr 18, 2008 12:10 am    Post subject: Reply with quote

Est-ce que ton kernel à le module agpgart de chargé?

Je crois que tu dois utilise le agpgart qui provient de ton driver, donc ne par charger le agpgart du kernel.
Back to top
View user's profile Send private message
SlashRhumSlashNeisson
Apprentice
Apprentice


Joined: 30 Dec 2006
Posts: 200
Location: Lille

PostPosted: Fri Apr 18, 2008 4:33 am    Post subject: Reply with quote

+1 nokernel

Code:
grep AGP /usr/src/linux/.config


Code:

CONFIG_AGP=m
CONFIG_AGP_ATI=m


Ensuite dans ton /etc/modules.autoload.d/kernel-2.6 tu ajoutes

Code:

fglrx
ati-agp
agpgart

_________________
Gentoo only
Back to top
View user's profile Send private message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Fri Apr 18, 2008 2:34 pm    Post subject: Reply with quote

Merci pour toutes ces reponses, mais je ne serais pas chez moi avant une ou 2 semaines donc je testerai en ce temps la !
Merci encore :D
Back to top
View user's profile Send private message
nokernel
n00b
n00b


Joined: 19 Jul 2004
Posts: 18
Location: Québec

PostPosted: Sat Apr 19, 2008 2:36 am    Post subject: Reply with quote

SlashRhumSlashNeisson wrote:
+1 nokernel

Code:
grep AGP /usr/src/linux/.config


Code:

CONFIG_AGP=m
CONFIG_AGP_ATI=m


Ensuite dans ton /etc/modules.autoload.d/kernel-2.6 tu ajoutes

Code:

fglrx
ati-agp
agpgart


Merci pour les détails, je veux bien aider, mais j'ai tendance à être avard des petits détails.
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Apr 20, 2008 1:29 am    Post subject: Reply with quote

sephiroth2 wrote:
Merci pour toutes ces reponses, mais je ne serais pas chez moi avant une ou 2 semaines donc je testerai en ce temps la !
Merci encore :D



Utilise le driver libre dès que possible, fglrx capucpalibreetcapu :lol:
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Mon Apr 21, 2008 7:43 pm    Post subject: Reply with quote

Il n'y a pas l'acceleration 3D avec xorg-server en version 1.4 et xorg-x11 en version 7.3 avec le driver libre radeon :(
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Mon Apr 21, 2008 8:08 pm    Post subject: Reply with quote

Hum ça c'est normal oui, radeon c'est de 7200 à x800 je crois. Pour les cartes plus récentes faut le driver radeonHD, mais lui non plus n'a pas encore la 3D (ils planchent justement dessus).
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Mon Apr 21, 2008 10:03 pm    Post subject: Reply with quote

kwenspc wrote:
Hum ça c'est normal oui, radeon c'est de 7200 à x800 je crois. Pour les cartes plus récentes faut le driver radeonHD, mais lui non plus n'a pas encore la 3D (ils planchent justement dessus).



très juste ;)


http://radeonhd.org

:lol:
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Mon Apr 28, 2008 5:49 pm    Post subject: Reply with quote

Code:
sephiroth@dell ~ $ grep AGP /usr/src/linux/.config
CONFIG_AGP=m
# CONFIG_AGP_ALI is not set
CONFIG_AGP_ATI=m
# CONFIG_AGP_AMD is not set
# CONFIG_AGP_AMD64 is not set
# CONFIG_AGP_INTEL is not set
# CONFIG_AGP_NVIDIA is not set
# CONFIG_AGP_SIS is not set
# CONFIG_AGP_SWORKS is not set
# CONFIG_AGP_VIA is not set
# CONFIG_AGP_EFFICEON is not set

Donc c'est bon !

Mais j'ai toujours ce problème
Code:
[fglrx:firegl_init_pcie] *ERROR* Invalid GART type 0.


J'ai donc aussi mis comme dit dans /etc/modules.autoload.d/kernel-2.6:
Code:
fglrx
ati-agp
agpgart


Je mets aussi mon xorg.conf au cas où:
Code:
Section "ServerLayout"

        Identifier     "Main Layout"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Touchpad" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"

        InputDevice    "USB Mouse" "SendCoreEvents"
EndSection

Section "Files"

        FontPath     "/usr/share/fonts/local"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/75dpi"
        FontPath     "/usr/share/fonts/100dpi"
        FontPath     "/usr/share/fonts/corefonts"
        FontPath     "/usr/share/fonts/cyrillic"
        FontPath     "/usr/share/fonts/default"
        FontPath     "/usr/share/fonts/dejavu"
        FontPath     "/usr/share/fonts/ttf-bitstream-vera"
EndSection

Section "Module"

        Load  "dbe"
        SubSection "extmod"
                Option      "omit xfree86-dga"
        EndSubSection
        Load  "type1"
        Load  "freetype"

        Load  "ddc"
        Load  "dri"


        Load  "extmod"
        Load  "glx"
        Load  "bitmap"
        Load  "record"

        Load "synaptics"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
        Option          "SendCoreEvents"        "true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
EndSection

Section "ServerFlags"
#       Option "AIGLX" "false"
        Option "AIGLX" "true"
        Option      "blank time" "10"   # 10 minutes
        Option      "standby time" "20"
        Option      "suspend time" "30"
        Option      "off time" "60"
        Option "AllowMouseOpenFail" "true"
EndSection

Section "InputDevice"

        Identifier  "Keyboard1"
        Driver      "keyboard"
        Option "XbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "fr"

        Option      "CoreKeyboard"
EndSection

Section "InputDevice"

        Identifier  "Touchpad"
        Driver      "synaptics"
        Option      "Protocol" "auto-dev"
        Option      "Device" "/dev/psaux"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
    Option          "XAANoOffscreenPixmaps" "true"
    Option          "VideoOverlay" "on"
    Option          "TexturedXrender" "true"

EndSection

Section "Device"
        Identifier  "vesa"
        Driver      "vesa"

EndSection

Section "Device"
        Identifier  "radeon"
        Driver      "radeon"
        Option "RenderAccel" "true"
        Option "DRI" "true"
        Option "MergedDPI" "96 96"
        Option "XAANoOffscreenPixmaps" "true"
        Option "HWCursor" "true"
        Option "ColorTiling" "on"
#       Option "AccelMethod" "EXA"
        Option "EnablePageFlip" "on"
#       Option "GARTSize" "64"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
#       Device     "radeon"
#       Device     "vesa"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                ViewPort   0 0
                Depth     24
        EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection

Section "Extensions"
### fglrx
 Option "Composite" "enable"
# Option "Composite" "disable"
### Driver libre
# Option "Composite" "enable"
# Option "RENDER" "enable"
###
EndSection


Je voulais aussi dire que avec le kernel 2.6.24 j'ai le direct rendering, mais j'aimerais savoir pourquoi il n'est pas sous le 2.6.23 :?

Et dans le Xorg.0.log je trouve ceci:(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
(WW) fglrx(0): could not detect X server version (query_status=-3)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

Code:

(II) fglrx(0): Acceleration enabled
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used
(II) fglrx(0): Direct rendering disabled


Et aussi:
Code:
cat /var/log/Xorg.0.log | grep WW
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension MIT-SCREEN-SAVER
(EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1007)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.

Merci de votre aide :P
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Mon Apr 28, 2008 8:43 pm    Post subject: Reply with quote

GPS ??????
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Tue Apr 29, 2008 3:58 pm    Post subject: Reply with quote

loopx wrote:
GPS ??????


Bah oui Global Positioning System

Ok je ---->[]
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Tue Apr 29, 2008 7:19 pm    Post subject: Reply with quote

C'est encore moi !
Après désinstallation de fglrx et mis radeon ben ça marche :D
Donc je le garde, parcontre je remarque que la 3D rame plus qu'avant quand je l'utilisais !
Mais dans le log de Xorg.0.log, voici ce que je trouve:
Code:
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/r300_dri.so: undefined symbol: __driCreateNewScreen_20050727)

Je ne sais pas à quoi correspond cette erreur !
De plus, je veux réemerger mesa-9999 sauf que je me prends une erreur au milieu de la compilation:
Code:
dri2.c:38:38: erreur: X11/extensions/dri2proto.h : Aucun fichier ou répertoire de ce type
dri2.c:43: erreur: ‘DRI2_NAME’ undeclared here (not in a function)
dri2.c: In function ‘DRI2QueryVersion’:
dri2.c:81: erreur: ‘xDRI2QueryVersionReply’ undeclared (first use in this function)
dri2.c:81: erreur: (Each undeclared identifier is reported only once
dri2.c:81: erreur: for each function it appears in.)
dri2.c:81: erreur: expected ‘;’ before ‘rep’
dri2.c:82: erreur: ‘xDRI2QueryVersionReq’ undeclared (first use in this function)
dri2.c:82: erreur: ‘req’ undeclared (first use in this function)
dri2.c:82: erreur: opérandes invalides pour le binaire *
dri2.c:87: erreur: ‘sz_xDRI2QueryVersionReq’ undeclared (first use in this function)
dri2.c:87: erreur: opérandes invalides pour le binaire +
dri2.c:87: erreur: expected expression before ‘)’ token
dri2.c:87: erreur: opérandes invalides pour le binaire *
dri2.c:87: erreur: called object ‘<erroneous-expression>’ is not a function
dri2.c:87: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:87: erreur: ‘X_DRI2QueryVersion’ undeclared (first use in this function)
dri2.c:87: erreur: request for member ‘length’ in something not a structure or union
dri2.c:87: erreur: opérandes invalides pour le binaire +
dri2.c:87: erreur: utilisation invalide d'un tableau n'étant pas membre gauche
dri2.c:88: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:89: erreur: request for member ‘dri2ReqType’ in something not a structure or union
dri2.c:90: erreur: request for member ‘majorVersion’ in something not a structure or union
dri2.c:90: erreur: ‘DRI2_MAJOR’ undeclared (first use in this function)
dri2.c:91: erreur: request for member ‘minorVersion’ in something not a structure or union
dri2.c:91: erreur: ‘DRI2_MINOR’ undeclared (first use in this function)
dri2.c:92: erreur: ‘rep’ undeclared (first use in this function)
dri2.c:97: erreur: request for member ‘majorVersion’ in something not a structure or union
dri2.c:97: attention : assignment makes integer from pointer without a cast
dri2.c:98: erreur: request for member ‘minorVersion’ in something not a structure or union
dri2.c:98: attention : assignment makes integer from pointer without a cast
dri2.c: In function ‘DRI2Connect’:
dri2.c:109: erreur: ‘xDRI2ConnectReply’ undeclared (first use in this function)
dri2.c:109: erreur: expected ‘;’ before ‘rep’
dri2.c:110: erreur: ‘xDRI2ConnectReq’ undeclared (first use in this function)
dri2.c:110: erreur: ‘req’ undeclared (first use in this function)
dri2.c:110: erreur: opérandes invalides pour le binaire *
dri2.c:115: erreur: ‘sz_xDRI2ConnectReq’ undeclared (first use in this function)
dri2.c:115: erreur: opérandes invalides pour le binaire +
dri2.c:115: erreur: expected expression before ‘)’ token
dri2.c:115: erreur: opérandes invalides pour le binaire *
dri2.c:115: erreur: called object ‘<erroneous-expression>’ is not a function
dri2.c:115: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:115: erreur: ‘X_DRI2Connect’ undeclared (first use in this function)
dri2.c:115: erreur: request for member ‘length’ in something not a structure or union
dri2.c:115: erreur: opérandes invalides pour le binaire +
dri2.c:115: erreur: utilisation invalide d'un tableau n'étant pas membre gauche
dri2.c:116: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:117: erreur: request for member ‘dri2ReqType’ in something not a structure or union
dri2.c:118: erreur: request for member ‘screen’ in something not a structure or union
dri2.c:119: erreur: ‘rep’ undeclared (first use in this function)
dri2.c:125: erreur: request for member ‘sareaHandle’ in something not a structure or union
dri2.c:125: attention : assignment makes integer from pointer without a cast
dri2.c:127: erreur: request for member ‘driverNameLength’ in something not a structure or union
dri2.c:127: attention : passing argument 1 of ‘malloc’ makes integer from pointer without a cast
dri2.c:130: erreur: request for member ‘driverNameLength’ in something not a structure or union
dri2.c:130: erreur: opérandes invalides pour le binaire &
dri2.c:131: erreur: request for member ‘busIdLength’ in something not a structure or union
dri2.c:131: erreur: opérandes invalides pour le binaire &
dri2.c:131: erreur: opérandes invalides pour le binaire +
dri2.c:131: attention : passing argument 2 of ‘_XEatData’ makes integer from pointer without a cast
dri2.c:136: erreur: request for member ‘driverNameLength’ in something not a structure or union
dri2.c:136: attention : passing argument 3 of ‘_XReadPad’ makes integer from pointer without a cast
dri2.c:137: erreur: request for member ‘driverNameLength’ in something not a structure or union
dri2.c:137: erreur: l'indice du tableau n'est pas un entier
dri2.c:139: erreur: request for member ‘busIdLength’ in something not a structure or union
dri2.c:139: attention : passing argument 1 of ‘malloc’ makes integer from pointer without a cast
dri2.c:142: erreur: request for member ‘busIdLength’ in something not a structure or union
dri2.c:142: erreur: opérandes invalides pour le binaire &
dri2.c:142: attention : passing argument 2 of ‘_XEatData’ makes integer from pointer without a cast
dri2.c:147: erreur: request for member ‘busIdLength’ in something not a structure or union
dri2.c:147: attention : passing argument 3 of ‘_XReadPad’ makes integer from pointer without a cast
dri2.c:148: erreur: request for member ‘busIdLength’ in something not a structure or union
dri2.c:148: erreur: l'indice du tableau n'est pas un entier
dri2.c:153: erreur: request for member ‘sareaHandle’ in something not a structure or union
dri2.c: In function ‘DRI2AuthConnection’:
dri2.c:159: erreur: ‘xDRI2AuthConnectionReq’ undeclared (first use in this function)
dri2.c:159: erreur: ‘req’ undeclared (first use in this function)
dri2.c:159: erreur: opérandes invalides pour le binaire *
dri2.c:160: erreur: ‘xDRI2AuthConnectionReply’ undeclared (first use in this function)
dri2.c:160: erreur: expected ‘;’ before ‘rep’
dri2.c:165: erreur: ‘sz_xDRI2AuthConnectionReq’ undeclared (first use in this function)
dri2.c:165: erreur: opérandes invalides pour le binaire +
dri2.c:165: erreur: expected expression before ‘)’ token
dri2.c:165: erreur: opérandes invalides pour le binaire *
dri2.c:165: erreur: called object ‘<erroneous-expression>’ is not a function
dri2.c:165: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:165: erreur: ‘X_DRI2AuthConnection’ undeclared (first use in this function)
dri2.c:165: erreur: request for member ‘length’ in something not a structure or union
dri2.c:165: erreur: opérandes invalides pour le binaire +
dri2.c:165: erreur: utilisation invalide d'un tableau n'étant pas membre gauche
dri2.c:166: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:167: erreur: request for member ‘dri2ReqType’ in something not a structure or union
dri2.c:168: erreur: request for member ‘screen’ in something not a structure or union
dri2.c:169: erreur: request for member ‘magic’ in something not a structure or union
dri2.c:170: erreur: ‘rep’ undeclared (first use in this function)
dri2.c:170: erreur: request for member ‘authenticated’ in something not a structure or union
dri2.c:179: erreur: request for member ‘authenticated’ in something not a structure or union
dri2.c:179: attention : return makes integer from pointer without a cast
dri2.c: In function ‘DRI2CreateDrawable’:
dri2.c:186: erreur: ‘xDRI2CreateDrawableReply’ undeclared (first use in this function)
dri2.c:186: erreur: expected ‘;’ before ‘rep’
dri2.c:187: erreur: ‘xDRI2CreateDrawableReq’ undeclared (first use in this function)
dri2.c:187: erreur: ‘req’ undeclared (first use in this function)
dri2.c:187: erreur: opérandes invalides pour le binaire *
dri2.c:192: erreur: ‘sz_xDRI2CreateDrawableReq’ undeclared (first use in this function)
dri2.c:192: erreur: opérandes invalides pour le binaire +
dri2.c:192: erreur: expected expression before ‘)’ token
dri2.c:192: erreur: opérandes invalides pour le binaire *
dri2.c:192: erreur: called object ‘<erroneous-expression>’ is not a function
dri2.c:192: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:192: erreur: ‘X_DRI2CreateDrawable’ undeclared (first use in this function)
dri2.c:192: erreur: request for member ‘length’ in something not a structure or union
dri2.c:192: erreur: opérandes invalides pour le binaire +
dri2.c:192: erreur: utilisation invalide d'un tableau n'étant pas membre gauche
dri2.c:193: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:194: erreur: request for member ‘dri2ReqType’ in something not a structure or union
dri2.c:195: erreur: request for member ‘drawable’ in something not a structure or union
dri2.c:196: erreur: ‘rep’ undeclared (first use in this function)
dri2.c:204: erreur: request for member ‘handle’ in something not a structure or union
dri2.c:204: attention : assignment makes integer from pointer without a cast
dri2.c:205: erreur: request for member ‘head’ in something not a structure or union
dri2.c:205: attention : assignment makes integer from pointer without a cast
dri2.c: In function ‘DRI2DestroyDrawable’:
dri2.c:213: erreur: ‘xDRI2DestroyDrawableReq’ undeclared (first use in this function)
dri2.c:213: erreur: ‘req’ undeclared (first use in this function)
dri2.c:213: erreur: opérandes invalides pour le binaire *
dri2.c:220: erreur: ‘sz_xDRI2DestroyDrawableReq’ undeclared (first use in this function)
dri2.c:220: erreur: opérandes invalides pour le binaire +
dri2.c:220: erreur: expected expression before ‘)’ token
dri2.c:220: erreur: opérandes invalides pour le binaire *
dri2.c:220: erreur: called object ‘<erroneous-expression>’ is not a function
dri2.c:220: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:220: erreur: ‘X_DRI2DestroyDrawable’ undeclared (first use in this function)
dri2.c:220: erreur: request for member ‘length’ in something not a structure or union
dri2.c:220: erreur: opérandes invalides pour le binaire +
dri2.c:220: erreur: utilisation invalide d'un tableau n'étant pas membre gauche
dri2.c:221: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:222: erreur: request for member ‘dri2ReqType’ in something not a structure or union
dri2.c:223: erreur: request for member ‘drawable’ in something not a structure or union
dri2.c: In function ‘DRI2ReemitDrawableInfo’:
dri2.c:231: erreur: ‘xDRI2ReemitDrawableInfoReply’ undeclared (first use in this function)
dri2.c:231: erreur: expected ‘;’ before ‘rep’
dri2.c:232: erreur: ‘xDRI2ReemitDrawableInfoReq’ undeclared (first use in this function)
dri2.c:232: erreur: ‘req’ undeclared (first use in this function)
dri2.c:232: erreur: opérandes invalides pour le binaire *
dri2.c:237: erreur: ‘sz_xDRI2ReemitDrawableInfoReq’ undeclared (first use in this function)
dri2.c:237: erreur: opérandes invalides pour le binaire +
dri2.c:237: erreur: expected expression before ‘)’ token
dri2.c:237: erreur: opérandes invalides pour le binaire *
dri2.c:237: erreur: called object ‘<erroneous-expression>’ is not a function
dri2.c:237: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:237: erreur: ‘X_DRI2ReemitDrawableInfo’ undeclared (first use in this function)
dri2.c:237: erreur: request for member ‘length’ in something not a structure or union
dri2.c:237: erreur: opérandes invalides pour le binaire +
dri2.c:237: erreur: utilisation invalide d'un tableau n'étant pas membre gauche
dri2.c:238: erreur: request for member ‘reqType’ in something not a structure or union
dri2.c:239: erreur: request for member ‘dri2ReqType’ in something not a structure or union
dri2.c:240: erreur: request for member ‘drawable’ in something not a structure or union
dri2.c:241: erreur: ‘rep’ undeclared (first use in this function)
dri2.c:249: erreur: request for member ‘head’ in something not a structure or union
dri2.c:249: attention : assignment makes integer from pointer without a cast
make[3]: *** [dri2.o] Erreur 1
make[3]: quittant le répertoire « /var/tmp/portage/media-libs/mesa-9999/work/mesa-9999/src/glx/x11 »
make[2]: *** [subdirs] Erreur 1
make[2]: quittant le répertoire « /var/tmp/portage/media-libs/mesa-9999/work/mesa-9999/src »
make[1]: *** [default] Erreur 1
make[1]: quittant le répertoire « /var/tmp/portage/media-libs/mesa-9999/work/mesa-9999 »
make: *** [linux-dri-x86] Erreur 2
 *
 * ERROR: media-libs/mesa-9999 failed.
 * Call stack:
 *          ebuild.sh, line 1701:  Called dyn_compile
 *          ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *          ebuild.sh, line   44:  Called src_compile
 *   mesa-9999.ebuild, line  243:  Called die
 * The specific snippet of code:
 *      emake -j1 ${CONFIG} || die "Build failed"
 *  The die message:
 *   Build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/mesa-9999/temp/build.log'.
 *

 * Messages for package media-libs/mesa-9999:

 *
 * ERROR: media-libs/mesa-9999 failed.
 * Call stack:
 *          ebuild.sh, line 1701:  Called dyn_compile
 *          ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *          ebuild.sh, line   44:  Called src_compile
 *   mesa-9999.ebuild, line  243:  Called die
 * The specific snippet of code:
 *      emake -j1 ${CONFIG} || die "Build failed"
 *  The die message:
 *   Build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/mesa-9999/temp/build.log'.
 *

Malgrès un direct rendering: Yes

Si vous pouvez m'aider, ce serait avec plaisir !
Merci :)
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Apr 29, 2008 7:26 pm    Post subject: Reply with quote

D'où tu sors mesa-9999 toi? 8O Ce serais pas un ebuild venant d'un overlay? vérifies que tu utilises bien l'arbre portage officiel et pas des overlays à côté.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Tue Apr 29, 2008 7:35 pm    Post subject: Reply with quote

J'utilise un overlay en effet :D
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Tue Apr 29, 2008 7:44 pm    Post subject: Reply with quote

GPS GPS ???? 8O 8O 8O :o
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Apr 29, 2008 7:45 pm    Post subject: Reply with quote

Eh bah cherches pas l'erreur alors... l'ebuild est totalement instable (ainsi que le source qu'il tente d'installer)

(et la compile n'a rien à voir avec le fait d'avoir le DRI ou non)
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Tue May 06, 2008 8:37 pm    Post subject: Reply with quote

Bon ben je vais attendre le futur mesa 7.0.4 car ma carte vient d'être supportée par compiz fusion avec ce nouveau mesa:
http://www.phoronix.com/scan.php?page=news_item&px=NjQ2MA
Bref, utilisez le driver radeon ! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum