Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] packet bloqué... je pête un câble ![resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Thu Apr 17, 2008 8:45 am    Post subject: [emerge] packet bloqué... je pête un câble ![resolu] Reply with quote

Salut

Voilà je viens de mettre à jour mon système à jour et le verbose d'emerge me renvoie ce message.
Et comme à chaque fois, même si j'ai bien lu la doc je ne comprends pas comment m'en sortir tout seul sans faire appelle au forum.
Qui bloque qui ? A cause de quoi ? Bref je me fais des noeuds à la tête.

Quelle méthode appliquez-vous pour résoudre ce genre de problèmes.
Merci de m'aider à devenir autonome sur ce genre de cas particuliers car là je pête mon câble sinon !

Code:
[blocks B     ] sys-apps/mktemp (is blocking sys-apps/coreutils-6.10-r1)
[blocks B     ] >=sys-apps/coreutils-6.10 (is blocking sys-apps/mktemp-1.5)

Total: 37 packages (33 upgrades, 3 new, 1 in new slot, 2 blocks), Size of downloads: 68,503 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Last edited by BENJI on Tue Apr 22, 2008 2:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 114

PostPosted: Thu Apr 17, 2008 8:48 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-687976.html

C'est pas comme si a chaque "blocking" yavait 10 post sur le forums ;)
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Thu Apr 17, 2008 8:55 am    Post subject: Re: [emerge] packet bloqué... je pête un câble ! Reply with quote

BENJI wrote:
Et comme à chaque fois, même si j'ai bien lu la doc je ne comprends pas comment m'en sortir tout seul sans faire appelle au forum.
Qui bloque qui ? A cause de quoi ? Bref je me fais des noeuds à la tête.

Tu lis le changelog de chacun des paquets concernés par le blocage, en général c'est expliqué ;)
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Apr 17, 2008 8:58 am    Post subject: Reply with quote

Surtout, surtout ne pas desinstaller core-utils hein, juste au cas où...
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Thu Apr 17, 2008 10:39 am    Post subject: Re: [emerge] packet bloqué... je pête un câble ! Reply with quote

geekounet wrote:

Tu lis le changelog de chacun des paquets concernés par le blocage, en général c'est expliqué ;)

Question bête peut-être : Comment savoir ou il est et quel est celui qui m'intéresse ?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Apr 17, 2008 10:46 am    Post subject: Reply with quote

Code:
/usr/portage/category/paquet/ChangeLog

Et ceux intéressants sont ceux des paquets qui bloquent.
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Thu Apr 17, 2008 11:11 am    Post subject: Reply with quote

Ou sinon l'option --changelog d'emerge avant d'effectuer la mise à jour.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Thu Apr 17, 2008 11:48 am    Post subject: Reply with quote

Juste parce que j'y ai été confronté deux fois dernièrement : il suffit d'unmerger mktemp, puis de mettre à jour coreutils (la mise à jour de ce dernier reprend les fonctionnalités de mktemp).
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Apr 18, 2008 7:19 am    Post subject: Reply with quote

Merci pour l'aide c'est résolu.

J'ai juste un dernier message mais que j'avais déjà avant et à qui je voudrais tordre le coup maintenant.
Code:

These are the packages that would be merged, in order:

Calculating world dependencies /
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
x11-wm/compiz


Je crois que mon frère avait essayé de m'installer compiz, il m'avait dit avoir tout remis à plat mais on dirait qu'il y a un petit reste. Comme je n'y ai pas trempé dedans... je ne sais pas ce qu'il faut modifier.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8039
Location: ~Brussels - Belgique

PostPosted: Fri Apr 18, 2008 8:07 am    Post subject: Reply with quote

si tu n'en as pas besoin, tu fais
Code:
emerge -C compiz

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Delvin
Guru
Guru


Joined: 07 Jul 2004
Posts: 546

PostPosted: Fri Apr 18, 2008 9:28 am    Post subject: Reply with quote

Un petit emerge depclean suivi d'un revdep rebuild pour nettoyer aprés peut être pas mal non plus.
_________________
Ne tirez pas sur les canards !!
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Fri Apr 18, 2008 9:34 am    Post subject: Reply with quote

emerge -C mktemp && emerge coreutils


validé ^^
Back to top
View user's profile Send private message
Delvin
Guru
Guru


Joined: 07 Jul 2004
Posts: 546

PostPosted: Fri Apr 18, 2008 9:38 am    Post subject: Reply with quote

emerge --oneshot coreutils plutôt non ? (ça doit bien être en dépendance d'un paquet d'autre truc)
_________________
Ne tirez pas sur les canards !!
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Apr 18, 2008 9:39 am    Post subject: Reply with quote

Oui, ça fait partie du profil system, c'est inutile donc de l'avoir dans world.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Apr 18, 2008 8:18 pm    Post subject: Reply with quote

Bon maintenant que j'ai fait tout ce que vous m'avez dit
Code:
emerge -C compiz
Un petit emerge depclean suivi d'un revdep rebuild pour nettoyer aprés peut être pas mal non plus.

voilà où en est la situation
Code:
ataualpa ~ # emerge -DuvaN world

These are the packages that would be merged, in order:

Calculating world dependencies /
!!! All ebuilds that could satisfy ">=x11-wm/compiz-0.6.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-wm/compiz-0.6.2-r1 (masked by: ~x86 keyword)
- x11-wm/compiz-0.6.2 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-libs/libcompizconfig-0.6.0" [installed])



!!! Problem resolving dependencies for x11-apps/ccsm
!!! Depgraph creation failed.

je fais quoi maintenant ?
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Fri Apr 18, 2008 8:33 pm    Post subject: Reply with quote

Code:
!!! Problem resolving dependencies for x11-apps/ccsm


Vire x11-apps/ccsm
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Apr 22, 2008 2:22 pm    Post subject: Reply with quote

Des fois je me demande si j'ai pas de la M.rd. dans les yeux !

C'est bon c'est résolu !

Merci.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum