Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi XFS [Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Tue Apr 15, 2008 2:26 pm    Post subject: Problemi XFS [Risolto] Reply with quote

Ho appena reinstallato gentoo sul mio laptop dell ed ho usato per la prima volta il filesystem xfs.
Sia la partizione di / che la /home le ho formattate così:
Code:
mkfs.xfs -fl version=2,size=64m /dev/sda2
mkfs.xfs -fl version=2,size=64m /dev/sda3
Il problema è che la root viene montata, la home no.
All'avvio mi dà questo avviso:
Code:
 * Mounting local filesystems ...
mount: wrong fstype, bad option, bad superblock on /dev/sda3,
missing codepage or other error
 * Some local filesystem failed to mount [!!]

Il mio fstab è
Code:
/dev/sda1      /boot      ext3      defaults,noatime                   1 2
/dev/sda2      /      xfs   defaults,noatime,nodiratime,logbsize=64      0 1
/dev/sda3    /home           xfs   defaults,noatime,nodiratime,logbsize=64         0 1
/dev/sda4      none      swap      sw      0 0

Non serve mettere logbsize=32 come dice la guida di !equilibrium al punto 4, non và lo stesso.
Però se dopo l'avvio del sistema faccio un
Code:
mount /dev/sda3 /home
funziona e sono riuscito anche a scrivere un file di testo come prova all'interno.
Perchè le opzioni di montaggio valgono per la /, ma non per /home?
Ho provato anche a riformattare la partizione, ma niente...

---------------------------------

EDIT:

Togliendo completamente l'opzione logbsize la partizione viene montata...ma continuo a non capire perchè / sì e /home no...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)


Last edited by canduc17 on Tue Apr 15, 2008 7:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Tue Apr 15, 2008 5:49 pm    Post subject: Reply with quote

smonta, rimonta e mostra l'output di
Code:
tail /var/log/messages
probabilmente nei log ci troverai la spiegazione.
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Tue Apr 15, 2008 7:26 pm    Post subject: Reply with quote

Mancava una maledettissima k:
Code:
logbsize=64k

Però non capisco perchè per / non faceva differenza una k di meno...

Chissenefrega, passiamo al problema successivo...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum