Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mktemp blocking coreutils
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Apr 15, 2008 9:52 am    Post subject: mktemp blocking coreutils Reply with quote

Ho appena syncato e mi sono trovato un bel blocco riguardante i pacchetti nel titolo.
Come scritto qui segnalo che la soluzione corretta è:
Code:

# emerge -C mktemp
# emerge -DuNav world


Spero di prevenire qualche affrettata rimozione delle coreutils (non esattamente immediate da rimettere).

Bye
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Tue Apr 15, 2008 9:55 am    Post subject: Re: mktemp blocking coreutils Reply with quote

Onip wrote:
Spero di prevenire qualche affrettata rimozione delle coreutils (non esattamente immediate da rimettere).


PRIMO! :P

Per fortuna mi sono salvato con l'altro pc :roll:



sono un idiota :(
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Tue Apr 15, 2008 10:06 am    Post subject: Reply with quote

Anch'io stavo per fare l'errore, ma poi google ha detto no...
La stessa cosa era successa un paio di mesi fa con setarch e util-linux...
Back to top
View user's profile Send private message
codadilupo
Advocate
Advocate


Joined: 05 Aug 2003
Posts: 3135

PostPosted: Tue Apr 15, 2008 11:49 am    Post subject: Reply with quote

scusate, ma mktemp blocca l'aggiornamento delle coreutils, perchè mai dovrei rimuovere queste ultime :-P ?
Per altro, si fa davvero motlo in fretta a dare un
Code:
quickpkg mktemp; emerge -C mktemp; emerge -uDN world; emerge --depclean -p
per scoprire che mktemp non viene nuovamente richiesto dalle debianutils (nonostante sia indicato come loro dipendenza da equery) :-D

Coda
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Tue Apr 15, 2008 3:21 pm    Post subject: Reply with quote

codadilupo wrote:
scusate, ma mktemp blocca l'aggiornamento delle coreutils, perchè mai dovrei rimuovere queste ultime :-P ?


Perché veniva visualizzato un doppio blocco: coreutils blocca mktemp e viceversa.
Dipende da quale linea guardi prima.

Se malauguratamente servisse a qualcuno in questo thread sul forum internazionale c'é il link a un pacchetto binario.
_________________
Ciao da me!
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Apr 15, 2008 4:10 pm    Post subject: Reply with quote

codadilupo wrote:
scusate, ma mktemp blocca l'aggiornamento delle coreutils, perchè mai dovrei rimuovere queste ultime :-P ?


randomaze wrote:
Perché veniva visualizzato un doppio blocco: coreutils blocca mktemp e viceversa.


Esattamente, mi sono dimenticato di scriverlo nel primo post :oops:
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Tue Apr 15, 2008 5:30 pm    Post subject: Reply with quote

aggiungo: la ragione di questo blocco immediato sta nel fatto che ora mktemp incluso nelle coreutils.
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
Alucard13
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2005
Posts: 87
Location: Pisa

PostPosted: Mon Jun 09, 2008 8:33 pm    Post subject: Reply with quote

Scusate se riapro il thread, ma ho un problema conseguentemente hai comandi:

Code:

# emerge -C mktemp
# emerge -DuNav world


durante l'aggiornamento del sistema mi da un'errore quando arriva a emergere kbd:


Code:


checking for alarm... yes
checking for memset... yes
checking for setlocale... yes
checking for strcasecmp... yes
checking for strchr... yes
checking for strdup... yes
checking for strerror... yes
checking for strspn... yes
checking for strstr... yes
checking for strtol... yes
checking for strtoul... yes
configure: creating ./config.status
./config.status: line 469: mktemp: command not found

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-apps/kbd-1.14.1-r1/work/kbd-1.14.1/config.log
 *
 * ERROR: sys-apps/kbd-1.14.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2023:  Called econf '--enable-nls'
 *               ebuild.sh, line  526:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/kbd-1.14.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/kbd-1.14.1-r1/temp/environment'.
 *



Sembra che si blocca perchè non trova mktemp...
Premetto che ho appena installato e questo è il primo riavvio...
Grazie..
_________________
Un'uomo potra' sempre sentirsi ricco se qualcuno disegnera le sue gesta!!
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Jun 09, 2008 9:08 pm    Post subject: Reply with quote

prova con
Code:
# emerge -1u coreutils
# emerge -DuNav world

_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Alucard13
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2005
Posts: 87
Location: Pisa

PostPosted: Mon Jun 09, 2008 10:04 pm    Post subject: Reply with quote

evviva.... errori su errori...
dando emerge -1u coreutils ora da un bel errore su libtool :

Code:

./libtool: line 1173: X-march=pentium4: command not found
./libtool: line 1173: X-pipe: command not found
./libtool: line 1173: X-MT: command not found
./libtool: line 1173: Xlibltdl/lt__strl.lo: No such file or directory
./libtool: line 1173: X-MD: command not found
./libtool: line 1173: X-MP: command not found
./libtool: line 1173: X-MF: command not found
./libtool: line 1173: Xlibltdl/.deps/lt__strl.Tpo: No such file or directory
./libtool: line 1173: X-c: command not found
./libtool: line 1225: Xlibltdl/lt__strl.lo: No such file or directory
./libtool: line 1230: libtool: compile: cannot determine name of library object from `': command not found
make[2]: *** [libltdl/lt__strl.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-devel/libtool-2.2.4/work/libtool-2.2.4'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-devel/libtool-2.2.4/work/libtool-2.2.4'
make: *** [all] Error 2
 *
 * ERROR: sys-devel/libtool-2.2.4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2495:  Called die
 * The specific snippet of code:
 *           emake || die "emake failed";
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-devel/libtool-2.2.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/libtool-2.2.4/temp/environment'.
 *

 * Messages for package sys-devel/libtool-2.2.4:

 *
 * ERROR: sys-devel/libtool-2.2.4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2495:  Called die
 * The specific snippet of code:
 *           emake || die "emake failed";
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-devel/libtool-2.2.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/libtool-2.2.4/temp/environment'.
 *



come lo risolvo??
_________________
Un'uomo potra' sempre sentirsi ricco se qualcuno disegnera le sue gesta!!
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Tue Jun 10, 2008 8:51 am    Post subject: Reply with quote

Alucard13 wrote:
evviva.... errori su errori...
dando emerge -1u coreutils ora da un bel errore su libtool :
come lo risolvo??


cercando sul bugzilla prima di postare sul forum: https://bugs.gentoo.org/show_bug.cgi?id=225577

/EDIT: perchè stai usando la versione ~arch di libtool??
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Fri Jun 20, 2008 1:14 pm    Post subject: Reply with quote

e io che avevo mascherato le coreutils => 6.10 ... :oops:
_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Jul 16, 2008 10:40 am    Post subject: Reply with quote

io stamattina facendo una nuova macchina ho trovato questo problema e l'ho risolto come sempre
poi però oggi mi son trovato anche con un nuovo blocco successivo: util-linux che blocca sempre le coreutils

HO RISOLTO COSI'
Code:
emerge -1 util-linux
emerge -1 coreutils
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum