Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] Broadcom cards with B43 & WPA - 2.6.24 kernel
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
iulius
n00b
n00b


Joined: 16 Mar 2008
Posts: 9

PostPosted: Sun May 18, 2008 9:21 am    Post subject: Reply with quote

Hi!
I've read this discussion and read the wiki entry for the b43 driver. my card just runs with the b43legacy driver but it's up and running and i can see my neighbours wirelesses.
anyway, when i try to connect to my wpa1 secured wireless i get the following error message:

Code:
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Trying to associate with SSID 'Netzwerk'
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 -



i'm using this conf file:
Code:

# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=2
update_config=1

network={
        ssid="Netzwerk"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        psk="my_key"
        priority=1
}

however i can't get it working. any ideas, what's wrong?

thx!
Iulius
Back to top
View user's profile Send private message
NixdorfZippaHed
n00b
n00b


Joined: 07 Nov 2004
Posts: 14
Location: PA

PostPosted: Sun May 18, 2008 10:20 pm    Post subject: Reply with quote

iulius wrote:
Hi!
I've read this discussion and read the wiki entry for the b43 driver. my card just runs with the b43legacy driver but it's up and running and i can see my neighbours wirelesses.
anyway, when i try to connect to my wpa1 secured wireless i get the following error message:

Code:
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Trying to associate with SSID 'Netzwerk'
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 -



i'm using this conf file:
Code:

# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=2
update_config=1

network={
        ssid="Netzwerk"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        psk="my_key"
        priority=1
}

however i can't get it working. any ideas, what's wrong?

thx!
Iulius


I haven't been able to get the braodcom drivers working yet, but I have ndiswrapper working on kernel 2.6.23-gentoo-r9. I used the wpa gui to connect to a wpa protected network and it produced a few different options that are not in your config. I'll paste it below. Have you tried the gui to configure your network?

Code:

network={
        ssid="DarkCrystal"
        psk="EssenceOfGelfling"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP WEP104 WEP40
}


Cheers.
Back to top
View user's profile Send private message
code933k
n00b
n00b


Joined: 30 Aug 2007
Posts: 52

PostPosted: Mon May 19, 2008 6:44 am    Post subject: Reply with quote

Posting your card series BCMxxx, kernel and used firmware would make easier our lives :wink:

BTW b43 doesn't work quite good with earlier kernels. Look at their home page. 2.6.24 should work
but latest firmware versions require higher kernels (ie. 2.6.25.x).
_________________
If gods were created by language then praying is an infinite loop.
Back to top
View user's profile Send private message
krenshala
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2006
Posts: 81
Location: Austin TX, NorAm, Sol III

PostPosted: Fri Jan 16, 2009 9:41 pm    Post subject: Reply with quote

I'd just like to throw out a thank you for this thread, as it has helped me get a BCM4318 PCMCIA card working in 2.6.26-r4.

The error about Operation not permitted I was able to fix by changing my firewall (iptables) settings to allow the wireless card to send and receive data (I hadn't unblocked it yet since it wasn't working before).

Oh, and for others that use a Passphrase for WEP: use the hex key generated from the passphrase, and if you aren't sure about which key to use pick wep_key_0 (or if you only have one key listed in the router).
_________________
krenshala
:wq
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 904
Location: Germany

PostPosted: Tue Feb 03, 2009 7:33 am    Post subject: Reply with quote

Hi people,

i use the kernel 2.6.26.
I try with howto with different firmwares, but they all not works.
Use some people the gentoo-kernel-2.6.26, with b43 broadcom module?

greating
joerg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum