Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200804-09 ] am-utils: Insecure temporary file creation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu Apr 10, 2008 9:26 pm    Post subject: [ GLSA 200804-09 ] am-utils: Insecure temporary file creatio Reply with quote

Gentoo Linux Security Advisory

Title: am-utils: Insecure temporary file creation (GLSA 200804-09)
Severity: normal
Exploitable: local
Date: April 10, 2008
Bug(s): #210158
ID: 200804-09

Synopsis

am-utils creates temporary files insecurely allowing local users to overwrite arbitrary files via a symlink attack.

Background

am-utils is a collection of utilities for use with the Berkeley Automounter.

Affected Packages

Package: net-fs/am-utils
Vulnerable: < 6.1.5
Unaffected: >= 6.1.5
Architectures: All supported architectures


Description

Tavis Ormandy discovered that, when creating temporary files, the 'expn' utility does not check whether the file already exists.

Impact

A local attacker could exploit the vulnerability via a symlink attack to overwrite arbitrary files.

Workaround

There is no known workaround at this time.

Resolution

All am-utils users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-fs/am-utils-6.1.5"


References

CVE-2008-1078
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum