Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[WPA_SUPPLICANT] WPA2 problème de config majeur [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 11:11 am    Post subject: [WPA_SUPPLICANT] WPA2 problème de config majeur [Résolu] Reply with quote

Salut tout le monde, depuis près de 1 an que je roule avec une encryption WEP et j'ai le goût de tester WPA2 avec wpa_supplicant.

J'ai fais les modifs nécessaire, sauf que ça fonctionne pas. Par contre, si je fais ma connection avec Wlassistant dans KDE ça roule nickel.

Alors est-ce que quelqu'un pourrait regarder ce qui se passe avec ma config s.v.p.

J'utilise le kernel 2.6.24-Gentoo-r4 avec le driver Iwl3945 dans le noyau.

Code:

/etc/init.d/net.wlan0 start
 * Starting wlan0
 *   Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported                                                                                                                                                                   [ ok ]th param 5 value 0x1 -
 *   Starting wpa_cli on wlan0 ...                                                                                                                                                                                                   [ ok ]
 *     Backgrounding ...

wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:17:9a:21:f8:28
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1a:70:62:40:88
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1a:70:62:40:88
wlan0: authenticate with AP 00:1a:70:62:40:88
wlan0: authenticate with AP 00:1a:70:62:40:88
wlan0: authentication with AP 00:1a:70:62:40:88 timed out
wlan0: authentication frame received from 00:1a:70:62:40:88, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1a:70:62:40:88, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1a:70:62:40:88, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1a:70:62:40:88, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1a:70:62:40:88, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1a:70:62:40:88, but not in authenticate state - ignored

ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1a:70:62:40:88
wlan0: RX authentication from 00:1a:70:62:40:88 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1a:70:62:40:88
wlan0: authentication frame received from 00:1a:70:62:40:88, but not in authenticate state - ignored
wlan0: RX AssocResp from 00:1a:70:62:40:88 (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
wlan0: disassociate(reason=3)

wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1a:70:62:40:88
wlan0: RX authentication from 00:1a:70:62:40:88 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1a:70:62:40:88
wlan0: RX AssocResp from 00:1a:70:62:40:88 (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
gentootux ~ # ifconfig -a
irda0     Lien encap:IrLAP  HWaddr 00:00:00:00
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:8
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

sit0      Lien encap:IPv6-dans-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0     Lien encap:Ethernet  HWaddr 00:1B:77:4F:4B:1A
          adr inet6: fe80::21b:77ff:fe4f:4b1a/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:2736 (2.6 Kb)

wmaster0  Lien encap:UNSPEC  HWaddr 00-1B-77-4F-4B-1A-C0-09-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


Ça c'est quand que je lance /etc/init.d/net.wlan0

Voici mes 2 fichiers de config correspondant :

Code:

cat /etc/wpa_supplicant/wpa_supplicant.conf
#ctrl_interface=/var/run/wpa_supplicant
#ctrl_interface_group=wheel
ap_scan=0
#update_config=1

network={
        ssid="gentoonet"
        psk="3zr2xbg7gentoo"
        proto=WPA2
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
        priority=5
}


Code:

gentootux ~ # cat /etc/conf.d/net
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).


#WPA_SUPPLICANT

modules=( "wpa_supplicant" )
wpa_supplicant_wlan0_="-Dwext"
config_wlan0=( "dhcp" )
##dhcpcd_wlan0="-t 30 -L - H"

#Wireless tools

##dns_domain_lo="homenetwork"
##config_eth0="dhcp"
##dhcpcd_eth0="-N"

##config_gentoonet=( "dhcp" )
##key_gentoonet="307b09e7e3979a1f4988afdb83 enc open"
##preferred_aps=( "gentoonet" )

#preup()
#{
#          if [[ ${IFACE} = "eth1" ]]; then
#               sleep 3
#         fi
#       return 0
# }


De plus, je dois vous dire que lorsque j'utilise Wlassistant j'ai dans le fichier de wpa

Code:

gentootux ~ # wpa_cli status
Selected interface 'wlan0'
bssid=00:1a:70:62:40:88
ssid=gentoonet
id=0
pairwise_cipher=CCMP
group_cipher=TKIP
key_mgmt=WPA2-PSK
wpa_state=COMPLETED
ip_address=192.168.1.102


Enfin, je dois activer l'option ASCII lors de la saisie de la clé quand je veux me brancher avec Wlasssistant...alors est-ce que c'est la source de mon problème ça ?


Last edited by d2_racing on Wed Apr 09, 2008 8:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 11:15 am    Post subject: Reply with quote

Enfin, j'ai aussi des erreurs quand je lance wpa_gui quelques fois.

Code:

[sylvain@gentootux ~]# wpa_gui
The gui comes up and then I get this:
Failed to open control connection to wpa_supplicant.
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect
PING failed - trying to reconnect


Dernière chose, même avec wpa_gui, je peux m'associer sans que j'ai pas d'adresse ip...

Je sais pas du tout ce qui se passe :evil:
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Wed Apr 09, 2008 1:48 pm    Post subject: Re: [WPA_SUPPLICANT] WPA2 problème de config majeur Reply with quote

d2_racing wrote:
Code:

cat /etc/wpa_supplicant/wpa_supplicant.conf
#ctrl_interface=/var/run/wpa_supplicant
#ctrl_interface_group=wheel
ap_scan=0
#update_config=1

network={
        ssid="gentoonet"
        psk="3zr2xbg7gentoo"
        proto=WPA2
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
        priority=5
}

Un peu au hasard :
Il me semble me souvenir que la ligne "ctrl_interface=..." est indispensable !
As-tu essayé avec un fichier de conf minimaliste ? En effet, la plupart des variables prennent des valeurs par défaut qui suffisent bien souvent. :
Code:
cat /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="gentoonet"
        psk="3zr2xbg7gentoo"
}

Si ça marche ainsi, essaie d'affiner petit à petit les réglages qui t'intéressent...
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 2:12 pm    Post subject: Reply with quote

Ouais, je vais essayer ça ce soir.

Et pour la fait que je dois entrer ma clé en ascii, est- ce que ça change quelque chose ?
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Wed Apr 09, 2008 4:07 pm    Post subject: Reply with quote

Ton fichier de config utilise le CCMP, alors que tu as mis TKIP dans la config de ton routeur, d'après ce que tu m'en as dit ;)
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 4:09 pm    Post subject: Reply with quote

Dans mon routeur, j'ai seulement l'option AES ou TKIP...
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 4:09 pm    Post subject: Reply with quote

J'ai un Linksys WRT54G version 8.0.
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Wed Apr 09, 2008 4:15 pm    Post subject: Reply with quote

Utilise AES, c'est l'algorithme d'encryption utilisé par CCMP :)
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 4:17 pm    Post subject: Reply with quote

Je vais mettre AES seulement ce soir.

Je redonne des news :)
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 5:12 pm    Post subject: Reply with quote

Quand je me connectais avec Wlassistant j'avais ceci comme info :

Code:

gentootux ~ # wpa_cli status
Selected interface 'wlan0'
bssid=00:1a:70:62:40:88
ssid=gentoonet
id=0
pairwise_cipher=CCMP
group_cipher=TKIP
key_mgmt=WPA2-PSK
wpa_state=COMPLETED
ip_address=192.168.1.102
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Apr 09, 2008 8:53 pm    Post subject: Reply with quote

J'ai changé mon routeur pour AES et tout est fonctionnel :)

Merci !

Mes configs :

Code:

sylvain@gentootux ~ $ cat /etc/conf.d/net
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).


#WPA_SUPPLICANT

modules=( "wpa_supplicant" )
wpa_supplicant_wlan0_="-Dwext"
config_wlan0=( "dhcp" )

#Wireless tools

##dns_domain_lo="homenetwork"
##config_eth0="dhcp"
##dhcpcd_eth0="-N"

##config_gentoonet=( "dhcp" )
##key_gentoonet="307b09e7e3979a1f4988afdb83 enc open"
##preferred_aps=( "gentoonet" )

#preup()
#{
#          if [[ ${IFACE} = "eth1" ]]; then
#               sleep 3
#         fi
#       return 0
# }
sylvain@gentootux ~ $


Code:

sylvain@gentootux ~ $ cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=0
#update_config=1

network={
        ssid="gentoonet"
        psk="3zr2xbg7gentoo"
        proto=WPA2
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
        priority=5
}
sylvain@gentootux ~ $




Code:

gentootux ~ # wpa_cli status
Selected interface 'wlan0'
bssid=00:1a:70:62:40:88
ssid=gentoonet
id=0
pairwise_cipher=CCMP
group_cipher=CCMP
key_mgmt=WPA2-PSK
wpa_state=COMPLETED
ip_address=192.168.1.101
gentootux ~ #
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum