Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nuovo kernel, grub fa le bizze...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Tue Apr 08, 2008 9:34 pm    Post subject: nuovo kernel, grub fa le bizze... Reply with quote

Salve,
ho aggiornato il kernel usando il vecchio .config con make oldconfig e
Code:
genkernel --menuconfig --bootloader=grub all

ho controllato grub ed /etc/fstab ed al caricamento della /root, quando parto con la nuova voce del grub, mi viene detto che /dev/sdb4 non è una partizione valida. Fin quì tutto normale se non fosse per il fatto che dando come parametro proprio /dev/sdb4, la /root viene caricata ed il sistema si avvia. Se avvio con la voce del precedente kernel, va tutto a buon fine. Vi posto le due voci del grub e l' /etc/fstab:
Code:
title=Gentoo Linux (2.6.24-gentoo-r4)
   root (hd1,1)
   kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r4  root=/dev/sdb4 ramdisk=8192 quiet init=/linuxrc splash=silent,theme:Keramik vga=791 CONSOLE=/dev/tty1 udev noscsi
   initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r4


sotto la voce del grub che avvia il sistema senza problemi:
Code:
title=Gentoo Linux (2.6.23-gentoo-r3)
   root (hd1,1)
   kernel /boot/kernel-genkernel-x86-2.6.23-gentoo-r3  root=/dev/sdb4 ramdisk=8192 quiet  init=/linuxrc splash=silent,theme:Keramik vga=791 CONSOLE=/dev/tty1 udev noscsi
   initrd /boot/initramfs-genkernel-x86-2.6.23-gentoo-r3


sotto ancora, parte dell'/etc/fstab:
Code:
/dev/sdb2      /boot      ext2   defaults,noatime   1 2
/dev/sdb4      /      ext3   noatime         0 1
/dev/sda5      swap      swap   defaults,sw      0 0

Gentoo si trova sulla seconda partizione del secondo disco e come potrete notare, le due voci del grub differiscono solo per la versione del kernel...
Da cosa può dipendere questo strano comportamento?
Grazie.
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2702
Location: Italy

PostPosted: Tue Apr 08, 2008 10:21 pm    Post subject: Reply with quote

puoi postarci un errore un po' + specifico? Solitamente grub ha un errore numerato da quello ci si arriva facilmente :D

Cmq di solito succede che non trova la partizione perchè diventa da /dev/sda a /dev/hda controlla le impostazioni atapi sata etc etc :)
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Apr 09, 2008 9:51 am    Post subject: Reply with quote

koma wrote:
puoi postarci un errore un po' + specifico? Solitamente grub ha un errore numerato da quello ci si arriva facilmente :D

Cmq di solito succede che non trova la partizione perchè diventa da /dev/sda a /dev/hda controlla le impostazioni atapi sata etc etc :)

In effetti non è un errore del grub, nel senso che il sistema si avvia ma, al momento di montare la /root, non la trova. Inserendo a mano il valore /dev/sdb4 che è però già presente nel grub ed in /etc/fstab, monta la /root e completa il caricamento del sistema. Le partizioni non sono cambiate da sda ad hda!
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Apr 09, 2008 10:11 am    Post subject: Reply with quote

Tigerwalk wrote:
koma wrote:
puoi postarci un errore un po' + specifico? Solitamente grub ha un errore numerato da quello ci si arriva facilmente :D

Cmq di solito succede che non trova la partizione perchè diventa da /dev/sda a /dev/hda controlla le impostazioni atapi sata etc etc :)

In effetti non è un errore del grub, nel senso che il sistema si avvia ma, al momento di montare la /root, non la trova. Inserendo a mano il valore /dev/sdb4 che è però già presente nel grub ed in /etc/fstab, monta la /root e completa il caricamento del sistema. Le partizioni non sono cambiate da sda ad hda!


è comunque un problema come di koma di configurazione, in quanto genkernel non sò perchè con questo kernel combina qualche casino se usi il comando oldconfig.

ciauz
_________________
se fossi un disegnatore ti disegnerei, se fossi uno scrittore ti scriverei, se fossi un inventore ti inventerei...ma sono solo un trombettista!!!
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2702
Location: Italy

PostPosted: Wed Apr 09, 2008 10:19 am    Post subject: Reply with quote

Probabilmente le partizioni non sono passate da sda ad hda ma non le vede proprio.... disabilita il supporto pata eide etc e usa solo scsi sata. Oltre all'incremento di prestazioni avrai parecchie features carine.
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Apr 09, 2008 10:58 am    Post subject: Reply with quote

@koma
avevo già disattivato pata etc. ed uso solo scsi sata. Ho anche procato a togliere la vocina noscsi dal grub ma non va...

@crisandbea
adesso provo a ricompilare a mano e vediamo se cambia qualcosa...
Tanks!
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum