Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[OO calc] virgule sur le pavé numérique [résolu partiel.]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Fri Apr 04, 2008 11:21 pm    Post subject: [OO calc] virgule sur le pavé numérique [résolu partiel.] Reply with quote

Lorsque j'étais encore sous OO 2.3.x, lorsque j'utilisais le tableur et rentrais un nombre décimal avec le pavé numérique, le "." était compris comme une virgule (donc 2.75 était compris comme le nombre 2,75). Maintenant que je suis passé comme beaucoup d'entre vous à la version 2.4, le "." m'affiche une date dans le tableur... 2.4 est formaté comme « 02/04/08 » alors que je préfèrerai 2,4... Est-ce une boulette sur les ebuild ?
Évidemment j'ai googlelisé et ai vu que l'on devait jouer sur le paramètre linguistique, mais non satisfaisant car en ce cas, le "." n'est plus remplacé par une ",". Toujours cette même recherche m'a laissé entendre une macro... mais franchement un truc sur lequel je ne devais pas me prendre la tête avant me gonfle la vie aujourd'hui... 8O
Vous auriez une solution ?

N.B. 1 : tester cela aussi bien sur la version binaire que compilée.

N.B. 2 : pas de souci avec kspread... tableur pourtant beaucoup moins abouti que OO... normalement...


Last edited by salamandrix on Sat Apr 05, 2008 2:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
VikingB
Apprentice
Apprentice


Joined: 19 May 2006
Posts: 263
Location: ~Brussels (B)

PostPosted: Sat Apr 05, 2008 7:58 am    Post subject: Reply with quote

Bonjour

Je viens d'essayer avec la OO 2.4 fraîchement installée (bin). Depuis le pavé numérique, le "." donne une ","
Mon avis : je crois que cela devrait se situer dans "Outils">Options .
Back to top
View user's profile Send private message
VikingB
Apprentice
Apprentice


Joined: 19 May 2006
Posts: 263
Location: ~Brussels (B)

PostPosted: Sat Apr 05, 2008 8:04 am    Post subject: Reply with quote

Ceci devrait t'aider :
http://forum.ubuntu-fr.org/viewtopic.php?pid=165611
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Sat Apr 05, 2008 10:55 am    Post subject: Reply with quote

J'ai récemment résolu ce "problème" pour ma mère. :P Enfin c'était sur BLAG Linux And GNU (un excellent dérivé de Fedora)... Je mets "problème" entre guillemets car il se s'agissait pas d'un problème mais d'un choix : dans le fichier /usr/share/X11/xkb/symbols/fr, il était écrit, en commentaire, que le point du pavé numérique donne un point car c'est comme cela qu'il est représenté sur le clavier français. Après tout ce n'est pas stupide... Je me demande pourquoi est-ce que l'on a pas une virgule de dessinée sur cette touche.

Bref il suffit de modifier /usr/share/X11/xkb/symbols/fr, en remplaçant, vers les lignes 389-391, "period" par "KP_Decimal". Pour que la modification prenne effet, il faut très probablement redémarrer le serveur graphique.

Sinon, il y a aussi des solutions à l'intérieur d'Open Office, mais ne préfères-tu pas que ce comportement (une virgule sur la pavé numérique) soit commun à toutes les applications ?


Last edited by Magic Banana on Sat Apr 05, 2008 2:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Sat Apr 05, 2008 2:25 pm    Post subject: Reply with quote

Bon je viens de comprendre...
Suite à un autre topic, j'ai choisi pour la disposition du clavier dans KDE l'alternative oss_latin9 afin d'avoir des "œ", seulement le tableur d'open office n'apprécie pas d'où mes problèmes avec le "." du pavé numérique non reconnu comme virgule, même si je vais jouer avec les paramètres linguistiques. Donc ce n'est pas le changement de version d'OO qui est la cause mais la disposition du clavier sous KDE. Je trouve cela un peu dommage de la part d'OO de ne pas être indépendant de l'environnement utilisé à ce niveau là (dans kspread, il n'y a pas de souci avec le "." du clavier numérique malgré le changement de disposition du clavier).
Donc pour solution j'ai les différentes possibilités :
1) revenir à la disposition par défaut pour le clavier et perdre les "œ"... chose qui m'ennuie
2) mettre une deuxième disposition de clavier et switcher dessus lorsque j'utiliserai oocalc (pourquoi pas)
3) la solution de Magic Banana que je vais tester de suite...
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Sat Apr 05, 2008 2:35 pm    Post subject: Reply with quote

En relisant mon message, je viens de me rendre compte d'une faute de frappe. Elle est maintenant corrigée : le caractère séparateur décimal est noté "KP_Decimal" et non "KP-Decimal". Désolé.
Back to top
View user's profile Send private message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Sat Apr 05, 2008 2:41 pm    Post subject: Reply with quote

Magic Banana wrote:
En relisant mon message, je viens de me rendre compte d'une faute de frappe. Elle est maintenant corrigée : le caractère séparateur décimal est noté "KP_Decimal" et non "KP-Decimal". Désolé.

Comme j'ai fait un copier coller à partir du fichier cela n'a pas eu d'incidence ;) .
Par contre la modification, malgré le redémarrage de KDE, n'a pas eu d'influence :/ Cela dit, la modification est peut-être à faire ailleurs (étant donné que j'utilise oss_latin9) donc j'essayerai un peu de voir cela un peu plus tard car là j'ai la cuisine qui m'attend pour les invités de ce soir.
Je vais donc pour le moment me contenter de la solution 2 : mettre une deuxième disposition de clavier même si c'est pas top.

Merci à tous.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum