Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gpasswd] Accès impossible à /etc/shadow (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Sat Mar 29, 2008 3:43 pm    Post subject: [gpasswd] Accès impossible à /etc/shadow (résolu) Reply with quote

Bonjour à tous,
j'ai un petit problème avec ma gentoo.

Je ne peux pas modifier les groupes d'appartenance d'un utilisateur avec la commande gpasswd, voici l'erreur :
Code:
gpasswd : impossible d'ouvrir le fichier des mots de passe cachés /etc/shadow


Les droits :
Code:

-rw------- 1 root root 558 mar 29 16:29 /etc/shadow
-rw------- 1 root root 533 mar 28 13:33 /etc/shadow-


J'avais déjà eu ce problème sur une autre machine mais impossible de me rappeler comment j'avais fait :'( .

Avez-vous des solutions ?


Last edited by SnowBear on Sun Mar 30, 2008 8:47 am; edited 1 time in total
Back to top
View user's profile Send private message
nokernel
n00b
n00b


Joined: 19 Jul 2004
Posts: 18
Location: Québec

PostPosted: Sat Mar 29, 2008 4:49 pm    Post subject: Reply with quote

Tu utilise la command gpasswd avec quelle usager?
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Sat Mar 29, 2008 4:56 pm    Post subject: Reply with quote

en root :
gpasswd -a <mon_login> <groupe>
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Sun Mar 30, 2008 7:54 am    Post subject: Reply with quote

Personne ne sait ?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Mar 30, 2008 8:19 am    Post subject: Reply with quote

Ça m'était arrivé après une récente install, mais je n'avais pas pris le temps de chercher pourquoi, j'avais autrement. Et plus tard, après une update/re-emerge de sys-apps/shadow, c'était revenu comme il faut... ;p
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Sun Mar 30, 2008 8:22 am    Post subject: Reply with quote

Hummm merci toi, tu viens de me rappeler que j'avais du faire comme ça :D .
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Sun Mar 30, 2008 8:46 am    Post subject: Reply with quote

Après réinstallation puis exécution de grpconv problème fixé ;) .
Back to top
View user's profile Send private message
nokernel
n00b
n00b


Joined: 19 Jul 2004
Posts: 18
Location: Québec

PostPosted: Sun Mar 30, 2008 2:12 pm    Post subject: Reply with quote

SnowBear wrote:
Après réinstallation puis exécution de grpconv problème fixé ;) .


vas savoir hehe
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum