Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
macchina che non effettua il reboot
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Thu Mar 27, 2008 1:11 pm    Post subject: macchina che non effettua il reboot Reply with quote

ciao a tutti,

sto installando gentoo su un notebook (toshiba tecra a5 per la precisione) che ha problemi con il reboot: ogni volta che invoco il comando reboot, il sistema esegue la sequenza di stop dei servizi, di smontaggio dei dispositivi, ecc, salvo poi arrivare alla fase di bootstrap (quella in cui viene effettuato il check della ram per capirci) in cui il pc si pianta con schermata nera come se il notebook non si accendesse nemmemo. :-(

La cosa strana e' che in windows il notebook si riavvia correttamente, cosi' come si riavvia una volta effettuate delle modifiche al bios, cosi' come si riavvia quando utilizzo memtest86 per testare la ram... :?

ho provato tutte le opzioni del comando reboot (/sbin/reboot [-n] [-w] [-d] [-f] [-i] [-k]) ma niente da fare...

qualcuno ha gia' affrontato problemi di questo tipo o ha qualche idea su come risolvere?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Mar 27, 2008 1:42 pm    Post subject: Reply with quote

reboot o halt chiamati con l'opzione -f non fanno altro che resettare la macchina senza passare per lo shutdown. Se non funzionano vuol dire che è un problema è tra kernel, acpi/dsdt e bios.
Inizia a giocare con le varie opzioni tipo specific fixup for reboot ed estensioni specifiche per toshiba/dell nella configurazione del kernel. In genere il problema si ferma li.
A naso credo che hai attiva una estensione specifica che non si adatta al tuo hardware.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Fri Mar 28, 2008 9:23 am    Post subject: Reply with quote

Il problema è che il notebook non ha un bios toshiba, bensì un bios phoenix quindi tutti i moduli presenti nel kernel sono inutili :-(

Ho provato ad abilitare e disabilitare la voce "Enable X86 board specific fixups for reboot" come hai suggerito tu ma niente da fare...

Attraverso un
Code:
cat .config | grep REBOOT

ho visto che c'è un'altra voce che ha a che fare con il reboot (impostata come "y") ma non riesco ad individuarla nel menuconfig... ho provato a disabilitarla a mano modificando il .config ma ogni volta ritorna a "y" da sola...

Ora sto provando a disabilitare tutto quello che è possibile sotto la categoria "Processor type and features" ma non ho ancora avuto fortuna...

Altre idee?
Back to top
View user's profile Send private message
BikE
Guru
Guru


Joined: 21 Dec 2004
Posts: 455
Location: Genova

PostPosted: Fri Mar 28, 2008 11:32 am    Post subject: Reply with quote

Ma con il live di gentoo funziona correttamente? Prova a fare un diff tra il config del kernel che stai utilizzando e quello del live. Guarda se spunta qualche opzione utile...
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2702
Location: Italy

PostPosted: Fri Mar 28, 2008 11:34 am    Post subject: Reply with quote

Non penso che sia questione di processore ma di hardware in generale.
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Fri Mar 28, 2008 12:41 pm    Post subject: Reply with quote

BikE wrote:
Ma con il live di gentoo funziona correttamente? Prova a fare un diff tra il config del kernel che stai utilizzando e quello del live. Guarda se spunta qualche opzione utile...

con il cd di installazione non funziona, con la live non ho mai provato... posso scaricarla e fare una prova anche con quella per vedere se cambia qualcosa...
Back to top
View user's profile Send private message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Fri Mar 28, 2008 12:46 pm    Post subject: Reply with quote

koma wrote:
Non penso che sia questione di processore ma di hardware in generale.

può essere... quindi cosa consigli di provare?
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2702
Location: Italy

PostPosted: Fri Mar 28, 2008 5:29 pm    Post subject: Reply with quote

di non smanettare sotto le opzioni per il processore ma indagare sull'hardware... tipo che mobo monti? chipset?
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Wed Apr 02, 2008 12:07 pm    Post subject: Reply with quote

Mi scuso per il silenzio piuttosto prolungato ma non ho avuto il pc sottomano nel weekend (si tratta del notebook di un amico a cui stavo facendo un favore).

Gli ultimi sviluppi hanno portato a concludere che il pc abbia qualche noia a livello hardware in quanto ha iniziato a dare problemi con il riavvio anche con il windows marchiato toshiba del cd di ripristino che dovrebbe funzionare senza problemi...

A questo punto penso che poteremo il notebook in assistenza per vedere si si riesce a sistemare...

Grazie comunque a tutti per l'attenzione ed i suggerimenti.

--
Stefano
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Apr 02, 2008 1:09 pm    Post subject: Reply with quote

direi che un update del bios potrebbe risolvere il problema ma visto che lo portate in assistenza... non posso che compiangervi (per me "tecnico"=ladro|bastardo|piantagrane|incapace ma sono un tantino estremista).
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Wed Apr 02, 2008 1:51 pm    Post subject: Reply with quote

Condivido appieno la tua visione ma del resto l'aggiornamento del bios e' una strada che ho gia' tentato senza ottenere nessun risultato... :(

Dopo i test effettuati credo di dover concludere che il problema ricade nella categoria "guasto hardware" con tutti i problemi che ne conseguono... O meglio, diciamo che non so più dove sbattere la testa e sono arrivato alla famosa "ultima spiaggia"...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum