Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Problema con le "libslang-utf8.so.1"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
quantumwire
Guru
Guru


Joined: 15 Oct 2003
Posts: 403
Location: Lausanne

PostPosted: Sun Mar 23, 2008 11:01 pm    Post subject: [Risolto] Problema con le "libslang-utf8.so.1" Reply with quote

Ciao a tutti,

da quando le libslang sono state aggiornate alla versione 2.1.3-r1
(le quali non hanno piu' come useflag 'unicode' rispetto alla loro
precedente versione 1.4.9-r2) un sacco di programmi non si
compilano piu' in quanto continuano a cercare/volere la libreria
'libslang-utf8.so.1' che veniva installata dalla precedente versione
1.4.9-r2.

Ho provato anche a fare un bel 'revdep-rebuild' ma pure lui si
lamenta dello stesso identico problema ovvero non trova le
'libslang-utf8.so.1'.

Fare un downgrade alle 'slang-1.4.9-r2' nemmeno funziona
in quanto alcuni nuovi programmi vogliono le 'slang-2.1.3-r1'
ovvero emerge si rifiuta di continuare se non installo l'ultima
versione stabile delle libslang ovvero la '2.1.3-r1'.

### ERROR MESSAGE ###
configure:20000: checking for SDL - version >= 1.2.10
configure:20092: i686-pc-linux-gnu-gcc -o conftest -O3 -march=pentium3 -mtune=pentium3 -pipe -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT conftest.c -lSDL -lpthread >&5
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: warning: libslang-utf8.so.1, needed by /usr/lib/libcaca.so.0, not found (try using -rpath or -rpath-link)
configure:20095: $? = 0
configure:20097: ./conftest
./conftest: error while loading shared libraries: libslang-utf8.so.1: cannot open shared object file: No such file or directory


Avete idee in proposito?
_________________
HOWTO 1: Spegnere il laptop!
HOWTO 2: Comprimere i DVDs!


Last edited by quantumwire on Tue Mar 25, 2008 2:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Tue Mar 25, 2008 8:19 am    Post subject: Reply with quote

Hai provato a svuotare completamente la directory temporanea di Portage (di solito /var/tmp/portage/)?

Puoi fornire qualche esempio preciso di pacchetti che non ti compilano?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
dark_knight
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2006
Posts: 112

PostPosted: Tue Mar 25, 2008 9:06 am    Post subject: Re: Problema con le "libslang-utf8.so.1" Reply with quote

quantumwire wrote:
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: warning: libslang-utf8.so.1, needed by /usr/lib/libcaca.so.0, not found (try using -rpath or -rpath-link)

Per questo errore in particolare, prova a riemergere libcaca.
_________________
You can say that you are a true Gentoo-addicted when you type emerge --update --deep --newuse happiness.
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Tue Mar 25, 2008 1:01 pm    Post subject: Reply with quote

Per caso usi LDFLAGS?

Quali sono i pacchetti che danno errore?
Back to top
View user's profile Send private message
quantumwire
Guru
Guru


Joined: 15 Oct 2003
Posts: 403
Location: Lausanne

PostPosted: Tue Mar 25, 2008 2:33 pm    Post subject: Reply with quote

Scen wrote:
Hai provato a svuotare completamente la directory temporanea di Portage (di solito /var/tmp/portage/)?

Puoi fornire qualche esempio preciso di pacchetti che non ti compilano?


Il problema era proprio la directory /var/tmp/portage che non era vuota ma conteneva
un po' di subdirectory... appena le ho cancellate manualmente tutte revdep-rebuild ha
fatto il suo lavoro e sono spariti tutti i messaggi d'errore.

Grazie ragazzi!
_________________
HOWTO 1: Spegnere il laptop!
HOWTO 2: Comprimere i DVDs!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum