Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vsftpd e router
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Mar 22, 2008 12:03 pm    Post subject: vsftpd e router Reply with quote

Buongiorno a tutti, sto disperatamente cercando di far funzionare un server ftp dietro ad un router, ma non sono ancora riuscito a farlo funzionare al 100%

all'interno della lan tutto funziona correttamente, si vede sia con un browser sia con un client ftp come gftp. il problema è che dall'esterno riesco a farli funzionare solo uno per volta. Questo è il contenuto del file /etc/vsftpd/vsftpd.conf

Code:
listen=YES
anonymous_enable=YES
local_enable=YES
write_enable=YES

pasv_enable=YES
pasv_min_port=60000
pasv_max_port=60100

dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=NO
xferlog_file=/var/log/vsftpd.log


e con questa configurazione fuziona perfettamente da browser e da shell con il comando ftp nomehost, ma non con client come gftp. il router è un di-604 della d-link, ho impostato i virtual server per le porte 20, 21 e 60000-60100, ma quando qualcuno prova a connettersi dall'esterno con gftp riceve questo messaggio:

Code:
PASV
227 Entering Passive Mode (192,168,0,132,175,66)
Impossibile creare una connessione dati: No route to host


dove 192.168.0.132 è l'ip del server nella lan. cambiando però la configurazione di vsftpd, ovvero mettendo pasv_enable=NO e commentando le due righe successive, si riesce ad accedere con gftp anche dall'esterno, che mostra questo output:

Code:
PASV
550 Permission denied.
PORT 192,168,0,159,209,51
200 PORT command successful. Consider using PASV.
LIST -aL
150 Here comes the directory listing.
226 Directory send OK.


dove 192.168.0.159 non è assolutamente un ip della mia lan, ma va beh, misteri dell'informatica. il fatto è che con questa configurazione non si riesce accedere però con un browser, nè in modo anonimo, nè con autenticazione, ogni volta si riceve l'errore 550: permission denied, e questo accade sia dall'interno sia dall'esterno della lan.

c'è qualcuno così gentile che riesce a darmi una mano e a dirmi dove sbaglio?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum