Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with portage.mask
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Fri Mar 21, 2008 10:33 pm    Post subject: Problem with portage.mask Reply with quote

hello...i would like to install kommander-3.5.9 but kdewebdev-3.5.9 is blocking it...when i try to put kdewebdev in portage.mask i am able to emerge kommader-3.5.9 just fine but when i try to 'emerge -pvNuD world' i get an error about masked dependencies because kde-base/kde is trying to pull kdewebdev-3.5.9...how can i overcome this problem??
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Sat Mar 22, 2008 2:32 am    Post subject: Reply with quote

Two issues:

1. It's package.mask, but I think you figured that out...

2. kdewebdev, AFAIK, is part of the monolithic build series. Kommander is part of the split ebuilds series. Building kdewebdev should give you kommander. Mask out kommander, and unmask kdewebdev.

poly-p man
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8138

PostPosted: Sat Mar 22, 2008 2:57 am    Post subject: Reply with quote

This issue has already been discussed in the topic "Blockers in KDE 3.4.1", where it was summarized by Headrush; and it is also covered in The KDE Configuration HOWTO.

Moved from Portage & Programming to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum