Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
проблема с сетевым интерфейсом[Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Mr_Anonymouss
n00b
n00b


Joined: 12 Mar 2008
Posts: 7

PostPosted: Thu Mar 20, 2008 5:31 am    Post subject: проблема с сетевым интерфейсом[Solved] Reply with quote

После обновления мира появилась следующая проблема: при запуске сетевого интерфейса init скриптом net.eth0 выдается следующая ошибка:
Code:
RTNETLINK answers: Invalid argument
и соответственно интерфейс не поднимается. Попробовал прописать вручную ifconfig'ом, поднимается без проблем. С чем может быть связана данная ошибка и какие возможные пути ее устранения?

Last edited by Mr_Anonymouss on Thu Mar 20, 2008 1:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
burik666
n00b
n00b


Joined: 28 Jan 2007
Posts: 51
Location: Санкт-Петербург

PostPosted: Thu Mar 20, 2008 6:27 am    Post subject: Reply with quote

Покажи /etc/conf.d/net
_________________
Linux for you
gentoo.bloodhost.ru Gentoo mirror (Russia, Saint-Petersburg)
Back to top
View user's profile Send private message
Mr_Anonymouss
n00b
n00b


Joined: 12 Mar 2008
Posts: 7

PostPosted: Thu Mar 20, 2008 6:43 am    Post subject: Reply with quote

Code:
config_eth0=( "my_ip/24" )
routes_eth0=( "default via my_gateway" )

дело не в конфиге, т.к. с аналогичными работают еще несколько серверов
Back to top
View user's profile Send private message
burik666
n00b
n00b


Joined: 28 Jan 2007
Posts: 51
Location: Санкт-Петербург

PostPosted: Thu Mar 20, 2008 8:06 am    Post subject: Reply with quote

Code:
/etc/init.d/net.eth0 restart

тоже самое говорит
_________________
Linux for you
gentoo.bloodhost.ru Gentoo mirror (Russia, Saint-Petersburg)
Back to top
View user's profile Send private message
Mr_Anonymouss
n00b
n00b


Joined: 12 Mar 2008
Posts: 7

PostPosted: Thu Mar 20, 2008 10:10 am    Post subject: Reply with quote

проблема решена. откатился на sys-apps/iproute2-2.6.22.20070710
Back to top
View user's profile Send private message
burik666
n00b
n00b


Joined: 28 Jan 2007
Posts: 51
Location: Санкт-Петербург

PostPosted: Thu Mar 20, 2008 10:40 am    Post subject: Reply with quote

у меня стоит sys-apps/iproute2-2.6.23.2007101 и все ок.
_________________
Linux for you
gentoo.bloodhost.ru Gentoo mirror (Russia, Saint-Petersburg)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum